aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-12-25 07:13:23 +0800
committerantoine <antoine@FreeBSD.org>2014-12-25 07:13:23 +0800
commit394c8df6020589b49953bc282031e29734722865 (patch)
tree5087b0038e9f1b1126aaa701f3512d2bbfc536bb /graphics
parent8b93571395a3d0373ac5212015ee7ecf3ec37842 (diff)
downloadfreebsd-ports-gnome-394c8df6020589b49953bc282031e29734722865.tar.gz
freebsd-ports-gnome-394c8df6020589b49953bc282031e29734722865.tar.zst
freebsd-ports-gnome-394c8df6020589b49953bc282031e29734722865.zip
Properly support png 1.5
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libimg/Makefile4
-rw-r--r--graphics/libimg/pkg-plist3
2 files changed, 5 insertions, 2 deletions
diff --git a/graphics/libimg/Makefile b/graphics/libimg/Makefile
index 2a4ef8c67369..b4bd9de8189f 100644
--- a/graphics/libimg/Makefile
+++ b/graphics/libimg/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= mi@aldan.algebra.com
COMMENT= Library of image format handlers for Tk4.1 and later
BUILD_DEPENDS= dtplite:${PORTSDIR}/devel/tcllib
-LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
libtiff.so:${PORTSDIR}/graphics/tiff
@@ -46,7 +46,7 @@ post-configure:
# Link with -l$l
${REINPLACE_CMD} -E \
-e 's,^SHLIB_LD_LIBS[[:space:]]*=[[:space:]]*(.*),SHLIB_LD_LIBS=\1 -l$l,' \
- -e 's,-lpng$$,-lpng15,' ${WRKSRC}/$l/Makefile
+ ${WRKSRC}/$l/Makefile
.endfor
post-install:
diff --git a/graphics/libimg/pkg-plist b/graphics/libimg/pkg-plist
index a2b8f030e4eb..7c1a64273abf 100644
--- a/graphics/libimg/pkg-plist
+++ b/graphics/libimg/pkg-plist
@@ -48,3 +48,6 @@ lib/Img/libtkimgwindow142.so.1
lib/Img/libtkimgxpm142.so.1
lib/Img/pkgIndex.tcl
lib/Img/tkimgConfig.sh
+@comment include/tkimg.h
+@comment include/tkimgDecls.h
+@comment lib/tkimgConfig.sh