aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2013-01-17 11:32:27 +0800
committerswills <swills@FreeBSD.org>2013-01-17 11:32:27 +0800
commita4e3fd6ab8eae5ab75528f600c117c541ee64b11 (patch)
tree21a89118c4f60e0218d4ed4fbb1ea08b017366ae /graphics
parent6936b60df9b2aace56f75381d3fde3082c97bedd (diff)
downloadfreebsd-ports-gnome-a4e3fd6ab8eae5ab75528f600c117c541ee64b11.tar.gz
freebsd-ports-gnome-a4e3fd6ab8eae5ab75528f600c117c541ee64b11.tar.zst
freebsd-ports-gnome-a4e3fd6ab8eae5ab75528f600c117c541ee64b11.zip
- Chase lib version changes from ilmbase and OpenEXR updates
Diffstat (limited to 'graphics')
-rw-r--r--graphics/aqsis/Makefile3
-rw-r--r--graphics/cinepaint/Makefile4
-rw-r--r--graphics/exact-image/Makefile4
-rw-r--r--graphics/fyre/Makefile4
-rw-r--r--graphics/gegl/Makefile4
-rw-r--r--graphics/gimp-gmic-plugin/Makefile3
-rw-r--r--graphics/luxrender/Makefile4
-rw-r--r--graphics/nvidia-texture-tools/Makefile4
-rw-r--r--graphics/py-openexr/Makefile3
-rw-r--r--graphics/visionworkbench/Makefile4
10 files changed, 20 insertions, 17 deletions
diff --git a/graphics/aqsis/Makefile b/graphics/aqsis/Makefile
index a9a8db4d5f3e..95f2b8455e15 100644
--- a/graphics/aqsis/Makefile
+++ b/graphics/aqsis/Makefile
@@ -8,6 +8,7 @@
PORTNAME= aqsis
PORTVERSION= 1.8.2
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-source/${PORTVERSION}
@@ -19,7 +20,7 @@ LICENSE_COMB= multi
BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison \
xsltproc:${PORTSDIR}/textproc/libxslt
-LIB_DEPENDS= IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
+LIB_DEPENDS= IlmImf:${PORTSDIR}/graphics/OpenEXR \
boost_filesystem.4:${PORTSDIR}/devel/boost-libs \
tiff.4:${PORTSDIR}/graphics/tiff \
fltk.1:${PORTSDIR}/x11-toolkits/fltk
diff --git a/graphics/cinepaint/Makefile b/graphics/cinepaint/Makefile
index 687ea4c5a644..8330fe280b90 100644
--- a/graphics/cinepaint/Makefile
+++ b/graphics/cinepaint/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cinepaint
PORTVERSION= 0.22
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/CinePaint/CinePaint-${PORTVERSION}-1
DISTNAME= ${PORTNAME}-${PORTVERSION}-1
@@ -45,7 +45,7 @@ LDFLAGS+= -L${LOCALBASE}/lib -lintl
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENEXR}
-LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
+LIB_DEPENDS+= IlmImf:${PORTSDIR}/graphics/OpenEXR \
fltk.1:${PORTSDIR}/x11-toolkits/fltk
CONFIGURE_ARGS+= --with-openexr-prefix=${LOCALBASE}
CFLAGS+= -I${LOCALBASE}/include/openEXR
diff --git a/graphics/exact-image/Makefile b/graphics/exact-image/Makefile
index ae64f17c59da..786ee03f9659 100644
--- a/graphics/exact-image/Makefile
+++ b/graphics/exact-image/Makefile
@@ -7,7 +7,7 @@
PORTNAME= exact-image
PORTVERSION= 0.8.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics perl5 python
MASTER_SITES= http://dl.exactcode.de/oss/${PORTNAME}/ LOCAL/bf
@@ -23,7 +23,7 @@ LIB_DEPENDS= agg.2:${PORTSDIR}/graphics/agg \
png15:${PORTSDIR}/graphics/png \
gif.5:${PORTSDIR}/graphics/giflib \
jasper.4:${PORTSDIR}/graphics/jasper \
- IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
+ IlmImf:${PORTSDIR}/graphics/OpenEXR \
lcms.1:${PORTSDIR}/graphics/lcms \
freetype.9:${PORTSDIR}/print/freetype2 \
expat.6:${PORTSDIR}/textproc/expat2
diff --git a/graphics/fyre/Makefile b/graphics/fyre/Makefile
index d3c5cdb4a011..ee4d573eb3e0 100644
--- a/graphics/fyre/Makefile
+++ b/graphics/fyre/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fyre
PORTVERSION= 1.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://releases.navi.cx/fyre/
@@ -36,7 +36,7 @@ CFLAGS+= -march=native -O3 -ffast-math -fomit-frame-pointer
.endif
.if ${PORT_OPTIONS:MOPENEXR}
-LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR
+LIB_DEPENDS+= IlmImf:${PORTSDIR}/graphics/OpenEXR
.else
CONFIGURE_ARGS+=--disable-openexr
.endif
diff --git a/graphics/gegl/Makefile b/graphics/gegl/Makefile
index 750494dfc7fd..1915cf6c7a1b 100644
--- a/graphics/gegl/Makefile
+++ b/graphics/gegl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gegl
PORTVERSION= 0.1.8
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.gimp.org/pub/gegl/0.1/
@@ -127,7 +127,7 @@ CONFIGURE_ARGS+=--without-lua
.endif
.if !defined(WITHOUT_OPENEXR)
-LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR
+LIB_DEPENDS+= IlmImf:${PORTSDIR}/graphics/OpenEXR
PLIST_SUB+= OPENEXR=""
.else
CONFIGURE_ARGS+=--without-openexr
diff --git a/graphics/gimp-gmic-plugin/Makefile b/graphics/gimp-gmic-plugin/Makefile
index 160423be5ab7..4ea13f98963d 100644
--- a/graphics/gimp-gmic-plugin/Makefile
+++ b/graphics/gimp-gmic-plugin/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gmic
PORTVERSION= 1.5.2.4
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME} \
SF/${PORTNAME}/old
@@ -14,7 +15,7 @@ MAINTAINER= rm@FreeBSD.org
COMMENT= GREYC's Magic Image Converter
LIB_DEPENDS= GraphicsMagick++.9:${PORTSDIR}/graphics/GraphicsMagick13 \
- IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
+ IlmImf:${PORTSDIR}/graphics/OpenEXR \
Magick++:${PORTSDIR}/graphics/ImageMagick \
avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
fftw3:${PORTSDIR}/math/fftw3 \
diff --git a/graphics/luxrender/Makefile b/graphics/luxrender/Makefile
index 97ba697d4feb..b0baa30cd8e9 100644
--- a/graphics/luxrender/Makefile
+++ b/graphics/luxrender/Makefile
@@ -7,7 +7,7 @@
PORTNAME= luxrender
PORTVERSION= 0.7.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://src.luxrender.net/lux/archive/ \
http://freebsd.nsu.ru/distfiles/luxrender/
@@ -24,7 +24,7 @@ BROKEN= does not build with boost-1.48.0
BUILD_DEPENDS= ${LOCALBASE}/lib/libfreeimage.a:${PORTSDIR}/graphics/freeimage
LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
png15:${PORTSDIR}/graphics/png \
- IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
+ IlmImf:${PORTSDIR}/graphics/OpenEXR \
HG_NODEID= 9206b3ba7011
diff --git a/graphics/nvidia-texture-tools/Makefile b/graphics/nvidia-texture-tools/Makefile
index b3fca1e5059c..8a6f5c0d0d3e 100644
--- a/graphics/nvidia-texture-tools/Makefile
+++ b/graphics/nvidia-texture-tools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nvidia-texture-tools
DISTVERSION= 2.0.8-1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= GOOGLE_CODE \
http://mirror.amdmi3.ru/distfiles/
@@ -18,7 +18,7 @@ COMMENT= Texture Tools with support for DirectX 10 texture formats
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
jpeg.11:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
- IlmImf.6:${PORTSDIR}/graphics/OpenEXR
+ IlmImf:${PORTSDIR}/graphics/OpenEXR
USE_CMAKE= yes
CMAKE_ARGS= -DNVTT_SHARED=TRUE
diff --git a/graphics/py-openexr/Makefile b/graphics/py-openexr/Makefile
index 7600617c8915..cdd310f4a308 100644
--- a/graphics/py-openexr/Makefile
+++ b/graphics/py-openexr/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openexr
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= http://excamera.com/files/ \
CHEESESHOP
@@ -16,7 +17,7 @@ DISTNAME= OpenEXR-${PORTVERSION}
MAINTAINER= jamesb-bsd@excamera.com
COMMENT= Python module for ILM's OpenEXR image format and library
-LIB_DEPENDS= IlmImf.6:${PORTSDIR}/graphics/OpenEXR
+LIB_DEPENDS= IlmImf:${PORTSDIR}/graphics/OpenEXR
post-extract:
${REINPLACE_CMD} -e 's#/usr/local#${LOCALBASE}#g' ${WRKSRC}/setup.py
diff --git a/graphics/visionworkbench/Makefile b/graphics/visionworkbench/Makefile
index 901c06e33675..00acccb94698 100644
--- a/graphics/visionworkbench/Makefile
+++ b/graphics/visionworkbench/Makefile
@@ -7,7 +7,7 @@
PORTNAME= visionworkbench
PORTVERSION= 2.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://ti.arc.nasa.gov/m/project/nasa-vision-workbench/
DISTNAME= VisionWorkbench-${PORTVERSION}
@@ -33,7 +33,7 @@ LIB_DEPENDS+= boost_thread.4:${PORTSDIR}/devel/boost-libs
LIB_DEPENDS+= boost_python.4:${PORTSDIR}/devel/boost-python-libs
LIB_DEPENDS+= gdal:${PORTSDIR}/graphics/gdal
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
-LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR
+LIB_DEPENDS+= IlmImf:${PORTSDIR}/graphics/OpenEXR
LIB_DEPENDS+= cairomm-1.0.1:${PORTSDIR}/graphics/cairomm
.include <bsd.port.pre.mk>