aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2019-01-24 13:09:48 +0800
committerlinimon <linimon@FreeBSD.org>2019-01-24 13:09:48 +0800
commitfe75b475a6f7bf46fca5415aeb922dfe779ce980 (patch)
treefa89a75b73956428bc897f157b427c0be996064d /graphics
parent7d44a24992ac1c8f3e1d347d873f56ca1e3e358f (diff)
downloadfreebsd-ports-gnome-fe75b475a6f7bf46fca5415aeb922dfe779ce980.tar.gz
freebsd-ports-gnome-fe75b475a6f7bf46fca5415aeb922dfe779ce980.tar.zst
freebsd-ports-gnome-fe75b475a6f7bf46fca5415aeb922dfe779ce980.zip
Conditionalize the dependence of libunwind to x86-only to allow building
these ports on !x86. libunwind is only available for x86; lang/ruby* already expresses this correctly. Some of the rubygems did not: for the ones that already had USE_RUBY, the dependency was overspecified in the first place. Tested for no-harm on amd64. While here, pet portlint where appropriate. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/blender/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index 207a7f0ecc74..111b757ed6b4 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -47,6 +47,14 @@ OPTIONS_SUB= yes
.include "${.CURDIR}/Makefile.options"
+# libunwind is specific to amd64/i386
+OPTIONS_EXCLUDE_aarch64= CAMERATRACK
+OPTIONS_EXCLUDE_armv6= CAMERATRACK
+OPTIONS_EXCLUDE_armv7= CAMERATRACK
+OPTIONS_EXCLUDE_powerpc= CAMERATRACK
+OPTIONS_EXCLUDE_powerpc64= CAMERATRACK
+OPTIONS_EXCLUDE_powerpcspe= CAMERATRACK
+
ALEMBIC_CMAKE_BOOL= WITH_ALEMBIC
ALEMBIC_LIB_DEPENDS= libAlembic.so:graphics/alembic
# note that this needs to be set to match alembics hdf5 option