aboutsummaryrefslogtreecommitdiffstats
path: root/java/openjdk11
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2019-07-25 06:41:40 +0800
committerglewis <glewis@FreeBSD.org>2019-07-25 06:41:40 +0800
commit4f63fe4b3071ba1ea8a34c69dd0cd62d81a79f21 (patch)
tree9238fa9c6e3862550c52631dcface6ffe9f45d9a /java/openjdk11
parentf94813d2e9b12c402bd5db3abf9d05ce6db3a95a (diff)
downloadfreebsd-ports-gnome-4f63fe4b3071ba1ea8a34c69dd0cd62d81a79f21.tar.gz
freebsd-ports-gnome-4f63fe4b3071ba1ea8a34c69dd0cd62d81a79f21.tar.zst
freebsd-ports-gnome-4f63fe4b3071ba1ea8a34c69dd0cd62d81a79f21.zip
* Add a dependency on xrandr, since the latest version uses Xrandr.h
* Set NO_CCACHE to match configure being passed --disable-ccache Fixes the build in poudriere and for people trying to use ccache PR: 239387 Submitted by: Jonathan Chen <jonc@chen.org.nz>
Diffstat (limited to 'java/openjdk11')
-rw-r--r--java/openjdk11/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/java/openjdk11/Makefile b/java/openjdk11/Makefile
index d545e9912e87..3a32b4788455 100644
--- a/java/openjdk11/Makefile
+++ b/java/openjdk11/Makefile
@@ -25,12 +25,14 @@ LIB_DEPENDS= libasound.so:audio/alsa-lib \
libpng.so:graphics/png
USES= compiler:features gmake iconv jpeg pkgconfig
-USE_XORG= x11 xext xi xrender xt xtst
+USE_XORG= x11 xext xi xrandr xrender xt xtst
USE_GITHUB= yes
GH_ACCOUNT= battleblow
GH_PROJECT= openjdk-jdk11u
+NO_CCACHE= yes
+
_MAKE_JOBS= #
MAKE_ENV= LANG="C" \
LC_ALL="C" \