aboutsummaryrefslogtreecommitdiffstats
path: root/lang/perl5.12/Makefile
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2009-11-03 00:50:41 +0800
committerskv <skv@FreeBSD.org>2009-11-03 00:50:41 +0800
commit576fb990c2b75718b8a6174309af8a649ebae643 (patch)
tree5fb4dbee1c4396ef2cb74ea20774a55ac23723b4 /lang/perl5.12/Makefile
parentfe3c8b40d4d54289696578e5dce652b35cab1c86 (diff)
downloadfreebsd-ports-gnome-576fb990c2b75718b8a6174309af8a649ebae643.tar.gz
freebsd-ports-gnome-576fb990c2b75718b8a6174309af8a649ebae643.tar.zst
freebsd-ports-gnome-576fb990c2b75718b8a6174309af8a649ebae643.zip
- Fix behaviour of USE_PERL option when it is "off"
- Add PORTSCOUT variable
Diffstat (limited to 'lang/perl5.12/Makefile')
-rw-r--r--lang/perl5.12/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/lang/perl5.12/Makefile b/lang/perl5.12/Makefile
index e19a12ad8d7e..b252b8e53272 100644
--- a/lang/perl5.12/Makefile
+++ b/lang/perl5.12/Makefile
@@ -32,6 +32,8 @@ OPTIONS= DEBUGGING "Build with debugging support" off \
SITECUSTOMIZE "Run-time customization of @INC" off \
USE_PERL "Rewrite links in /usr/bin" on
+PORTSCOUT= limitw:1,even
+
PERL_VERSION= 5.10.1
PERL_ARCH= mach
SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VERSION}
@@ -138,6 +140,12 @@ CONFIGURE_ARGS+= -Dusemultiplicity=y
CONFIGURE_ARGS+= -Dusesitecustomize
.endif
+.if defined(WITH_USE_PERL)
+LINK_USRBIN= yes
+.else
+LINK_USRBIN= no
+.endif
+
NO_LATEST_LINK= yes
.if defined(WITH_GDBM)
@@ -161,6 +169,7 @@ post-patch:
-e 's|%%PERL_VERSION%%|${PERL_VERSION}|g;' \
-e 's|%%PERL_ARCH%%|${PERL_ARCH}|g;' \
-e 's|%%MAKE_CONF%%|${__MAKE_CONF}|g;' \
+ -e 's|%%LINK_USRBIN%%|${LINK_USRBIN}|g;' \
${FILESDIR}/use.perl \
> ${WRKDIR}/use.perl
${SED} -e 's|%%PERL%%|${PERL}|g; s|%%PERL_VERSION%%|${PERL_VERSION}|g; s|%%PKGNAME%%|${PKGNAME}|g' \
@@ -198,9 +207,7 @@ post-install:
${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP} -m ${NOBINMODE} \
${BSDPAN_WRKSRC}/${files} ${BSDPAN_DEST}/${files}
.endfor
-.if defined(WITH_USE_PERL)
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.endif
test: build
@(cd ${WRKSRC}; make test)