aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python31/files
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-04-22 20:14:26 +0800
committerkoobs <koobs@FreeBSD.org>2014-04-22 20:14:26 +0800
commit8dd14dc444bdc9c01e7e57c63e6b0b20045c92a8 (patch)
tree2226051bf99bde369767be57f56156ee325743e8 /lang/python31/files
parent00bd427fc1d02bf17f78e3ffbafa65e2ca699ff2 (diff)
downloadfreebsd-ports-gnome-8dd14dc444bdc9c01e7e57c63e6b0b20045c92a8.tar.gz
freebsd-ports-gnome-8dd14dc444bdc9c01e7e57c63e6b0b20045c92a8.tar.zst
freebsd-ports-gnome-8dd14dc444bdc9c01e7e57c63e6b0b20045c92a8.zip
lang/python{31,32,33}: Fix stage/package as non-root
Copy the second part of a change previously made to python27 [1], to python31, python32 and python33. This fixes staging and packaging of these ports by a non-root user by running ranlib on the archive prior to it being installed read-only. While I'm here: - python27: Add breadcrumbs and references to the patch header - python34: Update breadcrumbs and references to the patch header [1] https://svnweb.freebsd.org/ports?view=revision&revision=350207 Submitted by: antoine Reviewed by: kwm, sbz
Diffstat (limited to 'lang/python31/files')
-rw-r--r--lang/python31/files/patch-Makefile.pre.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/lang/python31/files/patch-Makefile.pre.in b/lang/python31/files/patch-Makefile.pre.in
new file mode 100644
index 000000000000..1979cfa34049
--- /dev/null
+++ b/lang/python31/files/patch-Makefile.pre.in
@@ -0,0 +1,16 @@
+# Description: Run ranlib before installing the library read-only
+# Submitted by: antoine@ (r350207)
+# TODO: Upstream
+
+--- ./Makefile.pre.in.orig 2014-04-20 23:22:37.435954278 +1000
++++ ./Makefile.pre.in 2014-04-20 23:23:10.767071278 +1000
+@@ -985,8 +985,8 @@
+ if test "$(SO)" = .dll; then \
+ $(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBPL) ; \
+ else \
++ $(RANLIB) $(LIBRARY) ; \
+ $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
+- $(RANLIB) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
+ fi; \
+ else \
+ echo Skip install of $(LIBRARY) - use make frameworkinstall; \