aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python31/files
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python31/files')
-rw-r--r--lang/python31/files/patch-Makefile.pre.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/lang/python31/files/patch-Makefile.pre.in b/lang/python31/files/patch-Makefile.pre.in
new file mode 100644
index 000000000000..1979cfa34049
--- /dev/null
+++ b/lang/python31/files/patch-Makefile.pre.in
@@ -0,0 +1,16 @@
+# Description: Run ranlib before installing the library read-only
+# Submitted by: antoine@ (r350207)
+# TODO: Upstream
+
+--- ./Makefile.pre.in.orig 2014-04-20 23:22:37.435954278 +1000
++++ ./Makefile.pre.in 2014-04-20 23:23:10.767071278 +1000
+@@ -985,8 +985,8 @@
+ if test "$(SO)" = .dll; then \
+ $(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBPL) ; \
+ else \
++ $(RANLIB) $(LIBRARY) ; \
+ $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
+- $(RANLIB) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
+ fi; \
+ else \
+ echo Skip install of $(LIBRARY) - use make frameworkinstall; \