aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-01-29 17:19:45 +0800
committerknu <knu@FreeBSD.org>2002-01-29 17:19:45 +0800
commit19d3130df9cdb4623804cf7be13f1ba367a15191 (patch)
tree36fb2f86cb27528f44d6855e2ab12ed13fbb61e8 /lang
parent4b2d2278de71e9e96ad617179d9de99c457b96c1 (diff)
downloadfreebsd-ports-gnome-19d3130df9cdb4623804cf7be13f1ba367a15191.tar.gz
freebsd-ports-gnome-19d3130df9cdb4623804cf7be13f1ba367a15191.tar.zst
freebsd-ports-gnome-19d3130df9cdb4623804cf7be13f1ba367a15191.zip
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command.
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby16_static/Makefile4
-rw-r--r--lang/ruby_static/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/lang/ruby16_static/Makefile b/lang/ruby16_static/Makefile
index 8b0fffe75c24..bf17e78ff910 100644
--- a/lang/ruby16_static/Makefile
+++ b/lang/ruby16_static/Makefile
@@ -80,9 +80,9 @@ do-extract:
${CP} -RPp $$extdir ${WRKSRC}/ext/
.endfor
.if defined(STATIC)
- ${ECHO} "option nodynamic" > ${WRKSRC}/ext/Setup
+ ${ECHO_CMD} "option nodynamic" > ${WRKSRC}/ext/Setup
.else
- ${ECHO} "#option nodynamic" > ${WRKSRC}/ext/Setup
+ ${ECHO_CMD} "#option nodynamic" > ${WRKSRC}/ext/Setup
.endif
(cd ${WRKSRC}/ext && \
for x in *; do [ -d $$x ] && echo $$x >> Setup; done)
diff --git a/lang/ruby_static/Makefile b/lang/ruby_static/Makefile
index 8b0fffe75c24..bf17e78ff910 100644
--- a/lang/ruby_static/Makefile
+++ b/lang/ruby_static/Makefile
@@ -80,9 +80,9 @@ do-extract:
${CP} -RPp $$extdir ${WRKSRC}/ext/
.endfor
.if defined(STATIC)
- ${ECHO} "option nodynamic" > ${WRKSRC}/ext/Setup
+ ${ECHO_CMD} "option nodynamic" > ${WRKSRC}/ext/Setup
.else
- ${ECHO} "#option nodynamic" > ${WRKSRC}/ext/Setup
+ ${ECHO_CMD} "#option nodynamic" > ${WRKSRC}/ext/Setup
.endif
(cd ${WRKSRC}/ext && \
for x in *; do [ -d $$x ] && echo $$x >> Setup; done)