aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2006-05-17 04:53:13 +0800
committerehaupt <ehaupt@FreeBSD.org>2006-05-17 04:53:13 +0800
commitd980b824a4f328ff5307b69d451f56c902dd802d (patch)
treed2e5bfa649ef32e43aafe15e3b8778a816f41bca /lang
parent03b9f18f0a6160abc4f5b8def31f7e54f4737bdd (diff)
downloadfreebsd-ports-gnome-d980b824a4f328ff5307b69d451f56c902dd802d.tar.gz
freebsd-ports-gnome-d980b824a4f328ff5307b69d451f56c902dd802d.tar.zst
freebsd-ports-gnome-d980b824a4f328ff5307b69d451f56c902dd802d.zip
This port now respects CFLAGS. Since 'gcc' is hardcoded in a really nasty way
CC still remains unrespected. PR: 96778 Submitted by: Gabor Kovesdan <gabor.kovesdan@t-hosting.hu> Approved by: Berend de Boer <berend@pobox.com> (maintainer)
Diffstat (limited to 'lang')
-rw-r--r--lang/smarteiffel/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/lang/smarteiffel/Makefile b/lang/smarteiffel/Makefile
index c5fd8247b391..445a16c0c44e 100644
--- a/lang/smarteiffel/Makefile
+++ b/lang/smarteiffel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= smarteiffel
DISTVERSION= 1.2r6
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://except.com.ar/downloads/smarteiffel/
DISTNAME= SmartEiffel-${DISTVERSION}
@@ -30,6 +31,12 @@ PLIST_SUB+= PORTVERSION=${DISTVERSION}
SUB_FILES= pkg-install pkg-message
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|^.*c_compiler_options:.*$$|c_compiler_options: ${CFLAGS}|' \
+ -e 's|^.*cpp_compiler_options:.*$$|cpp_compiler_options: ${CXXFLAGS}|' \
+ ${WRKSRC}/install/gcc.rc
+
# Make sure we can set the symbolic link SmartEiffel
# to the actual release directory.
do-install: