aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/smarteiffel/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/lang/smarteiffel/Makefile b/lang/smarteiffel/Makefile
index c5fd8247b391..445a16c0c44e 100644
--- a/lang/smarteiffel/Makefile
+++ b/lang/smarteiffel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= smarteiffel
DISTVERSION= 1.2r6
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://except.com.ar/downloads/smarteiffel/
DISTNAME= SmartEiffel-${DISTVERSION}
@@ -30,6 +31,12 @@ PLIST_SUB+= PORTVERSION=${DISTVERSION}
SUB_FILES= pkg-install pkg-message
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|^.*c_compiler_options:.*$$|c_compiler_options: ${CFLAGS}|' \
+ -e 's|^.*cpp_compiler_options:.*$$|cpp_compiler_options: ${CXXFLAGS}|' \
+ ${WRKSRC}/install/gcc.rc
+
# Make sure we can set the symbolic link SmartEiffel
# to the actual release directory.
do-install: