aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2016-11-28 01:00:08 +0800
committerdbn <dbn@FreeBSD.org>2016-11-28 01:00:08 +0800
commitde8be9930a39a62799c90cfbe165ac5495074746 (patch)
treed47ccdb7a554ac0b8b8399fa8a240b8f4abf36ad /lang
parent15f0e3bb987368438da100ecc38eabd8352189be (diff)
downloadfreebsd-ports-gnome-de8be9930a39a62799c90cfbe165ac5495074746.tar.gz
freebsd-ports-gnome-de8be9930a39a62799c90cfbe165ac5495074746.tar.zst
freebsd-ports-gnome-de8be9930a39a62799c90cfbe165ac5495074746.zip
USES=mono: simplify EXTRACT_ONLY, fix nuget-extract [1]
- Instead of excluding the specific packages added to DISTFILES (but only for FreeBSD 9+), exclude all files with a '.nupkg' extension. - Move the nuget-extract command to be before post-extract, to allow the port's post-extract command to move packages around audio/libgpod-sharp: add port for mono bindings for libgpod - audio/libgpod: [2] - USE_GNOME: add missing dependency - Remove mono files from pkg-plist (now in audio/libgpod-sharp) - Allow relevant variables to be overridden - Fix MONO options - Patch source to allow building with modern mono - Avoid post-install target for slave ports. devel/monodevelop: update to 4.6.2.7 - Update nuget package Fantomas to 2.4.0 (latest at time of monodevelop's release). - Downgrade nuget package FSharp.Compiler.CodeDom (per paket's specification) - LICENSE: Add license of LGPL21 - LICENSE_FILE: Add license file from source - PORTSCOUT: Avoid checking alpha releases (aka x.y.0.z releases) games/openra: simplify post-extract [3] - USES=mono:nuget allow overridding of NUGET_PACKAGEDIR - Set NUGET_PACKAGEDIR to correct location, fix patching accordingly lang/fsharp: update to 4.6.2.7 ChangeLog: - Fix #639: Problems with F# scripts on Mono - Fix FSharp.Compiler.Tools targets for .NET Core usage - Fix FSharp.Compiler.Tools package dependencies lang/mono: update to 4.6.2.7 Mono 4.6.2 is the 1st service release to the 4.6 series. Changes: - LICENSE: Add license of MIT - LICENSE_FILE: Add license file from source - PORTSCOUT: Avoid checking alpha releases (aka x.y.0.z releases) Bug fixes: - #44708 - "TrustFailure (The authentication or decryption has failed.) ... Invalid certificate received from server." with "Error code: 0x5" or "Error code: 0xffffffff800b010f" when attempting to access HTTPS servers on ports other than 443 - #39832 - SIGSEGV when running roslyn multimedia/banshee: bump port revision. - Update missing port dependencies - Convert to use option helpers - OPTIONS: Add APPLEDEV (missing dependency added) - LICENSE: Add MIT license - LICENSE_FILE: Add license file from source - PORTSCOUT: Skip alpha release (2.9.1) x11-toolkits/gnome-sharp20: fix port dependencies - Add missing dependencies - Convert post-patch to shebangfix - LICENSE: add LGPL21 license - LICENSE_FILE: use license file from source - MKAE_JOBS_UNSAFE: remove, does appear to work x11-toolkits/gtk-sharp20: update to 2.12.42. PR: 214680 [2] PR: 214681 Suggested by: jbeich [1] Submitted by: jbeich [3] Approved by: avilla (maintainer; timeout) [2]
Diffstat (limited to 'lang')
-rw-r--r--lang/fsharp/Makefile2
-rw-r--r--lang/fsharp/distinfo6
-rw-r--r--lang/mono/Makefile8
-rw-r--r--lang/mono/distinfo6
4 files changed, 12 insertions, 10 deletions
diff --git a/lang/fsharp/Makefile b/lang/fsharp/Makefile
index df5ec829bdda..59586e44f060 100644
--- a/lang/fsharp/Makefile
+++ b/lang/fsharp/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= fsharp
-PORTVERSION= 4.0.1.15
+PORTVERSION= 4.0.1.20
CATEGORIES= lang
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
diff --git a/lang/fsharp/distinfo b/lang/fsharp/distinfo
index f1e79cc82856..c4b37e880ce5 100644
--- a/lang/fsharp/distinfo
+++ b/lang/fsharp/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1477322407
+TIMESTAMP = 1479572291
SHA256 (fsharp.compiler.tools.4.0.1.3.nupkg) = 98a8792f59f4c9aa7ea02ab96644b71cf5dfe06d51fde0db1b0fe8373bee1ee4
SIZE (fsharp.compiler.tools.4.0.1.3.nupkg) = 6323760
SHA256 (fsharp.data.2.2.5.nupkg) = 449cba49c2567b0b1f27d39c0aaaab73607893072809a81563598b06e63234b1
@@ -15,5 +15,5 @@ SHA256 (system.collections.immutable.1.2.0.nupkg) = 7c9eec8208414eebce34f3af5c94
SIZE (system.collections.immutable.1.2.0.nupkg) = 300738
SHA256 (system.reflection.metadata.1.4.1-beta-24227-04.nupkg) = 0f077b4184d04f7db02e41169b9471e7c630c7dc873398f12eaf70b7a00a7993
SIZE (system.reflection.metadata.1.4.1-beta-24227-04.nupkg) = 435719
-SHA256 (fsharp-fsharp-4.0.1.15_GH0.tar.gz) = 59dd17ca62d1a91f124b3cce8522bd01855ee15abf5ad38ad5d7b6b607a01f45
-SIZE (fsharp-fsharp-4.0.1.15_GH0.tar.gz) = 37324140
+SHA256 (fsharp-fsharp-4.0.1.20_GH0.tar.gz) = 380fe581d1ad99e32c8dc5974c764d90681f31dcbb1c67eb43870f524a9d0209
+SIZE (fsharp-fsharp-4.0.1.20_GH0.tar.gz) = 37326450
diff --git a/lang/mono/Makefile b/lang/mono/Makefile
index d75ab61484ea..0aac950e6095 100644
--- a/lang/mono/Makefile
+++ b/lang/mono/Makefile
@@ -2,14 +2,16 @@
# $FreeBSD$
PORTNAME= mono
-PORTVERSION= 4.6.1.5
-PORTREVISION= 2
+PORTVERSION= 4.6.2.7
CATEGORIES= lang
MASTER_SITES= http://download.mono-project.com/sources/${PORTNAME}/
MAINTAINER= mono@FreeBSD.org
COMMENT= Open source implementation of .NET Development Framework
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
BUILD_DEPENDS= p5-XML-Parser>=0:textproc/p5-XML-Parser \
bash:shells/bash
LIB_DEPENDS= libinotify.so:devel/libinotify
@@ -22,7 +24,6 @@ USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/mono-${PORTVERSION:R}
CONFIGURE_ARGS= --disable-dtrace
-
CONFIGURE_ENV= ac_cv_header_sys_inotify_h=no
# Set location for .wapi creation.
@@ -36,6 +37,7 @@ MAKE_ENV= MONO_SHARED_DIR="${MONO_SHARED_DIR}" \
LC_ALL=C TZ=UTC
ONLY_FOR_ARCHS= i386 amd64 powerpc
+PORTSCOUT= ^\d+\.\d+.[1-9]\d*
.include <bsd.port.pre.mk>
diff --git a/lang/mono/distinfo b/lang/mono/distinfo
index d4620e27d103..3af1be0908bf 100644
--- a/lang/mono/distinfo
+++ b/lang/mono/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1476285918
-SHA256 (mono-4.6.1.5.tar.bz2) = 3871ee72bdfc2ea5d636ffff22cf49ae6bac7c4a4f3d687214dd8ac236bbf7c3
-SIZE (mono-4.6.1.5.tar.bz2) = 83174665
+TIMESTAMP = 1479537297
+SHA256 (mono-4.6.2.7.tar.bz2) = b69ead7db7590277630685f3fcad84a5ac2f83e40563f0dc8cf139b10cbe6b31
+SIZE (mono-4.6.2.7.tar.bz2) = 83271441