aboutsummaryrefslogtreecommitdiffstats
path: root/math/gretl/files
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2003-07-07 15:18:00 +0800
committerdaichi <daichi@FreeBSD.org>2003-07-07 15:18:00 +0800
commit8cc811a2c0ac1d9d608cb43e6c0019ea431a185f (patch)
treea9516ee21cce62f64a0f04b70169ecccba84eacd /math/gretl/files
parent524f56c131f5691621d6595ca324f8a3c0b1e4c5 (diff)
downloadfreebsd-ports-gnome-8cc811a2c0ac1d9d608cb43e6c0019ea431a185f.tar.gz
freebsd-ports-gnome-8cc811a2c0ac1d9d608cb43e6c0019ea431a185f.tar.zst
freebsd-ports-gnome-8cc811a2c0ac1d9d608cb43e6c0019ea431a185f.zip
update misc/gretl: 1.0.8 --> 1.0.9
PR: 52717 Submitted by: KATO Tsuguru <tkato@prontomail.com> (maintainer)
Diffstat (limited to 'math/gretl/files')
-rw-r--r--math/gretl/files/patch-configure.in47
-rw-r--r--math/gretl/files/patch-lib::Makefile.in28
2 files changed, 58 insertions, 17 deletions
diff --git a/math/gretl/files/patch-configure.in b/math/gretl/files/patch-configure.in
index 878856ca23be..68d83eb1fac6 100644
--- a/math/gretl/files/patch-configure.in
+++ b/math/gretl/files/patch-configure.in
@@ -1,6 +1,34 @@
---- configure.in.orig Wed Apr 9 01:11:09 2003
-+++ configure.in Mon Apr 14 15:16:28 2003
-@@ -417,7 +417,7 @@
+--- configure.in.orig Fri May 2 00:17:37 2003
++++ configure.in Fri May 23 12:31:12 2003
+@@ -169,6 +169,16 @@
+ fi,
+ try_gmp=yes)
+
++AC_ARG_WITH(lapack,
++[ --with-lapack Use LAPACK library [default=auto]],
++if test "x${withval}" = "xno"
++then
++ try_lapack=no
++else
++ try_lapack=yes
++fi,
++try_lapack=yes)
++
+ AC_ARG_WITH(x-12-arima,
+ [ --with-x-12-arima include X-12-ARIMA support [default=yes]],
+ if test "${withval}" = "no"
+@@ -277,7 +287,9 @@
+ *darwin*) LAPACK_LIBS="-Wl,-framework -Wl,vecLib"
+ ;;
+ esac
+-AM_PATH_LAPACK(, have_lapack="yes")
++if test x"${try_lapack}" != xno ; then
++ AM_PATH_LAPACK(, have_lapack="yes")
++fi
+
+ dnl
+ dnl Check for gnuplot, and its PNG capacity
+@@ -392,7 +404,7 @@
dnl Check for libpng
dnl
if test ${png_comments} = yes && test ${have_gtk} = "2.0" ; then
@@ -9,3 +37,16 @@
png_failed="no",
png_failed="yes"
)
+@@ -557,12 +569,6 @@
+ echo "
+ Please install libxml and then reconfigure gretl.
+ libxml is available from http://xmlsoft.org/
+-"
+-
+-elif test "${have_lapack}" = "no" ; then
+-echo "
+-Please install lapack and then reconfigure gretl.
+-Lapack is available from http://www.netlib.org/lapack/
+ "
+
+ else
diff --git a/math/gretl/files/patch-lib::Makefile.in b/math/gretl/files/patch-lib::Makefile.in
index 78167abd2528..ab1acc2f18d7 100644
--- a/math/gretl/files/patch-lib::Makefile.in
+++ b/math/gretl/files/patch-lib::Makefile.in
@@ -1,7 +1,7 @@
---- lib/Makefile.in.orig Mon Apr 21 23:24:57 2003
-+++ lib/Makefile.in Sun May 4 03:12:41 2003
-@@ -16,6 +16,11 @@
- GMP_LIBS = @GMP_LIBS@
+--- lib/Makefile.in.orig Sun May 25 04:04:32 2003
++++ lib/Makefile.in Tue May 27 09:33:13 2003
+@@ -17,6 +17,11 @@
+ FLIB = @FLIB@
have_gtk = @have_gtk@
+datadir = @datadir@
@@ -12,7 +12,7 @@
ifeq ($(INSTALL_PROGRAM),)
INSTALL_PROGRAM = $(INSTALL) -m 755
endif
-@@ -30,7 +35,7 @@
+@@ -31,7 +36,7 @@
libdir = $(prefix)/lib
includedir = $(prefix)/include/gretl
aclocaldir = $(prefix)/share/aclocal
@@ -21,16 +21,16 @@
INSTALLDIRS = $(libdir) $(includedir) $(aclocaldir)
-@@ -44,7 +49,7 @@
- INSTALL_CFG = install-cfg-old
- endif
+@@ -47,7 +52,7 @@
+
+ # The LIBS line may need FLIB (-lf2c or equivalent) at some point
-LIBS = -lm -ldl -L/usr/local/lib -lz $(XML_LIBS) $(GLIB_LIBS) $(GMP_LIBS)
+LIBS = -lm -lz $(XML_LIBS) $(GLIB_LIBS) $(GMP_LIBS) $(INTL_LIBS)
#### End of system configuration section. ####
-@@ -79,7 +84,7 @@
+@@ -83,7 +88,7 @@
LIBTOOL = ../libtool
@@ -39,12 +39,12 @@
COMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS)
-@@ -89,7 +94,7 @@
+@@ -93,7 +98,7 @@
- $(LIBGRETL): $(OBJS) $(LOBJS) $(CEPHES_OBJ) $(CEPHES_LOBJ)
- $(LIBTOOL) --mode=link $(CC) -o $@ $(LOBJS) $(CEPHES_LOBJ) \
-- -rpath $(prefix)/lib $(LIBS) -version-info 0:7:0
-+ -rpath $(prefix)/lib $(LIBS) -version-info 0:7:0 $(LDFLAGS)
+ $(LIBGRETL): $(OBJS) $(LOBJS) $(AUX_OBJ) $(AUX_LOBJ)
+ $(LIBTOOL) --mode=link $(CC) -o $@ $(LOBJS) $(AUX_LOBJ) \
+- -rpath $(prefix)/lib $(LIBS) -version-info 0:8:0
++ -rpath $(prefix)/lib $(LIBS) -version-info 0:8:0 $(LDFLAGS)
-include $(OBJS:.o=.d)