aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2019-08-25 08:00:54 +0800
committeryuri <yuri@FreeBSD.org>2019-08-25 08:00:54 +0800
commit8135da3da9feb526b090d8101b2d9595c9760311 (patch)
treee93a9386da8a5abc8e4a03472645ac8df8c1d680 /math
parenta89d18869738c65978626a555828710a7006bd2a (diff)
downloadfreebsd-ports-gnome-8135da3da9feb526b090d8101b2d9595c9760311.tar.gz
freebsd-ports-gnome-8135da3da9feb526b090d8101b2d9595c9760311.tar.zst
freebsd-ports-gnome-8135da3da9feb526b090d8101b2d9595c9760311.zip
New port: math/hpipm: High-performance interior-point-method QP solvers
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/hpipm/Makefile20
-rw-r--r--math/hpipm/distinfo3
-rw-r--r--math/hpipm/files/patch-CMakeLists.txt11
-rw-r--r--math/hpipm/pkg-descr8
-rw-r--r--math/hpipm/pkg-plist61
6 files changed, 104 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index aebf31802002..00fbf9828b9b 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -277,6 +277,7 @@
SUBDIR += hexcalc
SUBDIR += hipmcl
SUBDIR += hmat-oss
+ SUBDIR += hpipm
SUBDIR += hs-Agda
SUBDIR += hs-semigroups
SUBDIR += ignition-math
diff --git a/math/hpipm/Makefile b/math/hpipm/Makefile
new file mode 100644
index 000000000000..d29d4ea76854
--- /dev/null
+++ b/math/hpipm/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= hpipm
+DISTVERSION= 0.1.0-80
+DISTVERSIONSUFFIX= -g8679589
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= High-performance interior-point-method QP solvers
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= blasfeo>0:math/blasfeo
+
+USES= cmake localbase
+USE_GITHUB= yes
+GH_ACCOUNT= giaf
+
+.include <bsd.port.mk>
diff --git a/math/hpipm/distinfo b/math/hpipm/distinfo
new file mode 100644
index 000000000000..f06cc4af5164
--- /dev/null
+++ b/math/hpipm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1566690260
+SHA256 (giaf-hpipm-0.1.0-80-g8679589_GH0.tar.gz) = 293c068d79e32d9b872ba03c10685438036944985bdcc19fe068133e3a371f83
+SIZE (giaf-hpipm-0.1.0-80-g8679589_GH0.tar.gz) = 1454937
diff --git a/math/hpipm/files/patch-CMakeLists.txt b/math/hpipm/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..f79705b6577a
--- /dev/null
+++ b/math/hpipm/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2019-08-24 23:47:04 UTC
++++ CMakeLists.txt
+@@ -228,7 +228,7 @@ install(TARGETS hpipm EXPORT hpipmConfig
+ ARCHIVE DESTINATION lib
+ RUNTIME DESTINATION bin)
+
+-install(EXPORT hpipmConfig DESTINATION cmake)
++install(EXPORT hpipmConfig DESTINATION lib/cmake/hpipm)
+
+ file(GLOB_RECURSE HPIPM_HEADERS "include/*.h")
+ install(FILES ${HPIPM_HEADERS} DESTINATION ${HPIPM_HEADERS_INSTALLATION_DIRECTORY})
diff --git a/math/hpipm/pkg-descr b/math/hpipm/pkg-descr
new file mode 100644
index 000000000000..d2834968964c
--- /dev/null
+++ b/math/hpipm/pkg-descr
@@ -0,0 +1,8 @@
+This is HPIPM, a high-performance interior-point method solver for dense,
+optimal control- and tree-structured convex quadratic programs. It provides
+efficient implementations of dense and structure-exploiting algorithms to solve
+small to medium scale problems arising in model predictive control and embedded
+optimization in general and it relies on the high-performance linear algebra
+package BLASFEO.
+
+WWW: https://github.com/giaf/hpipm
diff --git a/math/hpipm/pkg-plist b/math/hpipm/pkg-plist
new file mode 100644
index 000000000000..f35bc2bbd4e3
--- /dev/null
+++ b/math/hpipm/pkg-plist
@@ -0,0 +1,61 @@
+include/hpipm_aux_string.h
+include/hpipm_common.h
+include/hpipm_d_cond.h
+include/hpipm_d_cond_aux.h
+include/hpipm_d_core_qp_ipm.h
+include/hpipm_d_core_qp_ipm_aux.h
+include/hpipm_d_dense_qp.h
+include/hpipm_d_dense_qp_dim.h
+include/hpipm_d_dense_qp_ipm.h
+include/hpipm_d_dense_qp_kkt.h
+include/hpipm_d_dense_qp_res.h
+include/hpipm_d_dense_qp_sol.h
+include/hpipm_d_ocp_qp.h
+include/hpipm_d_ocp_qp_dim.h
+include/hpipm_d_ocp_qp_ipm.h
+include/hpipm_d_ocp_qp_kkt.h
+include/hpipm_d_ocp_qp_res.h
+include/hpipm_d_ocp_qp_sol.h
+include/hpipm_d_ocp_qp_utils.h
+include/hpipm_d_part_cond.h
+include/hpipm_d_tree_ocp_qp.h
+include/hpipm_d_tree_ocp_qp_dim.h
+include/hpipm_d_tree_ocp_qp_ipm.h
+include/hpipm_d_tree_ocp_qp_kkt.h
+include/hpipm_d_tree_ocp_qp_res.h
+include/hpipm_d_tree_ocp_qp_sol.h
+include/hpipm_m_dense_qp.h
+include/hpipm_m_dense_qp_dim.h
+include/hpipm_m_ocp_qp.h
+include/hpipm_m_ocp_qp_ipm_hard.h
+include/hpipm_m_ocp_qp_kkt.h
+include/hpipm_s_cond.h
+include/hpipm_s_cond_aux.h
+include/hpipm_s_core_qp_ipm.h
+include/hpipm_s_core_qp_ipm_aux.h
+include/hpipm_s_dense_qp.h
+include/hpipm_s_dense_qp_dim.h
+include/hpipm_s_dense_qp_ipm.h
+include/hpipm_s_dense_qp_kkt.h
+include/hpipm_s_dense_qp_res.h
+include/hpipm_s_dense_qp_sol.h
+include/hpipm_s_ocp_qp.h
+include/hpipm_s_ocp_qp_dim.h
+include/hpipm_s_ocp_qp_ipm.h
+include/hpipm_s_ocp_qp_kkt.h
+include/hpipm_s_ocp_qp_res.h
+include/hpipm_s_ocp_qp_sol.h
+include/hpipm_s_ocp_qp_utils.h
+include/hpipm_s_part_cond.h
+include/hpipm_s_tree_ocp_qp.h
+include/hpipm_s_tree_ocp_qp_dim.h
+include/hpipm_s_tree_ocp_qp_ipm.h
+include/hpipm_s_tree_ocp_qp_kkt.h
+include/hpipm_s_tree_ocp_qp_res.h
+include/hpipm_s_tree_ocp_qp_sol.h
+include/hpipm_scenario_tree.h
+include/hpipm_timing.h
+include/hpipm_tree.h
+lib/cmake/hpipm/hpipmConfig-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/hpipm/hpipmConfig.cmake
+lib/libhpipm.a