aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2015-08-13 23:07:12 +0800
committerehaupt <ehaupt@FreeBSD.org>2015-08-13 23:07:12 +0800
commit7f72ed975bd6b09f10d6a86fc6dc3e1366484350 (patch)
tree263dfb6c4bf6f57dda41677334bdd730a93dd6bb /multimedia
parent8bf7594787088dd2c7bfd4f85e841f3465ce6ce1 (diff)
downloadfreebsd-ports-gnome-7f72ed975bd6b09f10d6a86fc6dc3e1366484350.tar.gz
freebsd-ports-gnome-7f72ed975bd6b09f10d6a86fc6dc3e1366484350.tar.zst
freebsd-ports-gnome-7f72ed975bd6b09f10d6a86fc6dc3e1366484350.zip
Introduce an option to build the new Qt5 based GUI. The Qt5 version will replace
the now deprecated WXGTK version in the future. If you're currently launching 'mmg' (the WXGTK GUI) you will get the following notification: Please note that this program (mkvmerge GUI) is deprecated and will be removed within one or two releases. It has been superseded by the new MKVToolNix GUI which should also be included in the same package. Don't enable this option by default to give current users a notice that future updates will pull in the Qt5 dependency chain by default. However, users are encouraged to try the Qt5 version and report bugs. This new option does not change the current default build of the port and therefore no PORTREVISION bump is required.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mkvtoolnix/Makefile16
-rw-r--r--multimedia/mkvtoolnix/pkg-plist9
2 files changed, 20 insertions, 5 deletions
diff --git a/multimedia/mkvtoolnix/Makefile b/multimedia/mkvtoolnix/Makefile
index bc7dfcfdfab3..9cd64ae056ab 100644
--- a/multimedia/mkvtoolnix/Makefile
+++ b/multimedia/mkvtoolnix/Makefile
@@ -26,14 +26,12 @@ RUBY_NO_RUN_DEPENDS= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV+= ac_cv_path_PO4A=no ZLIB_CFLAGS=-I/usr/include ZLIB_LIBS=-lz
-CONFIGURE_ARGS= --disable-qt \
- --with-boost=${LOCALBASE} \
+CONFIGURE_ARGS= --with-boost=${LOCALBASE} \
--with-boost-filesystem=boost_filesystem \
--with-boost-system=boost_system \
- --with-boost-regex=boost_regex \
- --without-curl
+ --with-boost-regex=boost_regex
-OPTIONS_DEFINE= WXGTK FLAC
+OPTIONS_DEFINE= WXGTK FLAC QT5
OPTIONS_DEFAULT=WXGTK FLAC
BROKEN_sparc64= Does not install on sparc64
@@ -58,6 +56,14 @@ MAKE_ENV+= V=1
INSTALLS_ICONS= yes
.endif
+.if ${PORT_OPTIONS:MQT5}
+USE_QT5= buildtools core widgets quick
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+= --enable-qt --with-curl
+.else
+CONFIGURE_ARGS+= --disable-qt --without-curl
+.endif
+
.if ${OSVERSION} < 1000000
post-patch:
@${REINPLACE_CMD} -e 's|std::llround|llround|g' \
diff --git a/multimedia/mkvtoolnix/pkg-plist b/multimedia/mkvtoolnix/pkg-plist
index cb3c92e9e131..a0027d722858 100644
--- a/multimedia/mkvtoolnix/pkg-plist
+++ b/multimedia/mkvtoolnix/pkg-plist
@@ -1,3 +1,12 @@
+%%QT5%%bin/mkvtoolnix-gui
+%%QT5%%man/de/man1/mkvtoolnix-gui.1.gz
+%%QT5%%man/es/man1/mkvtoolnix-gui.1.gz
+%%QT5%%man/ja/man1/mkvtoolnix-gui.1.gz
+%%QT5%%man/man1/mkvtoolnix-gui.1.gz
+%%QT5%%man/nl/man1/mkvtoolnix-gui.1.gz
+%%QT5%%man/uk/man1/mkvtoolnix-gui.1.gz
+%%QT5%%man/zh_CN/man1/mkvtoolnix-gui.1.gz
+%%QT5%%share/applications/mkvtoolnix-gui.desktop
%%WXGTK%%%%DOCSDIR%%/guide/en/images/addingremovingattachments.gif
%%WXGTK%%%%DOCSDIR%%/guide/en/images/addremovefiles.gif
%%WXGTK%%%%DOCSDIR%%/guide/en/images/attachmentoptions.gif