aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mkvtoolnix/Makefile16
-rw-r--r--multimedia/mkvtoolnix/pkg-plist9
2 files changed, 20 insertions, 5 deletions
diff --git a/multimedia/mkvtoolnix/Makefile b/multimedia/mkvtoolnix/Makefile
index bc7dfcfdfab3..9cd64ae056ab 100644
--- a/multimedia/mkvtoolnix/Makefile
+++ b/multimedia/mkvtoolnix/Makefile
@@ -26,14 +26,12 @@ RUBY_NO_RUN_DEPENDS= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV+= ac_cv_path_PO4A=no ZLIB_CFLAGS=-I/usr/include ZLIB_LIBS=-lz
-CONFIGURE_ARGS= --disable-qt \
- --with-boost=${LOCALBASE} \
+CONFIGURE_ARGS= --with-boost=${LOCALBASE} \
--with-boost-filesystem=boost_filesystem \
--with-boost-system=boost_system \
- --with-boost-regex=boost_regex \
- --without-curl
+ --with-boost-regex=boost_regex
-OPTIONS_DEFINE= WXGTK FLAC
+OPTIONS_DEFINE= WXGTK FLAC QT5
OPTIONS_DEFAULT=WXGTK FLAC
BROKEN_sparc64= Does not install on sparc64
@@ -58,6 +56,14 @@ MAKE_ENV+= V=1
INSTALLS_ICONS= yes
.endif
+.if ${PORT_OPTIONS:MQT5}
+USE_QT5= buildtools core widgets quick
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+= --enable-qt --with-curl
+.else
+CONFIGURE_ARGS+= --disable-qt --without-curl
+.endif
+
.if ${OSVERSION} < 1000000
post-patch:
@${REINPLACE_CMD} -e 's|std::llround|llround|g' \
diff --git a/multimedia/mkvtoolnix/pkg-plist b/multimedia/mkvtoolnix/pkg-plist
index cb3c92e9e131..a0027d722858 100644
--- a/multimedia/mkvtoolnix/pkg-plist
+++ b/multimedia/mkvtoolnix/pkg-plist
@@ -1,3 +1,12 @@
+%%QT5%%bin/mkvtoolnix-gui
+%%QT5%%man/de/man1/mkvtoolnix-gui.1.gz
+%%QT5%%man/es/man1/mkvtoolnix-gui.1.gz
+%%QT5%%man/ja/man1/mkvtoolnix-gui.1.gz
+%%QT5%%man/man1/mkvtoolnix-gui.1.gz
+%%QT5%%man/nl/man1/mkvtoolnix-gui.1.gz
+%%QT5%%man/uk/man1/mkvtoolnix-gui.1.gz
+%%QT5%%man/zh_CN/man1/mkvtoolnix-gui.1.gz
+%%QT5%%share/applications/mkvtoolnix-gui.desktop
%%WXGTK%%%%DOCSDIR%%/guide/en/images/addingremovingattachments.gif
%%WXGTK%%%%DOCSDIR%%/guide/en/images/addremovefiles.gif
%%WXGTK%%%%DOCSDIR%%/guide/en/images/attachmentoptions.gif