aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-02-04 19:39:45 +0800
committerMark Linimon <linimon@FreeBSD.org>2019-02-04 19:39:45 +0800
commit1512c9124e39797451c46efb95bc6cc2a9f058bf (patch)
tree872b1a4adc91acc3f613da62ef1ad02150a66657 /net-im
parentdfe22ba79cc0421f151de2993a1c7998700f44b3 (diff)
downloadfreebsd-ports-gnome-1512c9124e39797451c46efb95bc6cc2a9f058bf.tar.gz
freebsd-ports-gnome-1512c9124e39797451c46efb95bc6cc2a9f058bf.tar.zst
freebsd-ports-gnome-1512c9124e39797451c46efb95bc6cc2a9f058bf.zip
This port needs USES=compiler:c++11-lang to build on GCC-based
architectures. While here, pet portlint. PR: 235290 Submitted by: Piotr Kubaj Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gitterdone/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/net-im/gitterdone/Makefile b/net-im/gitterdone/Makefile
index 9d8ec4d5d060..77f210410ea4 100644
--- a/net-im/gitterdone/Makefile
+++ b/net-im/gitterdone/Makefile
@@ -10,16 +10,16 @@ COMMENT= Gitter Client based on Qt5
LICENSE= BSD2CLAUSE
-MAKE_ARGS= PREFIX=${STAGEDIR}${PREFIX}
-
-MAKE_JOBS_UNSAFE= yes
-USE_LDCONFIG= yes
-
-USES= qmake qt:5 shebangfix tar:xz
+USES= compiler:c++11-lang qmake qt:5 shebangfix tar:xz
USE_QT= core gui network linguist_build \
buildtools_build widgets webkit svg
USE_GL+= gl
+MAKE_ARGS= PREFIX=${STAGEDIR}${PREFIX}
+MAKE_JOBS_UNSAFE= yes
+
+USE_LDCONFIG= yes
+
WRKSRC_SUBDIR= src-qt5
QMAKE_ARGS= CONFIG+="configure"