aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/grepip
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-26 19:23:10 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-26 19:23:10 +0800
commit4b2730cede75350e270549c92386405814cedf29 (patch)
treebcb70db489e4e1122f70db449d4f7550cd096d17 /net-mgmt/grepip
parent016b9e9c9f0fe34991d9f694afa5976b495cf1ea (diff)
downloadfreebsd-ports-gnome-4b2730cede75350e270549c92386405814cedf29.tar.gz
freebsd-ports-gnome-4b2730cede75350e270549c92386405814cedf29.tar.zst
freebsd-ports-gnome-4b2730cede75350e270549c92386405814cedf29.zip
Support staging
Diffstat (limited to 'net-mgmt/grepip')
-rw-r--r--net-mgmt/grepip/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/net-mgmt/grepip/Makefile b/net-mgmt/grepip/Makefile
index 2a14cfafe425..ace10eeccc06 100644
--- a/net-mgmt/grepip/Makefile
+++ b/net-mgmt/grepip/Makefile
@@ -11,22 +11,22 @@ MASTER_SITES= http://komquats.com/distfiles/ \
MAINTAINER= cy@FreeBSD.org
COMMENT= Print lines contans IP matching a pattern in CIDR format
-LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
PLIST_FILES= bin/grepip
PORTDOCS= README.txt
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
do-build:
cd ${WRKSRC}; \
${CC} ${CFLAGS} -c patricia.c; \
- ${CC} ${CFLAGS} -I${LOCALBASE}/include -o grepip grepip.c patricia.o -L${LOCALBASE}/lib -lpcre
+ ${CC} ${CFLAGS} -I${LOCALBASE}/include -o grepip grepip.c patricia.o \
+ -L${LOCALBASE}/lib -lpcre
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/grepip ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/grepip ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>