aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/zabbix42-frontend
diff options
context:
space:
mode:
authordbaio <dbaio@FreeBSD.org>2019-04-25 19:56:06 +0800
committerdbaio <dbaio@FreeBSD.org>2019-04-25 19:56:06 +0800
commit92e6fa089a120955ab4636aa4945e7d25d699439 (patch)
treebe790bf70996c6cc36627f30c813a130ba46bd7c /net-mgmt/zabbix42-frontend
parent15fd55120a97cb415f142c57f4765825e619f82b (diff)
downloadfreebsd-ports-gnome-92e6fa089a120955ab4636aa4945e7d25d699439.tar.gz
freebsd-ports-gnome-92e6fa089a120955ab4636aa4945e7d25d699439.tar.zst
freebsd-ports-gnome-92e6fa089a120955ab4636aa4945e7d25d699439.zip
New ports: net-mgmt/zabbix42-[agent|frontend|java|proxy|server]
net-mgmt/zabbix4 -> net-mgmt/zabbix42 What's new in Zabbix 4.2: https://www.zabbix.com/documentation/4.2/manual/introduction/whatsnew420 PR: 237511 Approved by: Pakhom Golynga <pg@pakhom.spb.ru> (maintainer)
Diffstat (limited to 'net-mgmt/zabbix42-frontend')
-rw-r--r--net-mgmt/zabbix42-frontend/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-mgmt/zabbix42-frontend/Makefile b/net-mgmt/zabbix42-frontend/Makefile
new file mode 100644
index 000000000000..00e042f6d963
--- /dev/null
+++ b/net-mgmt/zabbix42-frontend/Makefile
@@ -0,0 +1,34 @@
+# Created by: Pakhom Golynga <pg@pakhom.spb.ru>
+# $FreeBSD$
+
+PORTNAME= zabbix42
+CATEGORIES= net-mgmt
+PKGNAMESUFFIX= -frontend
+
+MASTERDIR= ${.CURDIR}/../zabbix42-server
+
+NO_BUILD= yes
+NO_ARCH= yes
+PATCHDIR=
+PLIST= ${PKGDIR}/pkg-plist.frontend
+
+USE_PHP= bcmath ctype dom filter gd gettext json ldap mbstring pcre \
+ session simplexml snmp sockets xml xmlreader xmlwriter
+USES+= php:web
+
+OPTIONS_DEFINE= MYSQLI PGSQL ORACLE
+OPTIONS_DEFAULT= MYSQLI
+MYSQLI_DESC= MySQLI backend
+
+MYSQLI_USE= PHP=mysqli
+
+PGSQL_USE= PHP=pgsql
+
+ORACLE_CONFIGURE_WITH= oracle
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC}/frontends/php && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+
+.include "${MASTERDIR}/Makefile"