aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/litecoin
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
committertcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
commit2a8bcfc8ea71d4438b926a8adc477de360863145 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /net-p2p/litecoin
parent62341874a942de5989d54a3ba471cb8719d251ee (diff)
downloadfreebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.gz
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.zst
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Diffstat (limited to 'net-p2p/litecoin')
-rw-r--r--net-p2p/litecoin/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/net-p2p/litecoin/Makefile b/net-p2p/litecoin/Makefile
index 3b82784da39a..34db7b551d1f 100644
--- a/net-p2p/litecoin/Makefile
+++ b/net-p2p/litecoin/Makefile
@@ -19,7 +19,7 @@ NOT_FOR_ARCHS_REASON= fails to configure: "Big Endian not supported"
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs \
libevent.so:devel/libevent
-USES+= autoreconf compiler:c++11-lib gmake libtool pkgconfig ssl
+USES+= autoreconf compiler:c++11-lib gmake libtool pkgconfig qt:5 ssl
USE_GITHUB= yes
GNU_CONFIGURE= yes
@@ -27,13 +27,14 @@ SLAVE_PORT?= no
.if defined(SLAVE_PORT) && ${SLAVE_PORT} == "no"
USES+= desktop-file-utils
-USE_QT5= core gui network widgets \
+USE_QT= core gui network widgets \
buildtools_build linguisttools_build qmake_build
BUILD_DEPENDS+= protoc:devel/protobuf
LIB_DEPENDS+= libprotobuf.so:devel/protobuf
-TESTS_USE= QT5=testlib
+TESTS_USES= qt:5
+TESTS_USE= QT=testlib
TESTS_PLIST_FILES= bin/test_litecoin-qt \
bin/test_litecoin
.endif
@@ -49,7 +50,8 @@ WALLET_DESC= Wallet Management Support
ZMQ_DESC= Block and transaction broadcasting with ZeroMQ
DBUS_CONFIGURE_WITH= dbus
-DBUS_USE= QT5=dbus
+DBUS_USES= qt:5
+DBUS_USE= QT=dbus
DEBUG_CONFIGURE_ENABLE= debug
DEBUG_INSTALL_TARGET_OFF= install-strip