aboutsummaryrefslogtreecommitdiffstats
path: root/net/sip_scenario/Makefile
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-03-14 18:24:48 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-03-14 18:24:48 +0800
commit044bfb43e199664eced7bcdc14c6ea7224198526 (patch)
treef952ba5fa52dffa046c476c6c44d5ccce125c7c3 /net/sip_scenario/Makefile
parentb09f8e2c0da0d7c871faaa55ac6f7b4535ce8a38 (diff)
downloadfreebsd-ports-gnome-044bfb43e199664eced7bcdc14c6ea7224198526.tar.gz
freebsd-ports-gnome-044bfb43e199664eced7bcdc14c6ea7224198526.tar.zst
freebsd-ports-gnome-044bfb43e199664eced7bcdc14c6ea7224198526.zip
- Support staging
- Use shebangfix
Diffstat (limited to 'net/sip_scenario/Makefile')
-rw-r--r--net/sip_scenario/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/net/sip_scenario/Makefile b/net/sip_scenario/Makefile
index b960c143711e..7f896c4a4c48 100644
--- a/net/sip_scenario/Makefile
+++ b/net/sip_scenario/Makefile
@@ -12,8 +12,9 @@ COMMENT= SIP call flow creator (HTML format)
LICENSE= APACHE20
-USES= perl5 zip
+USES= perl5 zip shebangfix
USE_PERL5= run
+NO_BUILD= yes
WRKSRC= ${WRKDIR}
@@ -23,12 +24,10 @@ WRKSRC= ${WRKDIR}
# http://www.abptech.com/support/resources/SIP_scen_generator_v1.2.7/index/SipScenarioPart2.pdf
# download them and install them in /usr/local/share/doc/sip_scenario/
+SHEBANG_FILES= sip_scenario.pl
PLIST_FILES= bin/sip_scenario.pl
-NO_BUILD= yes
-NO_STAGE= yes
do-install:
- ${SED} -i -e '1s/local\///' ${WRKSRC}/sip_scenario.pl
- ${INSTALL_SCRIPT} ${WRKSRC}/sip_scenario.pl ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/sip_scenario.pl ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>