aboutsummaryrefslogtreecommitdiffstats
path: root/net/tridiavnc
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-07-26 18:46:37 +0800
committeraz <az@FreeBSD.org>2013-07-26 18:46:37 +0800
commit425a912423003f8cf48eb9dc516a4d77b8a20cf2 (patch)
tree4e432cd7adf68b48f6abe895819485849ed8f886 /net/tridiavnc
parent1079766f17b5d6a4c7cf98bd67a211c4e64e0017 (diff)
downloadfreebsd-ports-gnome-425a912423003f8cf48eb9dc516a4d77b8a20cf2.tar.gz
freebsd-ports-gnome-425a912423003f8cf48eb9dc516a4d77b8a20cf2.tar.zst
freebsd-ports-gnome-425a912423003f8cf48eb9dc516a4d77b8a20cf2.zip
- switch simple inline replacement from perl to sed
and remove where is no need in this anymore. - trim Makefile header Approved by: bapt@ (portmrg@)
Diffstat (limited to 'net/tridiavnc')
-rw-r--r--net/tridiavnc/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/net/tridiavnc/Makefile b/net/tridiavnc/Makefile
index 5ddfe23054ad..86d05a030d80 100644
--- a/net/tridiavnc/Makefile
+++ b/net/tridiavnc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tridiavnc
-# Date created: 14 June 2001
-# Whom: dwcjr
-#
+# Created by: dwcjr
# $FreeBSD$
-#
PORTNAME= tridiavnc
PORTVERSION= 1.4
@@ -21,7 +17,8 @@ LICENSE= GPLv2
USE_PERL5= yes
WRKSRC= ${WRKDIR}/unix/vnc_unixsrc
-USES= imake
+USES= imake shebangfix
+SHEBANG_FILES= vncserver
USE_XORG= ice sm x11 xaw xext xmu xt xpm
ALL_TARGET= World
NO_INSTALL_MANPAGES= yes
@@ -47,10 +44,10 @@ PLIST_SUB+= XVNC=""
post-patch:
.for file in vncviewer/Imakefile Xvnc/config/cf/vnclibs.def Xvnc/config/cf/Imake.tmpl
- @${PERL} -pi -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/${file}
+ ${REINPLACE_CMD} -i '' -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/${file}
.endfor
- @${PERL} -pi -e "s,/usr/local/vnc/classes,${DATADIR}/classes,g ; \
- s,^#!/usr/bin/perl,#!${PERL},g" ${WRKSRC}/vncserver
+ ${REINPLACE_CMD} -i '' -e 's|/usr/local/vnc/classes|${DATADIR}/classes|' \
+ ${WRKSRC}/vncserver
# We have to frob a few things, and we want our own permissions, so it's easier
# to do the install ourselves.