aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2011-11-02 04:46:07 +0800
committerdougb <dougb@FreeBSD.org>2011-11-02 04:46:07 +0800
commit1bc38e5917b8cea3b0e88cf78156ae0f2d1fa031 (patch)
treeaf91d2702348c174c7196f86202ab50e796da11a /net
parent7849acac910fa057e1d4e5183af310dbfda24a5a (diff)
downloadfreebsd-ports-gnome-1bc38e5917b8cea3b0e88cf78156ae0f2d1fa031.tar.gz
freebsd-ports-gnome-1bc38e5917b8cea3b0e88cf78156ae0f2d1fa031.tar.zst
freebsd-ports-gnome-1bc38e5917b8cea3b0e88cf78156ae0f2d1fa031.zip
Remove references to unsupported FreeBSD versions. Mostly of the form:
.if ${OSVERSION} < 700000
Diffstat (limited to 'net')
-rw-r--r--net/cphone/Makefile8
-rw-r--r--net/netembryo/Makefile10
-rw-r--r--net/ohphone/Makefile8
-rw-r--r--net/openam/Makefile8
-rw-r--r--net/vde2/Makefile4
-rw-r--r--net/xorp-devel/Makefile4
6 files changed, 4 insertions, 38 deletions
diff --git a/net/cphone/Makefile b/net/cphone/Makefile
index 7b1bea4d55c7..10a1ada25238 100644
--- a/net/cphone/Makefile
+++ b/net/cphone/Makefile
@@ -30,12 +30,6 @@ MAKE_ENV= QTDIR=${QT_PREFIX} \
MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${ARCH:S/i386/x86/} \
OSRELEASE=${OSVERSION} CPLUS=${CXX}
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == sparc64 && ${OSVERSION} <= 700003
-BROKEN= does not link due to missing symbol in default thread library
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/graphdisplay.h/d' -e '/videodisplay.h/d' \
-e '/labeldisplay.h/d' ${WRKSRC}/mainwindow.ui \
@@ -44,4 +38,4 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/obj_r/cphone ${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/netembryo/Makefile b/net/netembryo/Makefile
index 7a6eae118a01..50bd4b5e847c 100644
--- a/net/netembryo/Makefile
+++ b/net/netembryo/Makefile
@@ -21,12 +21,4 @@ USE_BZIP2= yes
USE_LDCONFIG= yes
USE_GNOME= pkgconfig gnomehack
-OPTIONS= SCTP "Don't check if SCTP is present" off
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700028 && ! defined(WITH_SCTP)
-IGNORE= sorry, please use FreeBSD 7.x or patch your system for SCTP (http://www.sctp.org/download.html) and use WITH_SCTP=YES
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/ohphone/Makefile b/net/ohphone/Makefile
index 518ac92b7858..b9f4e940477d 100644
--- a/net/ohphone/Makefile
+++ b/net/ohphone/Makefile
@@ -31,12 +31,6 @@ PLIST_SUB= PORTNAME=${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/openh323
EXAMPLESDIR= ${PREFIX}/share/examples/openh323
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == sparc64 && ${OSVERSION} <= 700003
-BROKEN= does not link due to missing symbol in default thread library
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/obj_r/ohphone ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/ohphone.1 ${PREFIX}/man/man1
@@ -49,4 +43,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/regtest ${EXAMPLESDIR}/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/stresstest ${EXAMPLESDIR}/${PORTNAME}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/openam/Makefile b/net/openam/Makefile
index be0237fadd47..cc585140b28b 100644
--- a/net/openam/Makefile
+++ b/net/openam/Makefile
@@ -31,12 +31,6 @@ MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${ARCH:S/i386/x86/} \
PLIST_SUB= PORTNAME=${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/openh323
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == sparc64 && ${OSVERSION} <= 700003
-BROKEN= does not link due to missing symbol in default thread library
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/obj_r/openam ${PREFIX}/bin
@${MKDIR} ${DOCSDIR}/${PORTNAME}
@@ -44,4 +38,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/sample_message.wav ${DOCSDIR}/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/sample_message_g7231.wav ${DOCSDIR}/${PORTNAME}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/vde2/Makefile b/net/vde2/Makefile
index 6b1d8bcaf8ed..b858fec78a3b 100644
--- a/net/vde2/Makefile
+++ b/net/vde2/Makefile
@@ -32,10 +32,6 @@ MAN8= vde_tunctl.8
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700000
-BROKEN= fails to build on 6.x
-.endif
-
.if defined(BATCH) || defined(PACKAGE_BUILDING)
MAKE_ENV+= V=1
.endif
diff --git a/net/xorp-devel/Makefile b/net/xorp-devel/Makefile
index 279da72ebeab..dee7ac62092b 100644
--- a/net/xorp-devel/Makefile
+++ b/net/xorp-devel/Makefile
@@ -59,10 +59,6 @@ do-fetch:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700000
-IGNORE= unsupported on FreeBSD versions prior to 7.0
-.endif
-
XORP_GROUP= xorp
USE_RC_SUBR= xorp