aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-12-22 14:32:18 +0800
committeredwin <edwin@FreeBSD.org>2004-12-22 14:32:18 +0800
commit1cd1f4b3bcc268007021ebce5b53ea8f363f8da0 (patch)
tree15c8ec1faa70984da20fa62d441d2ac9e260180c /net
parentc8d534df292d194c003eea41d3d04b5262c25d40 (diff)
downloadfreebsd-ports-gnome-1cd1f4b3bcc268007021ebce5b53ea8f363f8da0.tar.gz
freebsd-ports-gnome-1cd1f4b3bcc268007021ebce5b53ea8f363f8da0.tar.zst
freebsd-ports-gnome-1cd1f4b3bcc268007021ebce5b53ea8f363f8da0.zip
A (new) port of the Mirror Project Random Image Widget
The Random Image Widget is a small (wxPython) application that periodically polls The Mirror Project for a random image and displays it in a window on your desktop. PR: ports/70060 Submitted by: Aaron Straup Cope <asc@vineyard.net>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-mp-random/Makefile34
-rw-r--r--net/py-mp-random/distinfo2
-rw-r--r--net/py-mp-random/pkg-descr3
-rw-r--r--net/py-mp-random/pkg-plist1
5 files changed, 41 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 95744126ffc0..369b00297482 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -592,6 +592,7 @@
SUBDIR += py-ldap2
SUBDIR += py-libnet
SUBDIR += py-medusa
+ SUBDIR += py-mp-random
SUBDIR += py-msnp
SUBDIR += py-pcap
SUBDIR += py-rrdpipe
diff --git a/net/py-mp-random/Makefile b/net/py-mp-random/Makefile
new file mode 100644
index 000000000000..a4bffd70ccd9
--- /dev/null
+++ b/net/py-mp-random/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: py-MirrorProjectRandomImageWidget
+# Date created: August 03, 2004
+# Whom: Aaron Straup Cope ascope@cpan.org
+#
+# $FreeBSD$
+#
+
+PORTNAME=mp-random
+PORTVERSION= 1.0
+CATEGORIES= net python
+MASTER_SITES= http://mirrorproject.com/widget/
+PKGNAMEPREFIX= py-
+DISTNAME= MirrorProjectRandomImageWidget-src-${PORTVERSION}
+
+MAINTAINER= randomimage-widget@mirrorproject.com
+COMMENT= Display random Mirror Project images on your desktop
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/wxPython/wxc.so:${PORTSDIR}/x11-toolkits/py-wxPython
+
+USE_PYTHON= yes
+USE_X_PREFIX= yes
+NO_BUILD= yes
+
+pre-install:
+ ${PRINTF} "#!${PYTHON_CMD}\n" > ${WRKSRC}/mp-random
+ ${CAT} ${WRKSRC}/MirrorProjectRandomImageWidget.py >> \
+ ${WRKSRC}/mp-random
+ ${CHMOD} 0755 ${WRKSRC}/mp-random
+
+do-install:
+ ${ECHO} "Installing ${PREFIX}/bin/mp-random"
+ ${CP} ${WRKSRC}/mp-random ${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/net/py-mp-random/distinfo b/net/py-mp-random/distinfo
new file mode 100644
index 000000000000..57677fb9496c
--- /dev/null
+++ b/net/py-mp-random/distinfo
@@ -0,0 +1,2 @@
+MD5 (MirrorProjectRandomImageWidget-src-1.0.tar.gz) = 127a6f7f736bd742f568a5d283405bbe
+SIZE (MirrorProjectRandomImageWidget-src-1.0.tar.gz) = 4891
diff --git a/net/py-mp-random/pkg-descr b/net/py-mp-random/pkg-descr
new file mode 100644
index 000000000000..66469037fbaa
--- /dev/null
+++ b/net/py-mp-random/pkg-descr
@@ -0,0 +1,3 @@
+Display random Mirror Project images on your desktop.
+
+WWW: http://www.mirrorproject.com/widget
diff --git a/net/py-mp-random/pkg-plist b/net/py-mp-random/pkg-plist
new file mode 100644
index 000000000000..3a3a480ac37c
--- /dev/null
+++ b/net/py-mp-random/pkg-plist
@@ -0,0 +1 @@
+bin/mp-random