aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2014-11-23 16:44:34 +0800
committerhrs <hrs@FreeBSD.org>2014-11-23 16:44:34 +0800
commit79d180c339449f9f7d1a433d315218fd514836d2 (patch)
tree6a8eefa3cb9a23b2e354faa867ab3702b4eb99ea /print
parent974053393aee1bd31379c64e219fdb8523fdac56 (diff)
downloadfreebsd-ports-gnome-79d180c339449f9f7d1a433d315218fd514836d2.tar.gz
freebsd-ports-gnome-79d180c339449f9f7d1a433d315218fd514836d2.tar.zst
freebsd-ports-gnome-79d180c339449f9f7d1a433d315218fd514836d2.zip
- Strip binaries properly.
- Update pkg-message.
Diffstat (limited to 'print')
-rw-r--r--print/ghostscript8/Makefile27
-rw-r--r--print/ghostscript8/files/patch-base-Makefile.in23
-rw-r--r--print/ghostscript8/files/patch-base-unixinst.mak13
-rw-r--r--print/ghostscript8/files/pkg-message.in10
4 files changed, 39 insertions, 34 deletions
diff --git a/print/ghostscript8/Makefile b/print/ghostscript8/Makefile
index d58df32f5360..b76ef626eb58 100644
--- a/print/ghostscript8/Makefile
+++ b/print/ghostscript8/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ghostscript
PORTVERSION= 8.71
-PORTREVISION= 16
+PORTREVISION= 17
CATEGORIES= print
MASTER_SITES= http://downloads.ghostscript.com/public/:gs_srcs \
SF/ghostscript/GPL%20Ghostscript/${PORTVERSION}:gs_srcs \
@@ -140,34 +140,31 @@ pre-build-drivers.mak:
.endfor
pre-build: pre-build-drivers.mak
- ${MKDIR} ${WRKSRC}/obj
- ${MKDIR} ${WRKSRC}/bin
- ${MKDIR} ${WRKSRC}/freetype/include
+ ${MKDIR} ${WRKSRC}/obj ${WRKSRC}/bin ${WRKSRC}/freetype/include
${LN} -s -f ${LOCALBASE}/include/ft2build.h \
- ${WRKSRC}/freetype/include/ft2build.h
+ ${WRKSRC}/freetype/include/ft2build.h
${LN} -s -f ${LOCALBASE}/include/freetype2/freetype \
- ${WRKSRC}/freetype/include/freetype
+ ${WRKSRC}/freetype/include/freetype
${MKDIR} ${WRKSRC}/freetype/objs
${LN} -s -f ${LOCALBASE}/lib/libfreetype.so \
- ${WRKSRC}/freetype/objs/freetype214MT_D.so
+ ${WRKSRC}/freetype/objs/freetype214MT_D.so
pre-su-install:
${MKDIR} ${STAGEDIR}${DATADIR}
post-install-docs:
${MKDIR} ${WRKSRC}/contrib/japanese
- ${INSTALL_DATA} ${WRKSRC}/contrib/japanese/doc/* ${WRKSRC}/contrib/japanese
+ ${INSTALL_DATA} ${WRKSRC}/contrib/japanese/doc/* \
+ ${WRKSRC}/contrib/japanese
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/contrib && \
- ${TAR} -cf - ${PORTDOC_FILES} | \
- ( cd ${STAGEDIR}${DOCSDIR} && ${TAR} -xof - )
+ ${TAR} -cf - ${PORTDOC_FILES} | \
+ (cd ${STAGEDIR}${DOCSDIR} && ${TAR} -xof -)
post-install:
- ${INSTALL_DATA} ${WRKSRC}/lib/FAPIcidfmap \
- ${WRKSRC}/lib/FAPIconfig ${WRKSRC}/lib/FAPIfontmap \
- ${STAGEDIR}${DATADIR}/${PORTVERSION}/Resource/Init
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DATADIR}/${PORTVERSION}
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/gsc ${STAGEDIR}${PREFIX}/bin/gsx
+ ${INSTALL_DATA} ${WRKSRC}/lib/FAPIcidfmap \
+ ${WRKSRC}/lib/FAPIconfig ${WRKSRC}/lib/FAPIfontmap \
+ ${STAGEDIR}${DATADIR}/${PORTVERSION}/Resource/Init
${LN} -sf gsc ${STAGEDIR}${PREFIX}/bin/gs
${LN} -s -f ${LOCALBASE}/share/fonts/CIDFont \
${STAGEDIR}${CIDFONTDIR}/CIDFont
diff --git a/print/ghostscript8/files/patch-base-Makefile.in b/print/ghostscript8/files/patch-base-Makefile.in
index 92dc3c96df60..fdfac547a986 100644
--- a/print/ghostscript8/files/patch-base-Makefile.in
+++ b/print/ghostscript8/files/patch-base-Makefile.in
@@ -1,18 +1,19 @@
--- base/Makefile.in.orig 2009-12-18 16:04:10.000000000 +0900
-+++ base/Makefile.in 2010-05-23 03:04:55.000000000 +0900
-@@ -47,9 +47,8 @@
++++ base/Makefile.in 2014-11-23 17:40:23.000000000 +0900
+@@ -47,9 +47,9 @@
# the directories also define the default search path for the
# initialization files (gs_*.ps) and the fonts.
-INSTALL = $(GLSRCDIR)/instcopy -c
-INSTALL_PROGRAM = $(INSTALL) -m 755
-INSTALL_DATA = $(INSTALL) -m 644
-+INSTALL_PROGRAM = ${BSD_INSTALL_SCRIPT}
++INSTALL_PROGRAM = ${BSD_INSTALL_PROGRAM}
++INSTALL_SCRIPT = ${BSD_INSTALL_SCRIPT}
+INSTALL_DATA = ${BSD_INSTALL_DATA}
INSTALL_SHARED = @INSTALL_SHARED@
prefix = @prefix@
-@@ -156,7 +155,7 @@
+@@ -156,7 +156,7 @@
# some older JPEG streams that violate the standard. If the JPEG
# library built from local sources, the patch will be applied.
@@ -21,7 +22,7 @@
JPEG_NAME=jpeg
# Define the directory where the PNG library sources are stored,
-@@ -164,12 +163,12 @@
+@@ -164,12 +164,12 @@
# You may need to change this if the libpng version changes.
# See libpng.mak for more information.
@@ -36,7 +37,7 @@
TIFFSRCDIR=@LIBTIFFDIR@
TIFFPLATFORM=unix
TIFFCONFIG_SUFFIX=
-@@ -178,7 +177,7 @@
+@@ -178,7 +178,7 @@
# Define the directory where the zlib sources are stored.
# See zlib.mak for more information.
@@ -45,7 +46,7 @@
ZSRCDIR=@ZLIBDIR@
#ZLIB_NAME=gz
ZLIB_NAME=z
-@@ -254,7 +253,7 @@
+@@ -254,7 +254,7 @@
# Define the added flags for standard, debugging, profiling
# and shared object builds.
@@ -54,7 +55,7 @@
CFLAGS_DEBUG=-g -O0
CFLAGS_PROFILE=-pg @OPT_CFLAGS@
CFLAGS_SO=@DYNAMIC_CFLAGS@
-@@ -299,7 +298,7 @@
+@@ -299,7 +299,7 @@
# Solaris may need -lnsl -lsocket -lposix4.
# (Libraries required by individual drivers are handled automatically.)
@@ -63,7 +64,7 @@
# Define the standard libraries to search at the end of linking.
# Most platforms require -lpthread for the POSIX threads library;
-@@ -343,7 +342,7 @@
+@@ -343,7 +343,7 @@
# the pthread library. Otherwise use SYNC=nosync
#SYNC=posync
#SYNC=nosync
@@ -72,7 +73,7 @@
# programs we use
RM=rm -f
-@@ -436,27 +435,27 @@
+@@ -436,27 +436,27 @@
#DEVICE_DEVS20=$(DD)cljet5.dev $(DD)cljet5c.dev
#DEVICE_DEVS21=$(DD)spotcmyk.dev $(DD)devicen.dev $(DD)xcf.dev $(DD)psdcmyk.dev $(DD)psdrgb.dev
DEVICE_DEVS=$(DISPLAY_DEV) @X_DEVS@
@@ -121,7 +122,7 @@
# Shared library target to build.
-@@ -490,6 +489,7 @@
+@@ -490,6 +490,7 @@
# ---------------- End of platform-specific section ---------------- #
INSTALL_CONTRIB=@INSTALL_CONTRIB@
diff --git a/print/ghostscript8/files/patch-base-unixinst.mak b/print/ghostscript8/files/patch-base-unixinst.mak
index 013836f8afe2..4f6006f3a9a8 100644
--- a/print/ghostscript8/files/patch-base-unixinst.mak
+++ b/print/ghostscript8/files/patch-base-unixinst.mak
@@ -1,5 +1,14 @@
---- base/unixinst.mak.orig 2007-08-15 05:48:29.000000000 +0900
-+++ base/unixinst.mak 2008-05-05 16:48:06.000000000 +0900
+--- base/unixinst.mak.orig 2009-11-19 09:09:15.000000000 +0900
++++ base/unixinst.mak 2014-11-23 17:40:46.000000000 +0900
+@@ -44,7 +44,7 @@
+ wftopfa fixmswrd.pl lprsetup.sh pj-gs.sh pv.sh sysvlp.sh unix-lpr.sh ;\
+ do if ( test -f $(PSLIBDIR)/$$f ); then \
+ (cat $(PSLIBDIR)/$$f | sed -e "s/GS_EXECUTABLE=gs/GS_EXECUTABLE=$(GS)/" > $(PSOBJDIR)/$$f); \
+- $(INSTALL_PROGRAM) $(PSOBJDIR)/$$f $(DESTDIR)$(scriptdir)/$$f; \
++ $(INSTALL_SCRIPT) $(PSOBJDIR)/$$f $(DESTDIR)$(scriptdir)/$$f; \
+ fi;\
+ done'
+
@@ -128,7 +128,7 @@
done'
diff --git a/print/ghostscript8/files/pkg-message.in b/print/ghostscript8/files/pkg-message.in
index 6026529d9348..ea0381cc7d91 100644
--- a/print/ghostscript8/files/pkg-message.in
+++ b/print/ghostscript8/files/pkg-message.in
@@ -1,7 +1,5 @@
-Note: in order to use the script dvipdf, dvips must be installed.
-This program may be provided by either print/dvips or print/dvipsk-tetex
-(print/dvipsk-tetex may be preferable since it doesn't conflict with
-tetex things).
+Note: in order to use the script "dvipdf", dvips must be installed.
+This program is provided by another package print/tex-dvipsk.
-Also note that FAPIfontmap and FAPIcidfmap in
-%%DATADIR%%/%%PORTVERSION%%/Resource/Init have to be configured first.
+FAPIfontmap and FAPIcidfmap in %%DATADIR%%/%%PORTVERSION%%/Resource/Init
+have to be configured if you want to use FAPI feature.