aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2014-09-02 20:59:54 +0800
committerrakuco <rakuco@FreeBSD.org>2014-09-02 20:59:54 +0800
commitf2e617b3169c55c1faded52dd5d1e127c50d62dd (patch)
tree67cd40943f0ef7eea725ecad6987a3d3cd88625d /science
parent5d8fa1985f0a3c993d2ac8be51d77e13a7069c46 (diff)
downloadfreebsd-ports-gnome-f2e617b3169c55c1faded52dd5d1e127c50d62dd.tar.gz
freebsd-ports-gnome-f2e617b3169c55c1faded52dd5d1e127c50d62dd.tar.zst
freebsd-ports-gnome-f2e617b3169c55c1faded52dd5d1e127c50d62dd.zip
Update CMake to 3.0.1.
The 3.0 series is an incremental improvement over the previous 2.8 series despite the major version number change. A list of important changes is available at http://www.cmake.org/cmake/help/v3.0/release/3.0.0.html On the porting side * The minimum FreeBSD release we have to support in the ports tree is now recent enough that ports/168671 can finally be committed: instead of building and using CMake's own copies of bzip2, curl, expat, libarchive, liblzma and zlib, we use the versions in ports and/or the base system. * CMake's documentation system has been changed and vastly improved at the cost of now depending on Sphinx. We still generate only man pages, but can start generating the HTML documentation in the future if desired. * devel/cmake-gui now uses Qt5 instead of Qt4 and does not needlessly build the ncurses UI that is installed by devel/cmake itself. * CMake commit 3816cd2 fixes a longstanding issue in the detection of the Python interpreter and its libraries, but requires us to revert a workaround for that in Mk/Uses/python.mk itself, effectively reverting the patch introduced by ports/168159. * Similarly, a few ports had to be fixed manually due to CMake being stricter when parsing some files or the ports detecting Python the wrong way. Fortunately, they all had been fixed upstream so I just grabbed the appropriate commits and pointed to them in the patches. science/gnudatalanguage had to have its PORTREVISION bumped because switching to USES=cmake:outsource removed a few files from the plist that were not supposed to have been installed in the first place. PR: 168671 PR: 192644
Diffstat (limited to 'science')
-rw-r--r--science/gnudatalanguage/Makefile4
-rw-r--r--science/gnudatalanguage/files/patch-CMakeLists.txt27
-rw-r--r--science/gnudatalanguage/pkg-plist27
3 files changed, 29 insertions, 29 deletions
diff --git a/science/gnudatalanguage/Makefile b/science/gnudatalanguage/Makefile
index 16ff1ae6ef8e..c7205ab6a503 100644
--- a/science/gnudatalanguage/Makefile
+++ b/science/gnudatalanguage/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnudatalanguage
DISTVERSION= 0.9.4
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= science lang
MASTER_SITES= SF/${PORTNAME}/gdl/${DISTVERSION}
.if defined(BUILD_PYTHON_MODULE)
@@ -37,7 +37,7 @@ LIB_DEPENDS+= libplplotd.so:${PORTSDIR}/math/plplot \
USE_WX= 2.8
WX_UNICODE= yes
USE_XORG= x11
-USES= pkgconfig cmake dos2unix compiler:gcc-c++11-lib
+USES= pkgconfig cmake:outsource dos2unix compiler:gcc-c++11-lib
# Disable ncurses and readline from ports
# Disable ImageMagick (does'nt work with plplot because dynamic drivers
diff --git a/science/gnudatalanguage/files/patch-CMakeLists.txt b/science/gnudatalanguage/files/patch-CMakeLists.txt
index 4a6a807e6ec8..b85763b8166b 100644
--- a/science/gnudatalanguage/files/patch-CMakeLists.txt
+++ b/science/gnudatalanguage/files/patch-CMakeLists.txt
@@ -1,5 +1,32 @@
+Includes revisions 1.50 and 1.57 from upstream:
+
+ Fri Jun 13 21:45:44 2014 UTC by gilles-duvert
+ Applied Orion's patch #77
+
+ Mon Sep 1 11:23:18 2014 UTC by alaingdl
+ patch 78 related to change in CMake 3.0
+
+Both patches are required for CMake 3.0+ support.
--- ./CMakeLists.txt.orig 2013-09-28 17:03:32.000000000 +0200
+++ ./CMakeLists.txt 2013-09-30 16:19:09.000000000 +0200
+@@ -610,13 +610,11 @@
+ message("-- Found Python executable: ${PYTHON_EXECUTABLE}")
+ endif()
+ else()
+- if(PYTHONVERSION)
+- set(PythonLibs_FIND_VERSION ${PYTHONVERSION})
+- else()
+- set(PythonLibs_FIND_VERSION 2)
++ if(NOT PYTHONVERSION)
++ set(PYTHONVERSION 2)
+ endif()
+- find_package(PythonLibs)
+- include(FindPythonInterp)
++ find_package(PythonInterp)
++ find_package(PythonLibs ${PYTHONVERSION})
+ endif()
+ set(USE_PYTHON ${PYTHONLIBS_FOUND})
+ if(PYTHONLIBS_FOUND)
@@ -752,7 +752,7 @@
endif(NOT PYTHON_MODULE)
diff --git a/science/gnudatalanguage/pkg-plist b/science/gnudatalanguage/pkg-plist
index 9a227a5a93de..425de52293b5 100644
--- a/science/gnudatalanguage/pkg-plist
+++ b/science/gnudatalanguage/pkg-plist
@@ -1,33 +1,10 @@
%%MASTER%%bin/gdl
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/CMakeDirectoryInformation.cmake
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/check.dir/DependInfo.cmake
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/check.dir/build.make
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/check.dir/cmake_clean.cmake
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/check.dir/progress.make
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/launchtest.dir/DependInfo.cmake
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/launchtest.dir/build.make
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/launchtest.dir/cmake_clean.cmake
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/launchtest.dir/depend.make
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/launchtest.dir/flags.make
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/launchtest.dir/link.txt
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/launchtest.dir/progress.make
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/progress.marks
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/test_ce.dir/DependInfo.cmake
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/test_ce.dir/build.make
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/test_ce.dir/cmake_clean.cmake
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/test_ce.dir/depend.make
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/test_ce.dir/flags.make
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/test_ce.dir/link.txt
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/test_ce.dir/progress.make
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeLists.txt
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CTestTestfile.cmake
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/Makefile
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/Makefile.am
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/README
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/Saturn.jpg
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/benchmark/bench_matrix_multiply.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/checks
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/cmake_install.cmake
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/example.grib
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/image_test.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/launchtest.c
@@ -363,9 +340,5 @@
%%MASTER%%@dirrm %%DATADIR%%/lib
%%MASTER%%@dirrm %%DATADIR%%
%%MASTER%%%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/testsuite/benchmark
-%%MASTER%%%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/testsuite/CMakeFiles/test_ce.dir
-%%MASTER%%%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/testsuite/CMakeFiles/launchtest.dir
-%%MASTER%%%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/testsuite/CMakeFiles/check.dir
-%%MASTER%%%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/testsuite/CMakeFiles
%%MASTER%%%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/testsuite
%%MASTER%%%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%