aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
Diffstat (limited to 'science')
-rw-r--r--science/gnudatalanguage/Makefile4
-rw-r--r--science/gnudatalanguage/files/patch-CMakeLists.txt27
-rw-r--r--science/gnudatalanguage/pkg-plist27
3 files changed, 29 insertions, 29 deletions
diff --git a/science/gnudatalanguage/Makefile b/science/gnudatalanguage/Makefile
index 16ff1ae6ef8e..c7205ab6a503 100644
--- a/science/gnudatalanguage/Makefile
+++ b/science/gnudatalanguage/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnudatalanguage
DISTVERSION= 0.9.4
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= science lang
MASTER_SITES= SF/${PORTNAME}/gdl/${DISTVERSION}
.if defined(BUILD_PYTHON_MODULE)
@@ -37,7 +37,7 @@ LIB_DEPENDS+= libplplotd.so:${PORTSDIR}/math/plplot \
USE_WX= 2.8
WX_UNICODE= yes
USE_XORG= x11
-USES= pkgconfig cmake dos2unix compiler:gcc-c++11-lib
+USES= pkgconfig cmake:outsource dos2unix compiler:gcc-c++11-lib
# Disable ncurses and readline from ports
# Disable ImageMagick (does'nt work with plplot because dynamic drivers
diff --git a/science/gnudatalanguage/files/patch-CMakeLists.txt b/science/gnudatalanguage/files/patch-CMakeLists.txt
index 4a6a807e6ec8..b85763b8166b 100644
--- a/science/gnudatalanguage/files/patch-CMakeLists.txt
+++ b/science/gnudatalanguage/files/patch-CMakeLists.txt
@@ -1,5 +1,32 @@
+Includes revisions 1.50 and 1.57 from upstream:
+
+ Fri Jun 13 21:45:44 2014 UTC by gilles-duvert
+ Applied Orion's patch #77
+
+ Mon Sep 1 11:23:18 2014 UTC by alaingdl
+ patch 78 related to change in CMake 3.0
+
+Both patches are required for CMake 3.0+ support.
--- ./CMakeLists.txt.orig 2013-09-28 17:03:32.000000000 +0200
+++ ./CMakeLists.txt 2013-09-30 16:19:09.000000000 +0200
+@@ -610,13 +610,11 @@
+ message("-- Found Python executable: ${PYTHON_EXECUTABLE}")
+ endif()
+ else()
+- if(PYTHONVERSION)
+- set(PythonLibs_FIND_VERSION ${PYTHONVERSION})
+- else()
+- set(PythonLibs_FIND_VERSION 2)
++ if(NOT PYTHONVERSION)
++ set(PYTHONVERSION 2)
+ endif()
+- find_package(PythonLibs)
+- include(FindPythonInterp)
++ find_package(PythonInterp)
++ find_package(PythonLibs ${PYTHONVERSION})
+ endif()
+ set(USE_PYTHON ${PYTHONLIBS_FOUND})
+ if(PYTHONLIBS_FOUND)
@@ -752,7 +752,7 @@
endif(NOT PYTHON_MODULE)
diff --git a/science/gnudatalanguage/pkg-plist b/science/gnudatalanguage/pkg-plist
index 9a227a5a93de..425de52293b5 100644
--- a/science/gnudatalanguage/pkg-plist
+++ b/science/gnudatalanguage/pkg-plist
@@ -1,33 +1,10 @@
%%MASTER%%bin/gdl
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/CMakeDirectoryInformation.cmake
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/check.dir/DependInfo.cmake
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/check.dir/build.make
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/check.dir/cmake_clean.cmake
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/check.dir/progress.make
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/launchtest.dir/DependInfo.cmake
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/launchtest.dir/build.make
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/launchtest.dir/cmake_clean.cmake
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/launchtest.dir/depend.make
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/launchtest.dir/flags.make
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/launchtest.dir/link.txt
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/launchtest.dir/progress.make
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/progress.marks
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/test_ce.dir/DependInfo.cmake
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/test_ce.dir/build.make
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/test_ce.dir/cmake_clean.cmake
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/test_ce.dir/depend.make
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/test_ce.dir/flags.make
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/test_ce.dir/link.txt
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeFiles/test_ce.dir/progress.make
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CMakeLists.txt
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/CTestTestfile.cmake
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/Makefile
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/Makefile.am
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/README
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/Saturn.jpg
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/benchmark/bench_matrix_multiply.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/checks
-%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/cmake_install.cmake
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/example.grib
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/image_test.pro
%%MASTER%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testsuite/launchtest.c
@@ -363,9 +340,5 @@
%%MASTER%%@dirrm %%DATADIR%%/lib
%%MASTER%%@dirrm %%DATADIR%%
%%MASTER%%%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/testsuite/benchmark
-%%MASTER%%%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/testsuite/CMakeFiles/test_ce.dir
-%%MASTER%%%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/testsuite/CMakeFiles/launchtest.dir
-%%MASTER%%%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/testsuite/CMakeFiles/check.dir
-%%MASTER%%%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/testsuite/CMakeFiles
%%MASTER%%%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/testsuite
%%MASTER%%%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%