aboutsummaryrefslogtreecommitdiffstats
path: root/security/orthrus/Makefile
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-07-16 14:30:29 +0800
committerjgh <jgh@FreeBSD.org>2013-07-16 14:30:29 +0800
commit0e5ca134db5acaa54d247fc6bea75dd901f74d90 (patch)
treee37a0bb6249a498aeede24c24e6ce2661b762566 /security/orthrus/Makefile
parent2999174d1f5856084e917e44be862cd5b4ef67bb (diff)
downloadfreebsd-ports-gnome-0e5ca134db5acaa54d247fc6bea75dd901f74d90.tar.gz
freebsd-ports-gnome-0e5ca134db5acaa54d247fc6bea75dd901f74d90.tar.zst
freebsd-ports-gnome-0e5ca134db5acaa54d247fc6bea75dd901f74d90.zip
Orthrus is a C library and user interfaces for RFC 2289,
"A One-Time Password System (OTP)", also known as OPIE or S/Key. WWW: http://code.google.com/p/orthrus PR: ports/180571 Submitted by: gavin@16degrees.com.au
Diffstat (limited to 'security/orthrus/Makefile')
-rw-r--r--security/orthrus/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/security/orthrus/Makefile b/security/orthrus/Makefile
new file mode 100644
index 000000000000..22ee0375adf2
--- /dev/null
+++ b/security/orthrus/Makefile
@@ -0,0 +1,37 @@
+# Created by: Gavin McDonald <gavin@16degrees.com.au>
+# $FreeBSD$
+
+PORTNAME= orthrus
+PORTVERSION= 0.8.0
+CATEGORIES= security
+MASTER_SITES= GOOGLE_CODE \
+ http://16degrees.com.au/${PORTNAME}/
+
+MAINTAINER= gavin@16degrees.com.au
+COMMENT= One-Time Password System (OTP) alternative to OPIE or S/Key
+
+LICENSE= AL2
+
+LIB_DEPENDS= apr-1:${PORTSDIR}/devel/apr1
+
+USE_SCONS= yes
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+USES= iconv
+PORTDOCS= *
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC} && \
+ ${INSTALL_DATA} NOTICE README TODO ${DOCSDIR})
+.endif
+ ${TOUCH} ${PREFIX}/etc/orthruskeys
+
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
+.include <bsd.port.mk>