aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2018-12-20 17:02:31 +0800
committerale <ale@FreeBSD.org>2018-12-20 17:02:31 +0800
commit80b8fa78a4bba78f0cca29cd696f896d8fee2c90 (patch)
tree7a3e5219d963b403897a0daf3e08e96a79bcf3f5 /security
parent70a8799d3c3c284e3d75b00e1d5c815f6f3f2d71 (diff)
downloadfreebsd-ports-gnome-80b8fa78a4bba78f0cca29cd696f896d8fee2c90.tar.gz
freebsd-ports-gnome-80b8fa78a4bba78f0cca29cd696f896d8fee2c90.tar.zst
freebsd-ports-gnome-80b8fa78a4bba78f0cca29cd696f896d8fee2c90.zip
Fix build on GCC based architectures.
PR: 234178 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
Diffstat (limited to 'security')
-rw-r--r--security/opensc/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/security/opensc/Makefile b/security/opensc/Makefile
index c0551827f9ac..8c654f472f45 100644
--- a/security/opensc/Makefile
+++ b/security/opensc/Makefile
@@ -11,7 +11,7 @@ COMMENT= Libraries and utilities to access smart cards
LICENSE= LGPL21
-BROKEN_powerpc64= fails to compile: cc1: unrecognized command line option "-Wno-unused-but-set-variable"
+USES= libtool pkgconfig gmake ssl
OPTIONS_SINGLE= BACKEND
OPTIONS_SINGLE_BACKEND=PCSC OPENCT CTAPI
@@ -25,7 +25,6 @@ CTAPI_DESC= Use CT-API backend
SM_DESC= Enable secure messaging support
NOTIFY_DESC= Enable notification support
-USES= libtool pkgconfig gmake ssl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
@@ -67,4 +66,10 @@ CONFIGURE_ENV+= XSLTPROC="${FALSE}"
CONFIGURE_ARGS+=--without-xsl-stylesheetsdir
.endif
+post-patch:
+.if exists(/usr/lib/libstdc++.so)
+ ${REINPLACE_CMD} -e '/-Wno-unused-but-set-variable/d' \
+ ${WRKSRC}/src/tools/Makefile.am
+.endif
+
.include <bsd.port.mk>