aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/opensc/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/security/opensc/Makefile b/security/opensc/Makefile
index c0551827f9ac..8c654f472f45 100644
--- a/security/opensc/Makefile
+++ b/security/opensc/Makefile
@@ -11,7 +11,7 @@ COMMENT= Libraries and utilities to access smart cards
LICENSE= LGPL21
-BROKEN_powerpc64= fails to compile: cc1: unrecognized command line option "-Wno-unused-but-set-variable"
+USES= libtool pkgconfig gmake ssl
OPTIONS_SINGLE= BACKEND
OPTIONS_SINGLE_BACKEND=PCSC OPENCT CTAPI
@@ -25,7 +25,6 @@ CTAPI_DESC= Use CT-API backend
SM_DESC= Enable secure messaging support
NOTIFY_DESC= Enable notification support
-USES= libtool pkgconfig gmake ssl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
@@ -67,4 +66,10 @@ CONFIGURE_ENV+= XSLTPROC="${FALSE}"
CONFIGURE_ARGS+=--without-xsl-stylesheetsdir
.endif
+post-patch:
+.if exists(/usr/lib/libstdc++.so)
+ ${REINPLACE_CMD} -e '/-Wno-unused-but-set-variable/d' \
+ ${WRKSRC}/src/tools/Makefile.am
+.endif
+
.include <bsd.port.mk>