aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2018-07-13 21:26:54 +0800
committergarga <garga@FreeBSD.org>2018-07-13 21:26:54 +0800
commitcde1f6973a69c4f7a5cc947f1462a1299dd69424 (patch)
treec7609646cebbed729d3f114f89c5486736826939 /security
parenta2d1c95896e105d9b15b77872bcb5c4086400f88 (diff)
downloadfreebsd-ports-gnome-cde1f6973a69c4f7a5cc947f1462a1299dd69424.tar.gz
freebsd-ports-gnome-cde1f6973a69c4f7a5cc947f1462a1299dd69424.tar.zst
freebsd-ports-gnome-cde1f6973a69c4f7a5cc947f1462a1299dd69424.zip
New port: security/py-fteproxy
fteproxy provides transport-layer protection to resist keyword filtering, censorship and discriminatory routing policies. Its job is to relay datastreams, such as web browsing traffic, by encoding streams as messages that match a user-specified regular expression. WWW: https://fteproxy.org/ Submitted by: Vinícius Zavam <egypcio@googlemail.com> Differential Revision: https://reviews.freebsd.org/D16244
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-fteproxy/Makefile25
-rw-r--r--security/py-fteproxy/distinfo3
-rw-r--r--security/py-fteproxy/pkg-descr7
4 files changed, 36 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index d495ddc8fa72..ada158591282 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -939,6 +939,7 @@
SUBDIR += py-flask-httpauth
SUBDIR += py-flask-kerberos
SUBDIR += py-flask-saml
+ SUBDIR += py-fteproxy
SUBDIR += py-gixy
SUBDIR += py-gnupg
SUBDIR += py-gnutls
diff --git a/security/py-fteproxy/Makefile b/security/py-fteproxy/Makefile
new file mode 100644
index 000000000000..a76af8e9bf6e
--- /dev/null
+++ b/security/py-fteproxy/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= fteproxy
+DISTVERSION= 0.2.19
+CATEGORIES= security net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= egypcio@googlemail.com
+COMMENT= Programmable proxy for censorship circumvention
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twisted>=17.9.0:devel/py-twisted@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}libfte>=0.1.0:net/py-libfte@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}obfsproxy-tor>=0.2.13:security/py-obfsproxy-tor@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyptlib>=0.0.6:security/py-pyptlib@${PY_FLAVOR}
+
+USES= python:2.7
+USE_PYTHON= autoplist distutils
+
+NO_BUILD= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-fteproxy/distinfo b/security/py-fteproxy/distinfo
new file mode 100644
index 000000000000..7d4669aee8bb
--- /dev/null
+++ b/security/py-fteproxy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1531402863
+SHA256 (fteproxy-0.2.19.tar.gz) = 440494100f84e94908c7959dc8b1d176182bf21c946600acaa1cf9e5eb6ed38a
+SIZE (fteproxy-0.2.19.tar.gz) = 24846
diff --git a/security/py-fteproxy/pkg-descr b/security/py-fteproxy/pkg-descr
new file mode 100644
index 000000000000..9157a2e2f346
--- /dev/null
+++ b/security/py-fteproxy/pkg-descr
@@ -0,0 +1,7 @@
+fteproxy provides transport-layer protection to resist keyword filtering,
+censorship and discriminatory routing policies.
+
+Its job is to relay datastreams, such as web browsing traffic,
+by encoding streams as messages that match a user-specified regular expression.
+
+WWW: https://fteproxy.org/