aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-03-16 16:25:34 +0800
committervs <vs@FreeBSD.org>2005-03-16 16:25:34 +0800
commitf506b2b40334dae2bbbdf9be8be1843f2b47a7b0 (patch)
tree3e331acf9a20b7c7c01e13549fc7d46604dc4cf3 /security
parentba34add974fb87ac32970a83e816f79598d450ac (diff)
downloadfreebsd-ports-gnome-f506b2b40334dae2bbbdf9be8be1843f2b47a7b0.tar.gz
freebsd-ports-gnome-f506b2b40334dae2bbbdf9be8be1843f2b47a7b0.tar.zst
freebsd-ports-gnome-f506b2b40334dae2bbbdf9be8be1843f2b47a7b0.zip
- Update to 1.0.4 from Debian
- Include patch to make this work again with GnuPG 1.0.4. This will break support for older versions of GnuPG! Noticed by: Marcus Frings
Diffstat (limited to 'security')
-rw-r--r--security/quintuple-agent/Makefile10
-rw-r--r--security/quintuple-agent/distinfo4
-rw-r--r--security/quintuple-agent/files/patch-agpg.c21
-rw-r--r--security/quintuple-agent/files/patch-configure11
4 files changed, 41 insertions, 5 deletions
diff --git a/security/quintuple-agent/Makefile b/security/quintuple-agent/Makefile
index 4b5610e010d9..e1fc44c9ca4f 100644
--- a/security/quintuple-agent/Makefile
+++ b/security/quintuple-agent/Makefile
@@ -6,15 +6,16 @@
#
PORTNAME= quintuple-agent
-PORTVERSION= 1.0.3
-PORTREVISION= 2
+PORTVERSION= 1.0.4
CATEGORIES= security
-MASTER_SITES= http://www.vibe.at/tools/q-agent/
+MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
+DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
MAINTAINER= vs@FreeBSD.org
COMMENT= Quintuple Agent is a program that stores secrets for you
USE_GETTEXT= yes
+USE_GETOPT_LONG=yes
USE_GNOME= glib12
.ifndef(WITHOUT_X11)
USE_GNOME+= gtk12
@@ -23,6 +24,7 @@ PLIST_SUB+= X11=""
PLIST_SUB+= X11="@comment "
.endif
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.orig
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
#catgets disabled because it can't find all messages:
@@ -30,6 +32,8 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
.ifdef(WITHOUT_X11)
CONFIGURE_ARGS+=--disable-gtktest
.endif
+USE_GMAKE= yes
+MAKE_ARGS= SUBDIRS="doc intl lib m4 po . test"
MAN1= agpg.1 apgp.1 q-agent.1 secret-ask.1 q-client.1 secret-query.1
diff --git a/security/quintuple-agent/distinfo b/security/quintuple-agent/distinfo
index 7f91eab2aaf9..2022a21d17f8 100644
--- a/security/quintuple-agent/distinfo
+++ b/security/quintuple-agent/distinfo
@@ -1,2 +1,2 @@
-MD5 (quintuple-agent-1.0.3.tar.gz) = dc999c047855f2fbcd2fc79972ced6f2
-SIZE (quintuple-agent-1.0.3.tar.gz) = 195900
+MD5 (quintuple-agent_1.0.4.orig.tar.gz) = c66079ad6fbb3962aa151b79e414e233
+SIZE (quintuple-agent_1.0.4.orig.tar.gz) = 341223
diff --git a/security/quintuple-agent/files/patch-agpg.c b/security/quintuple-agent/files/patch-agpg.c
new file mode 100644
index 000000000000..61cd90a5e093
--- /dev/null
+++ b/security/quintuple-agent/files/patch-agpg.c
@@ -0,0 +1,21 @@
+--- agpg.c 2002-09-28 07:16:01.000000000 +0000
++++ agpg.c 2005-02-21 21:49:21.466050839 +0000
+@@ -100,11 +100,13 @@
+ if (id)
+ free(buf);
+ while ((len = getline(&line, &size, gpg)) > 0) {
+- if (len > 10 && !strncmp(line, "sec ", 4) && line[10] == '/') {
+- char *x;
+- if ((x = strchr(line + 11, ' ')) != NULL) {
+- *x = 0;
+- id = strdup(line + 11);
++#define GPG_SECKEYS_DELIM " \t/"
++ if (strncmp(line, "sec ", 4) == 0 &&
++ strtok(line, GPG_SECKEYS_DELIM) &&
++ strtok(NULL, GPG_SECKEYS_DELIM)) {
++ char *x;
++ if ((x = strtok(NULL, GPG_SECKEYS_DELIM)) != NULL) {
++ id = strdup(x);
+ free(line);
+ pclose(gpg);
+ return id;
diff --git a/security/quintuple-agent/files/patch-configure b/security/quintuple-agent/files/patch-configure
new file mode 100644
index 000000000000..b67b8754609f
--- /dev/null
+++ b/security/quintuple-agent/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Tue Mar 15 14:22:33 2005
++++ configure Tue Mar 15 14:22:43 2005
+@@ -9388,7 +9388,7 @@
+ _ACEOF
+
+
+- ac_config_files="$ac_config_files Makefile debian/Makefile doc/Makefile intl/Makefile lib/Makefile m4/Makefile po/Makefile.in test/Makefile"
++ ac_config_files="$ac_config_files Makefile doc/Makefile intl/Makefile lib/Makefile m4/Makefile po/Makefile.in test/Makefile"
+ cat >confcache <<\_ACEOF
+ # This file is a shell script that caches the results of configure
+ # tests run on this system so they can be shared between configure