aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2018-07-28 20:24:26 +0800
committermiwi <miwi@FreeBSD.org>2018-07-28 20:24:26 +0800
commit60309d69f045711dd1775c87664624892071969d (patch)
tree66926987106dc0fd15041e7c496893aaac563608 /textproc
parentbb80fa21f731376c6ccc18e586808b17fcb9effa (diff)
downloadfreebsd-ports-gnome-60309d69f045711dd1775c87664624892071969d.tar.gz
freebsd-ports-gnome-60309d69f045711dd1775c87664624892071969d.tar.zst
freebsd-ports-gnome-60309d69f045711dd1775c87664624892071969d.zip
This library helps with the generation of fingerprints for entity data. A
fingerprint in this context is understood as a simplified entity identifier, derived from it's name or address and used for cross-referencing of entity across different datasets. WWW: https://github.com/alephdata/fingerprints PR: 229528 Submitted by: freebsd_ports@k-worx.org Sponsored by: iXsystems Inc.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-fingerprints/Makefile27
-rw-r--r--textproc/py-fingerprints/distinfo3
-rw-r--r--textproc/py-fingerprints/pkg-descr6
4 files changed, 37 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index cc890054b63f..0b6071eea91d 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1298,6 +1298,7 @@
SUBDIR += py-et_xmlfile
SUBDIR += py-excelerator
SUBDIR += py-feedparser
+ SUBDIR += py-fingerprints
SUBDIR += py-gambit-elasticsearch
SUBDIR += py-genshi
SUBDIR += py-gensim
diff --git a/textproc/py-fingerprints/Makefile b/textproc/py-fingerprints/Makefile
new file mode 100644
index 000000000000..4506658b6f94
--- /dev/null
+++ b/textproc/py-fingerprints/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= fingerprints
+DISTVERSION= 0.5.4
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= Easy comparing and cross-referencing of companies and people
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}normality>=0.4.0:textproc/py-normality@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+post-extract:
+ # Prevents that the tests directory will be installed into site-packages
+ @(cd ${WRKSRC} && ${MV} tests test)
+
+.include <bsd.port.mk>
diff --git a/textproc/py-fingerprints/distinfo b/textproc/py-fingerprints/distinfo
new file mode 100644
index 000000000000..a331499be712
--- /dev/null
+++ b/textproc/py-fingerprints/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1530199613
+SHA256 (fingerprints-0.5.4.tar.gz) = e720fa97356c6b8e227474aa8dbeb3c10e93452820a447e632d547bdb1981c5a
+SIZE (fingerprints-0.5.4.tar.gz) = 10454
diff --git a/textproc/py-fingerprints/pkg-descr b/textproc/py-fingerprints/pkg-descr
new file mode 100644
index 000000000000..1ff1d9eb5e89
--- /dev/null
+++ b/textproc/py-fingerprints/pkg-descr
@@ -0,0 +1,6 @@
+This library helps with the generation of fingerprints for entity data. A
+fingerprint in this context is understood as a simplified entity identifier,
+derived from it's name or address and used for cross-referencing of entity
+across different datasets.
+
+WWW: https://github.com/alephdata/fingerprints