aboutsummaryrefslogtreecommitdiffstats
path: root/www/erlang-cowboy
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2015-06-27 20:54:11 +0800
committerolgeni <olgeni@FreeBSD.org>2015-06-27 20:54:11 +0800
commit099bcd87401dc59b42fe814c1e7701fe95242f03 (patch)
tree7d61b3e1ed0576b122e72f1a7f9244ea99379aba /www/erlang-cowboy
parent2b760f8d8b19c5aa1a076e10629d275bfeab0425 (diff)
downloadfreebsd-ports-gnome-099bcd87401dc59b42fe814c1e7701fe95242f03.tar.gz
freebsd-ports-gnome-099bcd87401dc59b42fe814c1e7701fe95242f03.tar.zst
freebsd-ports-gnome-099bcd87401dc59b42fe814c1e7701fe95242f03.zip
Sorting out some Erlang stuff:
- Rename a few Erlang-related ports using the erlang- prefix; it will avoid confusion with elixir- ports. - Remove DOCS and EXAMPLES where not actually useful. - Simplify RUN_DEPENDS where possible. - Move textproc/exmpp to devel/erlang-exmpp. - Add missing R18 compatibility fix for devel/erlang-oserl. - Upgrade erlang-cuttlefish to 2.0.3. The idea is that libraries ("deps") have the "erlang-" prefix, while larger projects (rabbitmq, yaws, couchdb, etc) keep their usual names.
Diffstat (limited to 'www/erlang-cowboy')
-rw-r--r--www/erlang-cowboy/Makefile34
-rw-r--r--www/erlang-cowboy/distinfo2
-rw-r--r--www/erlang-cowboy/files/patch-Makefile11
-rw-r--r--www/erlang-cowboy/pkg-descr11
-rw-r--r--www/erlang-cowboy/pkg-plist188
5 files changed, 246 insertions, 0 deletions
diff --git a/www/erlang-cowboy/Makefile b/www/erlang-cowboy/Makefile
new file mode 100644
index 000000000000..7389c3aed28d
--- /dev/null
+++ b/www/erlang-cowboy/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= cowboy
+PORTVERSION= 1.0.1
+CATEGORIES= www
+PKGNAMEPREFIX= erlang-
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= Small, fast and modular HTTP server written in Erlang
+
+LICENSE= ISCL
+
+BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang \
+ erlang-cowlib>=1.0.0:${PORTSDIR}/devel/erlang-cowlib
+RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang \
+ erlang-cowlib>=1.0.0:${PORTSDIR}/devel/erlang-cowlib \
+ erlang-ranch>=1.0.0:${PORTSDIR}/net/erlang-ranch
+
+PLIST_SUB= VERSION="${PORTVERSION}"
+
+USES= gmake
+USE_GITHUB= yes
+GH_ACCOUNT= ninenines
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/ebin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/src
+ ${INSTALL_DATA} ${WRKSRC}/ebin/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/ebin
+ ${INSTALL_DATA} ${WRKSRC}/src/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/src
+
+.include <bsd.port.mk>
diff --git a/www/erlang-cowboy/distinfo b/www/erlang-cowboy/distinfo
new file mode 100644
index 000000000000..2804a6522755
--- /dev/null
+++ b/www/erlang-cowboy/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ninenines-cowboy-1.0.1_GH0.tar.gz) = 23c7acbfbc2017c60f645ebd1fc0d000952cefedae47701a122ccd6c68b6437e
+SIZE (ninenines-cowboy-1.0.1_GH0.tar.gz) = 4790457
diff --git a/www/erlang-cowboy/files/patch-Makefile b/www/erlang-cowboy/files/patch-Makefile
new file mode 100644
index 000000000000..4cef4226c791
--- /dev/null
+++ b/www/erlang-cowboy/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig
++++ Makefile
+@@ -12,7 +12,7 @@
+
+ # Dependencies.
+
+-DEPS = cowlib ranch
++DEPS =
+ TEST_DEPS = ct_helper gun
+ dep_ct_helper = git https://github.com/extend/ct_helper.git master
+
diff --git a/www/erlang-cowboy/pkg-descr b/www/erlang-cowboy/pkg-descr
new file mode 100644
index 000000000000..927858cc6268
--- /dev/null
+++ b/www/erlang-cowboy/pkg-descr
@@ -0,0 +1,11 @@
+Cowboy aims to provide a complete HTTP stack in a small code base. It
+is optimized for low latency and low memory usage, in parts because it
+uses binary strings.
+
+Cowboy provides routing capabilities, selectively dispatching requests
+to handlers written in Erlang.
+
+Because it uses Ranch for managing connections, Cowboy can easily be
+embedded in any other application.
+
+WWW: https://github.com/extend/cowboy
diff --git a/www/erlang-cowboy/pkg-plist b/www/erlang-cowboy/pkg-plist
new file mode 100644
index 000000000000..bc6bdb062817
--- /dev/null
+++ b/www/erlang-cowboy/pkg-plist
@@ -0,0 +1,188 @@
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy.app
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_app.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_bstr.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_clock.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_handler.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_http.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_http_handler.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_loop_handler.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_middleware.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_protocol.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_req.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_rest.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_router.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_spdy.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_static.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_sub_protocol.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_sup.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_websocket.beam
+lib/erlang/lib/cowboy-%%VERSION%%/ebin/cowboy_websocket_handler.beam
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy.app.src
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_app.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_bstr.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_clock.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_handler.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_http.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_http_handler.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_loop_handler.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_middleware.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_protocol.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_req.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_rest.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_router.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_spdy.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_static.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_sub_protocol.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_sup.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_websocket.erl
+lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_websocket_handler.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/relx.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/src/chunked_hello_world.app.src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/src/chunked_hello_world_app.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/src/chunked_hello_world_sup.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chunked_hello_world/src/toppage_handler.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/relx.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/src/compress_response.app.src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/src/compress_response_app.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/src/compress_response_sup.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/compress_response/src/toppage_handler.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/relx.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/src/cookie.app.src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/src/cookie_app.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/src/cookie_sup.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/src/toppage_handler.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cookie/templates/toppage.dtl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/relx.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/src/echo_get.app.src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/src/echo_get_app.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/src/echo_get_sup.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_get/src/toppage_handler.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/relx.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/src/echo_post.app.src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/src/echo_post_app.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/src/echo_post_sup.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/echo_post/src/toppage_handler.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/relx.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/src/error_hook.app.src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/src/error_hook_app.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/error_hook/src/error_hook_sup.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/priv/index.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/relx.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/src/eventsource.app.src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/src/eventsource_app.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/src/eventsource_handler.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eventsource/src/eventsource_sup.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/relx.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/src/hello_world.app.src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/src/hello_world_app.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/src/hello_world_sup.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hello_world/src/toppage_handler.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/priv/small.mp4
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/priv/small.ogv
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/priv/video.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/relx.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/src/erlmarkdown.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/src/markdown_converter.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/src/markdown_middleware.app.src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/src/markdown_middleware_app.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/markdown_middleware/src/markdown_middleware_sup.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_basic_auth/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_basic_auth/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_basic_auth/relx.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_basic_auth/src/rest_basic_auth.app.src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_basic_auth/src/rest_basic_auth_app.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_basic_auth/src/rest_basic_auth_sup.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_basic_auth/src/toppage_handler.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/relx.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/src/rest_hello_world.app.src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/src/rest_hello_world_app.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/src/rest_hello_world_sup.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_hello_world/src/toppage_handler.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/priv/index.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/priv/index.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/relx.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/src/rest_pastebin.app.src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/src/rest_pastebin_app.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/src/rest_pastebin_sup.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_pastebin/src/toppage_handler.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/relx.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/src/rest_stream_response.app.src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/src/rest_stream_response_app.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/src/rest_stream_response_sup.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rest_stream_response/src/toppage_handler.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/priv/ssl/cowboy-ca.crt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/priv/ssl/server.crt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/priv/ssl/server.key
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/relx.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/src/ssl_hello_world.app.src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/src/ssl_hello_world_app.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/src/ssl_hello_world_sup.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl_hello_world/src/toppage_handler.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/priv/small.mp4
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/priv/small.ogv
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/priv/test.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/priv/video.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/relx.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/src/static_world.app.src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/src/static_world_app.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/static_world/src/static_world_sup.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upload/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upload/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upload/priv/index.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upload/relx.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upload/src/upload.app.src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upload/src/upload_app.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upload/src/upload_handler.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upload/src/upload_sup.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/priv/small.mp4
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/priv/small.ogv
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/priv/test.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/priv/video.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/relx.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/src/directory_handler.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/src/directory_lister.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/src/web_server.app.src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/src/web_server_app.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/web_server/src/web_server_sup.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/priv/index.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/priv/static/jquery.min.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/relx.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/src/websocket.app.src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/src/websocket_app.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/src/websocket_sup.erl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/src/ws_handler.erl