aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2011-12-29 15:30:05 +0800
committerSergey A. Osokin <osa@FreeBSD.org>2011-12-29 15:30:05 +0800
commit2e59e19637f9e8a387eee0759b25cac6fc383ca0 (patch)
treeb8665e7f2207f5c1de501cfb08924332856c0314 /www/nginx
parentf1d1d70da975eabf7bb535da34df161e893967f1 (diff)
downloadfreebsd-ports-gnome-2e59e19637f9e8a387eee0759b25cac6fc383ca0.tar.gz
freebsd-ports-gnome-2e59e19637f9e8a387eee0759b25cac6fc383ca0.tar.zst
freebsd-ports-gnome-2e59e19637f9e8a387eee0759b25cac6fc383ca0.zip
Update third-party ngx_postgres module from 0.8 to 0.9.
Also remove needless patch. Do not bump PORTREVISION because these modules disabled by default. <ChangeLog> * Improve debug logging. From Yichun Zhang (agentzh). * Fix compatibility with poll, select and /dev/poll event models. Reported by Yichun Zhang (agentzh). * Fix compatibility with PostgreSQL 9.x. Reported by Yichun Zhang (agentzh). * Fix compatibility with nginx-1.1.4+. From Yichun Zhang (agentzh). * Enforce writing of proper SQL queries by replacing "row <row>" output format with "text" and returning whole result-set with values separated by newlines when using "postgres_output" directive. * Enforce writing of proper SQL queries by requiring result-set to contain exactly single value when using "binary_value" or "value" output formats when using "postgres_output" directive. * Fix "duplicated last chunk" issue. Reported by Silly Sad, diagnosed by Maxim Dounin. * Improve build-time PostgreSQL client library discovery process by using PostgreSQL's pg_config. Patch from Silly Sad. </ChangeLog>
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile2
-rw-r--r--www/nginx/distinfo4
-rw-r--r--www/nginx/files/extra-patch-ngx_postgres::config6
3 files changed, 6 insertions, 6 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 6a083c15d364..6c733be9b51d 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -487,7 +487,7 @@ CFLAGS+= -DNDEBUG
.if defined(WITH_POSTGRES_MODULE)
USE_PGSQL= yes
-NGINX_POSTGRES_MODULE_VERSION= 0.8
+NGINX_POSTGRES_MODULE_VERSION= 0.9
MASTER_SITES+= http://labs.frickle.com/files/:postgres
DISTFILES+= ngx_postgres-${NGINX_POSTGRES_MODULE_VERSION}.tar.gz:postgres
CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_postgres-${NGINX_POSTGRES_MODULE_VERSION}
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index 611f18ef3b38..22e8666c7d67 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -60,8 +60,8 @@ SHA256 (naxsi-0.42.tar.gz) = 94a08f6cb08d2a5b199cb4ad17caaa7509c959abaf50f254e46
SIZE (naxsi-0.42.tar.gz) = 43840
SHA256 (passenger-3.0.11.tar.gz) = 7bbabfafb9d7f4e1beb6a231dea1fe68d540910ceafec6469f51187a43d8ee4e
SIZE (passenger-3.0.11.tar.gz) = 2378398
-SHA256 (ngx_postgres-0.8.tar.gz) = 321de5ddfe95da45550a2b1d29cfcd425ed7d7d63edb0e086406486675d04283
-SIZE (ngx_postgres-0.8.tar.gz) = 40108
+SHA256 (ngx_postgres-0.9.tar.gz) = aac0141e73b5c440927b7e040072f120b36e49deb2ff36ad00ff96a80622fbec
+SIZE (ngx_postgres-0.9.tar.gz) = 41022
SHA256 (agentzh-redis2-nginx-module-v0.07-0-g6f7fc37.tar.gz) = 3fbc76fbf60e02e879184b28cb9e834a4bb8f10ecd073ebd3cc585c469650b1a
SIZE (agentzh-redis2-nginx-module-v0.07-0-g6f7fc37.tar.gz) = 23458
SHA256 (agentzh-set-misc-nginx-module-v0.22rc3-0-g7adef5a.tar.gz) = 3fab5dcd2fc653983c4295a6223ddb42283b06ac739131a45470aa084b17c402
diff --git a/www/nginx/files/extra-patch-ngx_postgres::config b/www/nginx/files/extra-patch-ngx_postgres::config
index 1b00e802dcce..cfba3278ca87 100644
--- a/www/nginx/files/extra-patch-ngx_postgres::config
+++ b/www/nginx/files/extra-patch-ngx_postgres::config
@@ -1,6 +1,6 @@
---- ../ngx_postgres-0.8/config.orig 2011-07-12 19:06:52.000000000 +0400
-+++ ../ngx_postgres-0.8/config 2011-07-12 19:07:42.000000000 +0400
-@@ -29,12 +29,12 @@
+--- ../ngx_postgres-0.9/config.orig 2011-12-29 11:17:24.000000000 +0400
++++ ../ngx_postgres-0.9/config 2011-12-29 11:18:47.000000000 +0400
+@@ -48,12 +48,12 @@
if [ $ngx_found = no ]; then
# FreeBSD