aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2019-01-22 22:44:38 +0800
committerGuido Falsi <madpilot@FreeBSD.org>2019-01-22 22:44:38 +0800
commit41ff4e536e680bc94d0949bc7708ddfe6f5646a7 (patch)
tree0b87a1825693d30844e1b681ab080746ab147896 /x11-wm
parentec5f7eb8bb72b6cf44e7b35905514df560d5f22b (diff)
downloadfreebsd-ports-gnome-41ff4e536e680bc94d0949bc7708ddfe6f5646a7.tar.gz
freebsd-ports-gnome-41ff4e536e680bc94d0949bc7708ddfe6f5646a7.tar.zst
freebsd-ports-gnome-41ff4e536e680bc94d0949bc7708ddfe6f5646a7.zip
Clenup xfce ports:
- Add missing dependencies - Remove unneeded patches - Regenerate and rename legacy patches - Add NLS option to ports providing such a knob, and missing the option - Add INSTALL_TARGET=install-strip where missing - Sort things - Remove unneeded += - Cosmetic changes to OPTION related variables to improve readability - Update WWW - Silence portlint warnings about variables order - Bump PORTREVISION where changing dependencies and/or adding install-strip
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/xfce4-desktop/Makefile30
-rw-r--r--x11-wm/xfce4-desktop/pkg-descr2
-rw-r--r--x11-wm/xfce4-panel/Makefile26
-rw-r--r--x11-wm/xfce4-panel/files/patch-configure11
-rw-r--r--x11-wm/xfce4-panel/pkg-descr2
-rw-r--r--x11-wm/xfce4-session/Makefile32
-rw-r--r--x11-wm/xfce4-session/files/patch-configure11
-rw-r--r--x11-wm/xfce4-session/pkg-descr2
-rw-r--r--x11-wm/xfce4-wm/Makefile27
-rw-r--r--x11-wm/xfce4-wm/files/patch-configure11
10 files changed, 69 insertions, 85 deletions
diff --git a/x11-wm/xfce4-desktop/Makefile b/x11-wm/xfce4-desktop/Makefile
index 84b2c2430a94..112070e04868 100644
--- a/x11-wm/xfce4-desktop/Makefile
+++ b/x11-wm/xfce4-desktop/Makefile
@@ -20,26 +20,30 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= gettext-tools gmake pkgconfig tar:bzip2 xfce
-GNU_CONFIGURE= yes
-INSTALLS_ICONS= yes
-USE_GNOME= glib20 gtk20 intltool libwnck cairo
+USES= gettext-tools gmake gnome pkgconfig tar:bzip2 xfce
+USE_GNOME= cairo glib20 gtk20 intltool libwnck
USE_XFCE= garcon libexo
USE_XORG= ice sm x11
+
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
-CONFIGURE_ARGS+=--enable-gio-unix \
+CONFIGURE_ARGS= --enable-gio-unix \
--enable-notifications
-OPTIONS_DEFINE= NLS THUNAR
-OPTIONS_DEFAULT= THUNAR
-NLS_USES= gettext-runtime
-NLS_CONFIGURE_ENABLE= nls
-THUNAR_USE= xfce=thunar
+OPTIONS_DEFINE= NLS THUNAR
+OPTIONS_DEFAULT= THUNAR
+OPTIONS_SUB= yes
+
+THUNAR_DESC= Thunar file manager support
+
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext-runtime
+
THUNAR_CONFIGURE_ENABLE= thunarx
-THUNAR_CONFIGURE_WITH= file-manager-fallback=Thunar
-THUNAR_DESC= Thunar file manager support
-OPTIONS_SUB= yes
+THUNAR_CONFIGURE_WITH= file-manager-fallback=Thunar
+THUNAR_USE= xfce=thunar
post-patch-NLS-off:
@${REINPLACE_CMD} -e 's|po ||' ${WRKSRC}/Makefile.in
diff --git a/x11-wm/xfce4-desktop/pkg-descr b/x11-wm/xfce4-desktop/pkg-descr
index 22d53b28d0a8..146c608ec64a 100644
--- a/x11-wm/xfce4-desktop/pkg-descr
+++ b/x11-wm/xfce4-desktop/pkg-descr
@@ -1,4 +1,4 @@
The desktop manager sets the background image, and provides a root
window menu, desktop icons or minimized icons and windows list.
-WWW: http://www.xfce.org/
+WWW: https://www.xfce.org/
diff --git a/x11-wm/xfce4-panel/Makefile b/x11-wm/xfce4-panel/Makefile
index a460a84e8c1e..f0e403c6a82a 100644
--- a/x11-wm/xfce4-panel/Makefile
+++ b/x11-wm/xfce4-panel/Makefile
@@ -20,28 +20,30 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-PORTSCOUT= limit:^4\.12\.
-
-USES= desktop-file-utils gmake libtool pathfix gettext-tools perl5 \
- pkgconfig tar:bzip2
-GNU_CONFIGURE= yes
-INSTALLS_ICONS= yes
-USE_GNOME= glib20 gtk20 intltool intlhack libwnck cairo
+USES= desktop-file-utils gettext-tools gmake gnome libtool pathfix \
+ perl5 pkgconfig tar:bzip2
+USE_GNOME= cairo glib20 gtk20 intlhack intltool libwnck
USE_LDCONFIG= yes
USE_XFCE= garcon libexo
USE_XORG= ice sm x11 xext
-INSTALL_TARGET= install-strip
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+INSTALL_TARGET= install-strip
CONFIGURE_ARGS+=--enable-gio-unix --without-html-dir
+PORTSCOUT= limit:^4\.12\.
+
OPTIONS_DEFINE= GTK3 NLS
OPTIONS_DEFAULT= GTK3
-GTK3_USES= xfce:gtk3
-GTK3_USE= gnome=gtk30
+OPTIONS_SUB= yes
+
GTK3_CONFIGURE_ENABLE= gtk3
+GTK3_USE= gnome=gtk30
GTK3_USES_OFF= xfce
-NLS_USES= gettext-runtime
+GTK3_USES= xfce:gtk3
+
NLS_CONFIGURE_ENABLE= nls
-OPTIONS_SUB= yes
+NLS_USES= gettext-runtime
.include <bsd.port.mk>
diff --git a/x11-wm/xfce4-panel/files/patch-configure b/x11-wm/xfce4-panel/files/patch-configure
deleted file mode 100644
index 0e8f87e6633d..000000000000
--- a/x11-wm/xfce4-panel/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig 2017-12-13 23:14:34 UTC
-+++ configure
-@@ -14100,7 +14100,7 @@ $as_echo "#define HAVE_LC_MESSAGES 1" >>confdefs.h
-
- fi
- fi
-- USE_NLS=yes
-+# USE_NLS=yes
-
-
- gt_cv_have_gettext=no
diff --git a/x11-wm/xfce4-panel/pkg-descr b/x11-wm/xfce4-panel/pkg-descr
index ecc6a3e0ba7c..58d9370e2908 100644
--- a/x11-wm/xfce4-panel/pkg-descr
+++ b/x11-wm/xfce4-panel/pkg-descr
@@ -1,4 +1,4 @@
The panel supports multiple panels, with many options for their
position, appearance, transparency and behavior.
-WWW: http://docs.xfce.org/xfce/xfce4-panel/start
+WWW: https://docs.xfce.org/xfce/xfce4-panel/start
diff --git a/x11-wm/xfce4-session/Makefile b/x11-wm/xfce4-session/Makefile
index b06abac96ece..ae8a8ebc0a20 100644
--- a/x11-wm/xfce4-session/Makefile
+++ b/x11-wm/xfce4-session/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xfce4-session
PORTVERSION= 4.12.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11-wm xfce
MASTER_SITES= XFCE/src/xfce/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
@@ -17,28 +17,32 @@ BUILD_DEPENDS= iceauth:x11/iceauth
RUN_DEPENDS= iceauth:x11/iceauth \
console-kit-daemon:sysutils/consolekit2
LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
+ libdbus-1.so:devel/dbus \
libupower-glib.so:sysutils/upower \
- libpolkit-gobject-1.so:sysutils/polkit
+ libpolkit-gobject-1.so:sysutils/polkit \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
-GNU_CONFIGURE= yes
-INSTALLS_ICONS= yes
-USE_GNOME= gtk20 glib20 intltool intlhack libwnck
-USES= pathfix pkgconfig gmake libtool gettext-tools xfce tar:bzip2
+USES= gettext-tools gmake gnome libtool pathfix pkgconfig \
+ tar:bzip2 xfce
+USE_GNOME= cairo gtk20 glib20 intlhack intltool libwnck
USE_LDCONFIG= yes
USE_XFCE= libmenu
-USE_XORG= x11 sm ice
+USE_XORG= ice sm x11
-CONFIGURE_ARGS+=--enable-legacy-sm \
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+CONFIGURE_ARGS= --enable-legacy-sm \
--with-xsession-prefix=${PREFIX}
-
SUB_FILES= pkg-message
+PLIST_SUB= VERSION="4.6"
+INSTALL_TARGET= install-strip
-OPTIONS_DEFINE= NLS
-NLS_USES= gettext-runtime
-NLS_CONFIGURE_ENABLE= nls
-OPTIONS_SUB= yes
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
-PLIST_SUB= VERSION="4.6"
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext-runtime
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
diff --git a/x11-wm/xfce4-session/files/patch-configure b/x11-wm/xfce4-session/files/patch-configure
deleted file mode 100644
index aa31d0998179..000000000000
--- a/x11-wm/xfce4-session/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./configure.orig 2012-04-28 20:43:34.000000000 +0000
-+++ ./configure 2013-04-24 23:04:07.000000000 +0000
-@@ -14200,7 +14200,7 @@
-
- fi
- fi
-- USE_NLS=yes
-+# USE_NLS=yes
-
-
- gt_cv_have_gettext=no
diff --git a/x11-wm/xfce4-session/pkg-descr b/x11-wm/xfce4-session/pkg-descr
index e38b77ededea..1c90b569402c 100644
--- a/x11-wm/xfce4-session/pkg-descr
+++ b/x11-wm/xfce4-session/pkg-descr
@@ -2,4 +2,4 @@ The Xfce session manager controls the loading of applications when
Xfce is started. It also handles logging out, shutting down, and
rebooting.
-WWW: http://www.xfce.org/
+WWW: https://www.xfce.org/
diff --git a/x11-wm/xfce4-wm/Makefile b/x11-wm/xfce4-wm/Makefile
index a1f5ddab2e39..1e7cbe6b6590 100644
--- a/x11-wm/xfce4-wm/Makefile
+++ b/x11-wm/xfce4-wm/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xfce4-wm
PORTVERSION= 4.12.5
+PORTREVISION= 1
CATEGORIES= x11-wm xfce
MASTER_SITES= XFCE/src/xfce/xfwm4/${PORTVERSION:R}
DISTNAME= xfwm4-${PORTVERSION}
@@ -18,6 +19,12 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
+USES= gettext-tools gmake gnome pkgconfig tar:bzip2 xfce
+USE_GNOME= cairo gtk20 intltool libwnck
+USE_XFCE= libmenu
+USE_XORG= ice sm x11 xcomposite xdamage xext xfixes xinerama \
+ xrandr xrender
+
CONFIGURE_ARGS= --enable-xsync \
--enable-render \
--enable-randr \
@@ -25,22 +32,22 @@ CONFIGURE_ARGS= --enable-xsync \
--disable-kde-systray
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USES= gettext-tools gmake pkgconfig tar:bzip2 xfce
-USE_GNOME= gtk20 intltool libwnck cairo
-USE_XFCE= libmenu
-USE_XORG= ice sm x11 xcomposite xdamage xext xfixes xrandr xrender
DATADIR= ${PREFIX}/share/xfwm4
OPTIONS_DEFINE= DRM NLS STARTUP
OPTIONS_DEFAULT= STARTUP
-DRM_DESC= Direct Rendering Module service
-STARTUP_DESC= Startup notification
-DRM_LIB_DEPENDS= libdrm.so:graphics/libdrm
+OPTIONS_SUB= yes
+
+DRM_DESC= Direct Rendering Module service
+STARTUP_DESC= Startup notification
+
DRM_CONFIGURE_ENABLE= libdrm
-NLS_USES= gettext-runtime
+DRM_LIB_DEPENDS= libdrm.so:graphics/libdrm
+
NLS_CONFIGURE_ENABLE= nls
-STARTUP_LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification
+NLS_USES= gettext-runtime
+
STARTUP_CONFIGURE_ENABLE= startup-notification
-OPTIONS_SUB= yes
+STARTUP_LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification
.include <bsd.port.mk>
diff --git a/x11-wm/xfce4-wm/files/patch-configure b/x11-wm/xfce4-wm/files/patch-configure
deleted file mode 100644
index 5faf072d744f..000000000000
--- a/x11-wm/xfce4-wm/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig 2018-07-29 12:57:35 UTC
-+++ configure
-@@ -14015,7 +14015,7 @@ $as_echo "#define HAVE_LC_MESSAGES 1" >>confdefs.h
-
- fi
- fi
-- USE_NLS=yes
-+# USE_NLS=yes
-
-
- gt_cv_have_gettext=no