aboutsummaryrefslogtreecommitdiffstats
path: root/x11/py-qt4-opengl
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-11-23 04:18:37 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2018-11-23 04:18:37 +0800
commitcc8a667aa283dbd1c377aa55dd4b47568cebc6b9 (patch)
tree61cb3664013fb792e76869e17b47783aadc54052 /x11/py-qt4-opengl
parent9ea8c5a60afa67ef2f40c0e73594522c3aec51a6 (diff)
downloadfreebsd-ports-gnome-cc8a667aa283dbd1c377aa55dd4b47568cebc6b9.tar.gz
freebsd-ports-gnome-cc8a667aa283dbd1c377aa55dd4b47568cebc6b9.tar.zst
freebsd-ports-gnome-cc8a667aa283dbd1c377aa55dd4b47568cebc6b9.zip
pyqt: Change install directories for Python flavor support
* PyQt could not be installed for multiple Python versions at the same time, as there were conflicting files. This patch creates Python-version versioned directories for all these, and further installs binaries with a version number. * Note, there might be some hickups for software that depends on on of the .so's provided by PyQt5, which might not be found anymore autmotically, and maybe need some LD-flaggery. * Update PyQt5 to 5.10.1 * Mark www/py-qt5-webengine broken. It is unforuntately no longer compatible with the old qt5-webengine-5.9.4 we ship. PR: 232745 Exp-run by: antoine Differential Revision: https://reviews.freebsd.org/D8714
Diffstat (limited to 'x11/py-qt4-opengl')
-rw-r--r--x11/py-qt4-opengl/Makefile6
-rw-r--r--x11/py-qt4-opengl/pkg-plist2
2 files changed, 4 insertions, 4 deletions
diff --git a/x11/py-qt4-opengl/Makefile b/x11/py-qt4-opengl/Makefile
index cba0d335ecfd..a5c6e719afe7 100644
--- a/x11/py-qt4-opengl/Makefile
+++ b/x11/py-qt4-opengl/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= opengl
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= x11 devel python
@@ -15,7 +15,7 @@ PYQT_DIST= yes
USES= python pyqt:4 qt:4
USE_GL= gl
USE_PYQT= sip_build core_run gui_run
-USE_PYTHON= flavors
+USE_PYTHON= concurrent flavors py3kplist
USE_QT= corelib gui opengl moc_build qmake_build
OPTIONS_DEFINE= API DEBUG
@@ -23,7 +23,7 @@ OPTIONS_DEFAULT=API
OPTIONS_SUB= yes
API_DESC= Install QtOpenGL API for QScintilla2
-API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${QSCIDIR}
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${PYQT_APIDIR}
API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2_qt4.so:devel/qscintilla2
DEBUG_CONFIGURE_ON= --debug --trace
diff --git a/x11/py-qt4-opengl/pkg-plist b/x11/py-qt4-opengl/pkg-plist
index bb957945f5c3..c4eaf8ad72d3 100644
--- a/x11/py-qt4-opengl/pkg-plist
+++ b/x11/py-qt4-opengl/pkg-plist
@@ -6,4 +6,4 @@
%%PYQT_SIPDIR%%/QtOpenGL/qglframebufferobject.sip
%%PYQT_SIPDIR%%/QtOpenGL/qglpixelbuffer.sip
%%PYQT_SIPDIR%%/QtOpenGL/qglshaderprogram.sip
-%%API%%share/qt4/qsci/api/python/QtOpenGL.api
+%%API%%%%PYQT_APIDIR%%/api/python/QtOpenGL.api