aboutsummaryrefslogtreecommitdiffstats
path: root/x11/py-qt4-opengl
diff options
context:
space:
mode:
Diffstat (limited to 'x11/py-qt4-opengl')
-rw-r--r--x11/py-qt4-opengl/Makefile6
-rw-r--r--x11/py-qt4-opengl/pkg-plist2
2 files changed, 4 insertions, 4 deletions
diff --git a/x11/py-qt4-opengl/Makefile b/x11/py-qt4-opengl/Makefile
index cba0d335ecfd..a5c6e719afe7 100644
--- a/x11/py-qt4-opengl/Makefile
+++ b/x11/py-qt4-opengl/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= opengl
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= x11 devel python
@@ -15,7 +15,7 @@ PYQT_DIST= yes
USES= python pyqt:4 qt:4
USE_GL= gl
USE_PYQT= sip_build core_run gui_run
-USE_PYTHON= flavors
+USE_PYTHON= concurrent flavors py3kplist
USE_QT= corelib gui opengl moc_build qmake_build
OPTIONS_DEFINE= API DEBUG
@@ -23,7 +23,7 @@ OPTIONS_DEFAULT=API
OPTIONS_SUB= yes
API_DESC= Install QtOpenGL API for QScintilla2
-API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${QSCIDIR}
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${PYQT_APIDIR}
API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2_qt4.so:devel/qscintilla2
DEBUG_CONFIGURE_ON= --debug --trace
diff --git a/x11/py-qt4-opengl/pkg-plist b/x11/py-qt4-opengl/pkg-plist
index bb957945f5c3..c4eaf8ad72d3 100644
--- a/x11/py-qt4-opengl/pkg-plist
+++ b/x11/py-qt4-opengl/pkg-plist
@@ -6,4 +6,4 @@
%%PYQT_SIPDIR%%/QtOpenGL/qglframebufferobject.sip
%%PYQT_SIPDIR%%/QtOpenGL/qglpixelbuffer.sip
%%PYQT_SIPDIR%%/QtOpenGL/qglshaderprogram.sip
-%%API%%share/qt4/qsci/api/python/QtOpenGL.api
+%%API%%%%PYQT_APIDIR%%/api/python/QtOpenGL.api