aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-08-03 06:37:40 +0800
committerMichael Nottebrock <lofi@FreeBSD.org>2007-08-03 06:37:40 +0800
commite332496be5f6fa4fa10c72920241b6910a69ca00 (patch)
tree7c1e4ee6690abd492b16853205c1bf65c308e4fb /x11
parenta89bbaf869b99b813eb1a147e18884857d7e5495 (diff)
downloadfreebsd-ports-gnome-e332496be5f6fa4fa10c72920241b6910a69ca00.tar.gz
freebsd-ports-gnome-e332496be5f6fa4fa10c72920241b6910a69ca00.tar.zst
freebsd-ports-gnome-e332496be5f6fa4fa10c72920241b6910a69ca00.zip
- bsd.qt.mk:
QT_COMPONENTS can now be depended on at runtime or buildtime only by specifiying them as <component>_build or <component>_run, respectively. Specifying <component> without any suffix will depend on the component at both build- and runtime just like before. - Convert Qt core ports to use the new dependency switches. - Add a patch to corelib to fix Qt4 on ARM, submitted by: Björn König <bkoenig@alpha-tierchen.de>
Diffstat (limited to 'x11')
-rw-r--r--x11/qt4-inputmethods/Makefile6
-rw-r--r--x11/qt4-inputmethods/pkg-plist2
-rw-r--r--x11/qt4-opengl/Makefile6
-rw-r--r--x11/qt4-opengl/pkg-plist2
4 files changed, 6 insertions, 10 deletions
diff --git a/x11/qt4-inputmethods/Makefile b/x11/qt4-inputmethods/Makefile
index f836361f37bb..c9b569ce84ad 100644
--- a/x11/qt4-inputmethods/Makefile
+++ b/x11/qt4-inputmethods/Makefile
@@ -19,7 +19,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt input method plugins
USE_QT_VER= 4
-QT_COMPONENTS= qmake moc corelib gui
+QT_COMPONENTS= qmake_build moc_build corelib gui
QT_NONSTANDARD= yes
QT_DIST= yes
@@ -43,8 +43,6 @@ EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
WRKSRC= ${WRKDIR}/${DISTNAME}/src/plugins/${PORTNAME}
CONFIGURE_WRKSRC=${WRKSRC}/../../..
-.include <bsd.port.pre.mk>
-
pre-configure:
${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib/plugins/inputmethods|g' \
@@ -53,4 +51,4 @@ pre-configure:
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../../bin/qmake
${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../../bin/moc
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/qt4-inputmethods/pkg-plist b/x11/qt4-inputmethods/pkg-plist
index a74e769e120c..b3ac7fe02e28 100644
--- a/x11/qt4-inputmethods/pkg-plist
+++ b/x11/qt4-inputmethods/pkg-plist
@@ -1,3 +1,3 @@
lib/plugins/inputmethods/libqimsw-multi.so
-lib/plugins/inputmethods/libqimsw-multi.so.debug
+%%DEBUG%%lib/plugins/inputmethods/libqimsw-multi.so.debug
@dirrm lib/plugins/inputmethods
diff --git a/x11/qt4-opengl/Makefile b/x11/qt4-opengl/Makefile
index 5bbe7cf165d8..06fc7a9437a2 100644
--- a/x11/qt4-opengl/Makefile
+++ b/x11/qt4-opengl/Makefile
@@ -19,7 +19,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt OpenGL library
USE_QT_VER= 4
-QT_COMPONENTS= qmake moc corelib gui
+QT_COMPONENTS= qmake_build moc_build corelib gui
QT_NONSTANDARD= yes
QT_DIST= yes
@@ -47,8 +47,6 @@ EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
WRKSRC= ${WRKDIR}/${DISTNAME}/src/${PORTNAME}
CONFIGURE_WRKSRC=${WRKSRC}/../../
-.include <bsd.port.pre.mk>
-
pre-configure:
${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib|g' \
@@ -67,4 +65,4 @@ post-configure:
-E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
${WRKSRC}/../../lib/pkgconfig/*Qt*
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/qt4-opengl/pkg-plist b/x11/qt4-opengl/pkg-plist
index 876fccd7e413..7c246915cae5 100644
--- a/x11/qt4-opengl/pkg-plist
+++ b/x11/qt4-opengl/pkg-plist
@@ -20,6 +20,6 @@ lib/libQtOpenGL.so
lib/libQtOpenGL.so.4
lib/libQtOpenGL.so.4.3
lib/libQtOpenGL.so.4.3.0
-lib/libQtOpenGL.so.4.3.0.debug
+%%DEBUG%%lib/libQtOpenGL.so.4.3.0.debug
libdata/pkgconfig/QtOpenGL.pc
@dirrm include/QtOpenGL