aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/forked-daapd/Makefile9
-rw-r--r--audio/sayonara/Makefile4
-rw-r--r--biology/vcftools/Makefile3
-rw-r--r--databases/monetdb/files/patch-configure87
-rw-r--r--devel/bennugd-core/Makefile4
-rw-r--r--devel/bennugd-modules/Makefile1
-rw-r--r--devel/liborcus/Makefile1
-rw-r--r--devel/liborcus07/Makefile1
-rw-r--r--devel/love/Makefile2
-rw-r--r--emulators/mupen64plus-core/files/patch-source_mupen64plus-core_projects_unix_Makefile26
-rw-r--r--emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-projects-unix_Makefile11
-rw-r--r--games/easyrpg-player/Makefile8
-rw-r--r--graphics/zathura/Makefile2
-rw-r--r--mail/notmuch/Makefile8
-rw-r--r--multimedia/mkvtoolnix/Makefile2
-rw-r--r--net-mgmt/seafile-client/files/patch-configure.ac35
-rw-r--r--net-mgmt/seafile-server/files/patch-configure.ac35
-rw-r--r--net-p2p/transmission-cli/Makefile3
-rw-r--r--news/nzbget/Makefile2
-rw-r--r--news/pan/Makefile2
-rw-r--r--print/cups-filters/Makefile3
-rw-r--r--print/libmspub01/Makefile1
-rw-r--r--security/openvas-libraries/files/patch-base-CMakeLists.txt12
-rw-r--r--textproc/libe-book/Makefile3
-rw-r--r--www/aria2/Makefile2
-rw-r--r--www/nghttp2/Makefile4
-rw-r--r--www/spdylay/Makefile4
27 files changed, 18 insertions, 257 deletions
diff --git a/audio/forked-daapd/Makefile b/audio/forked-daapd/Makefile
index fd69d23be5f4..663fe45d3c8c 100644
--- a/audio/forked-daapd/Makefile
+++ b/audio/forked-daapd/Makefile
@@ -53,14 +53,7 @@ LASTFM_CONFIGURE_ENABLE=lastfm
LASTFM_LIB_DEPENDS= libcurl.so:ftp/curl
MPD_CONFIGURE_ENABLE= mpd
-.include <bsd.port.pre.mk>
-
-# Ensure FreeBSD 9 can find zlib library
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000712
-CONFIGURE_ENV+= ZLIB_CFLAGS="-I/usr/include" ZLIB_LIBS="-lz"
-.endif
-
post-install:
@${MV} ${STAGEDIR}${PREFIX}/etc/forked-daapd.conf ${STAGEDIR}${PREFIX}/etc/forked-daapd.conf.sample
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/sayonara/Makefile b/audio/sayonara/Makefile
index 440fcef21752..45b2a0a88f5c 100644
--- a/audio/sayonara/Makefile
+++ b/audio/sayonara/Makefile
@@ -30,9 +30,5 @@ post-patch:
${WRKSRC}/resources/CMakeLists.txt
@${REINPLACE_CMD} -e '/DESTINATION/s,/usr/,,' \
${WRKSRC}/src/GUI/Resources/Icons/CMakeLists.txt
-.if !exists(/usr/libdata/pkgconfig/zlib.pc)
- @${REINPLACE_CMD} -e '/zlib/s/PKG_CHECK_MODULES/FIND_PACKAGE/' \
- ${WRKSRC}/src/Helper/Compressor/CMakeLists.txt
-.endif
.include <bsd.port.mk>
diff --git a/biology/vcftools/Makefile b/biology/vcftools/Makefile
index 881599ad3def..0c55b96fef55 100644
--- a/biology/vcftools/Makefile
+++ b/biology/vcftools/Makefile
@@ -14,9 +14,6 @@ LICENSE= LGPL3
USES= autoreconf gmake perl5 pkgconfig
GNU_CONFIGURE= yes
-# No zlib.pc on 9.x
-CONFIGURE_ENV= ZLIB_CFLAGS=" " ZLIB_LIBS="-lz"
-
USE_GITHUB= yes
.include <bsd.port.mk>
diff --git a/databases/monetdb/files/patch-configure b/databases/monetdb/files/patch-configure
index 0fce7bd2eedf..7285966d7be9 100644
--- a/databases/monetdb/files/patch-configure
+++ b/databases/monetdb/files/patch-configure
@@ -9,90 +9,3 @@
*)
if test "x$enable_jaql" = xyes; then
as_fn_error $? "MonetDB/JAQL requires flex" "$LINENO" 5
-@@ -17802,6 +17802,7 @@
- /* end confdefs.h. */
- #include <stdio.h>
- #include <bzlib.h>
-+#include <zlib.h>
- int
- main ()
- {
-@@ -20575,76 +20576,9 @@
-
-
- pkg_failed=no
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for zlib" >&5
--$as_echo_n "checking for zlib... " >&6; }
--
--if test -n "$zlib_CFLAGS"; then
-- pkg_cv_zlib_CFLAGS="$zlib_CFLAGS"
-- elif test -n "$PKG_CONFIG"; then
-- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"zlib\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "zlib") 2>&5
-- ac_status=$?
-- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-- test $ac_status = 0; }; then
-- pkg_cv_zlib_CFLAGS=`$PKG_CONFIG --cflags "zlib" 2>/dev/null`
-- test "x$?" != "x0" && pkg_failed=yes
--else
-- pkg_failed=yes
--fi
-- else
-- pkg_failed=untried
--fi
--if test -n "$zlib_LIBS"; then
-- pkg_cv_zlib_LIBS="$zlib_LIBS"
-- elif test -n "$PKG_CONFIG"; then
-- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"zlib\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "zlib") 2>&5
-- ac_status=$?
-- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-- test $ac_status = 0; }; then
-- pkg_cv_zlib_LIBS=`$PKG_CONFIG --libs "zlib" 2>/dev/null`
-- test "x$?" != "x0" && pkg_failed=yes
--else
-- pkg_failed=yes
--fi
-- else
-- pkg_failed=untried
--fi
--
--
--
--if test $pkg_failed = yes; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
--
--if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
-- _pkg_short_errors_supported=yes
--else
-- _pkg_short_errors_supported=no
--fi
-- if test $_pkg_short_errors_supported = yes; then
-- zlib_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "zlib" 2>&1`
-- else
-- zlib_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "zlib" 2>&1`
-- fi
-- # Put the nasty error message in config.log where it belongs
-- echo "$zlib_PKG_ERRORS" >&5
--
-- have_zlib="no"; why_have_zlib="(zlib not found)"
--elif test $pkg_failed = untried; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
-- have_zlib="no"; why_have_zlib="(zlib not found)"
--else
-- zlib_CFLAGS=$pkg_cv_zlib_CFLAGS
-- zlib_LIBS=$pkg_cv_zlib_LIBS
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
--$as_echo "yes" >&6; }
- have_zlib="yes"
--fi
--if test x"$have_zlib" = x"yes" ; then
-+
-+if x"$have_zlib" = x"yes" ; then
-
- $as_echo "#define HAVE_LIBZ 1" >>confdefs.h
-
diff --git a/devel/bennugd-core/Makefile b/devel/bennugd-core/Makefile
index 8c3de4c04208..728c7ba6443f 100644
--- a/devel/bennugd-core/Makefile
+++ b/devel/bennugd-core/Makefile
@@ -12,7 +12,7 @@ DISTNAME= bennugd-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= High level open source game development suite, core libs
-USES= dos2unix libtool tar:bzip2
+USES= dos2unix libtool pkgconfig tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --bindir="${PREFIX}/libexec"
SUB_FILES= bgdc bgdi
@@ -23,8 +23,6 @@ INSTALL_TARGET= install-strip
ONLY_FOR_ARCHS= i386
ONLY_FOR_ARCHS_REASON= Segfaults on !i386
-CONFIGURE_ENV= ZLIB_CFLAGS=" " ZLIB_LIBS="-lz"
-
WRKSRC= ${WRKDIR}/bennugd/${PORTNAME}
PLIST_FILES= bin/bgdc bin/bgdi \
diff --git a/devel/bennugd-modules/Makefile b/devel/bennugd-modules/Makefile
index fa94aa1d3b29..5e78aea5be13 100644
--- a/devel/bennugd-modules/Makefile
+++ b/devel/bennugd-modules/Makefile
@@ -21,7 +21,6 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --libdir="${PREFIX}/lib/bennugd"
-CONFIGURE_ENV= ZLIB_CFLAGS=" " ZLIB_LIBS="-lz"
DOS2UNIX_GLOB= *.c
INSTALL_TARGET= install-strip
diff --git a/devel/liborcus/Makefile b/devel/liborcus/Makefile
index 7f99c56a12e8..db8eb334d583 100644
--- a/devel/liborcus/Makefile
+++ b/devel/liborcus/Makefile
@@ -23,7 +23,6 @@ CONFIGURE_ARGS= --disable-spreadsheet-model --disable-werror \
--with-boost="${LOCALBASE}" \
--with-boost-system=boost_system \
--disable-python
-CONFIGURE_ENV= ZLIB_CFLAGS="-I/usr/include" ZLIB_LIBS="-lz"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/devel/liborcus07/Makefile b/devel/liborcus07/Makefile
index 6c211f3ae841..1083ec85b412 100644
--- a/devel/liborcus07/Makefile
+++ b/devel/liborcus07/Makefile
@@ -26,7 +26,6 @@ INSTALL_TARGET= install-strip
CONFIGURE_ARGS= --disable-spreadsheet-model --disable-werror \
--with-boost="${LOCALBASE}" \
--with-boost-system=boost_system
-CONFIGURE_ENV= ZLIB_CFLAGS="-I/usr/include" ZLIB_LIBS="-lz"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/devel/love/Makefile b/devel/love/Makefile
index 0c6d59946347..2ead5851a2c1 100644
--- a/devel/love/Makefile
+++ b/devel/love/Makefile
@@ -27,8 +27,6 @@ USES= compiler:c++11-lib desktop-file-utils gmake libtool \
USE_SDL= sdl2
USE_GL= gl glu
GNU_CONFIGURE= yes
-CONFIGURE_ENV= zlib_CFLAGS=" " \
- zlib_LIBS="-lz"
WRKSRC= ${WRKDIR}/love-${PORTVERSION}
INSTALL_TARGET= install-strip
diff --git a/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_projects_unix_Makefile b/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_projects_unix_Makefile
deleted file mode 100644
index 04a8ee08832f..000000000000
--- a/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_projects_unix_Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
---- source/mupen64plus-core/projects/unix/Makefile 2015-04-26 17:42:49.000000000 -0500
-+++ source/mupen64plus-core/projects/unix/Makefile 2015-06-12 17:54:03.000000000 -0500
-@@ -227,6 +227,10 @@
- ZLIB_LDLIBS += -lz
- endif
-
-+ifeq ($(OS), FREEBSD) # use system zlib on FreeBSD
-+ ZLIB_LDLIBS += -lz
-+endif
-+
- ifeq ($(origin ZLIB_CFLAGS) $(origin ZLIB_LDLIBS), undefined undefined)
- ifeq ($(shell $(PKG_CONFIG) --modversion zlib 2>/dev/null),)
- $(error No zlib development libraries found!)
-@@ -247,6 +251,12 @@
- CFLAGS += $(LIBPNG_CFLAGS)
- LDLIBS += $(LIBPNG_LDLIBS)
-
-+ifeq ($(OS), FREEBSD)
-+ SDL_CFLAGS += $(shell $(SDL2_CONFIG) --cflags)
-+ SDL_LDLIBS += $(shell $(SDL2_CONFIG) --libs)
-+endif
-+
-+
- # test for presence of SDL
- ifeq ($(origin SDL_CFLAGS) $(origin SDL_LDLIBS), undefined undefined)
- SDL_CONFIG = $(CROSS_COMPILE)sdl2-config
diff --git a/emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-projects-unix_Makefile b/emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-projects-unix_Makefile
index b0022b62df36..51b6739041b3 100644
--- a/emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-projects-unix_Makefile
+++ b/emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-projects-unix_Makefile
@@ -17,17 +17,6 @@
endif
ifeq ($(origin PKG_CONFIG), undefined)
-@@ -199,6 +200,10 @@
- ZLIB_LDLIBS += -lz
- endif
-
-+ifeq ($(OS), FREEBSD) # use system zlib on FreeBSD
-+ ZLIB_LDLIBS += -lz
-+endif
-+
- ifeq ($(origin ZLIB_CFLAGS) $(origin ZLIB_LDLIBS), undefined undefined)
- ifeq ($(shell $(PKG_CONFIG) --modversion zlib 2>/dev/null),)
- $(error No zlib development libraries found!)
@@ -292,8 +297,8 @@
endif
diff --git a/games/easyrpg-player/Makefile b/games/easyrpg-player/Makefile
index 691bbeaeb42c..841327ce58ff 100644
--- a/games/easyrpg-player/Makefile
+++ b/games/easyrpg-player/Makefile
@@ -38,16 +38,10 @@ PORTDOCS= AUTHORS README
OPTIONS_DEFINE= DOCS
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
-CONFIGURE_ENV+= ZLIB_CFLAGS=" " ZLIB_LIBS=-lz
-.endif
-
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/zathura/Makefile b/graphics/zathura/Makefile
index dbba496f9fbd..7ce1bf2014f5 100644
--- a/graphics/zathura/Makefile
+++ b/graphics/zathura/Makefile
@@ -24,8 +24,6 @@ USES= compiler:c11 gmake pathfix pkgconfig
PATHFIX_MAKEFILEIN= Makefile
MAKE_ENV= SFLAGS="${STRIP}" \
RSTTOMAN=${LOCALBASE}/bin/rst2man \
- ZLIB_INC= \
- ZLIB_LIB=-lz \
WITH_SYNCTEX=1
CPPFLAGS+= -DWITH_SYNCTEX
diff --git a/mail/notmuch/Makefile b/mail/notmuch/Makefile
index ba5c4a449b73..afc31670e1d7 100644
--- a/mail/notmuch/Makefile
+++ b/mail/notmuch/Makefile
@@ -68,12 +68,6 @@ MUTT_USE= PERL=yes
RUBY_USE= RUBY=yes
ZSH_CONFIGURE_WITH= zsh-completion
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 1000000
-CONFIGURE_ENV= zlib_cflags="" zlib_ldflags="-lz" PKG_CONFIG_PATH=""
-.endif
-
do-build-MUTT-on:
${MAKE_CMD} -C ${WRKSRC}/contrib/notmuch-mutt all
${GZIP_CMD} ${WRKSRC}/contrib/notmuch-mutt/notmuch-mutt.1
@@ -86,4 +80,4 @@ post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/notmuch
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libnotmuch.so.4.4.0
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/mkvtoolnix/Makefile b/multimedia/mkvtoolnix/Makefile
index 54717f2e5b6c..befed83b60ff 100644
--- a/multimedia/mkvtoolnix/Makefile
+++ b/multimedia/mkvtoolnix/Makefile
@@ -25,7 +25,7 @@ USES= compiler:c++14-lang iconv localbase pkgconfig tar:xz
GNU_CONFIGURE= yes
USE_RUBY= yes
RUBY_NO_RUN_DEPENDS= yes
-CONFIGURE_ENV+= ac_cv_path_PO4A=no ZLIB_CFLAGS=-I/usr/include ZLIB_LIBS=-lz
+CONFIGURE_ENV+= ac_cv_path_PO4A=no
CONFIGURE_ARGS= --without-curl \
--with-boost=${LOCALBASE} \
--with-boost-filesystem=boost_filesystem \
diff --git a/net-mgmt/seafile-client/files/patch-configure.ac b/net-mgmt/seafile-client/files/patch-configure.ac
index 8ce4aed3f861..9c9fea6b6a59 100644
--- a/net-mgmt/seafile-client/files/patch-configure.ac
+++ b/net-mgmt/seafile-client/files/patch-configure.ac
@@ -38,21 +38,19 @@
AM_CONDITIONAL([LINUX], [test "$blinux" = "true"])
-@@ -193,6 +207,9 @@ if test "$bwin32" = true; then
+@@ -193,6 +207,8 @@ if test "$bwin32" = true; then
LIB_MAC=
MSVC_CFLAGS="-D__MSVCRT__ -D__MSVCRT_VERSION__=0x0601"
LIB_CRYPT32=-lcrypt32
-+ ZLIB_LIBS=
+ LIB_INOTIFY=
+ LIB_KVM=
elif test "$bmac" = true ; then
LIB_WS32=
LIB_GDI32=
-@@ -207,6 +224,26 @@ elif test "$bmac" = true ; then
+@@ -207,6 +224,24 @@ elif test "$bmac" = true ; then
LIB_MAC="-framework CoreServices"
LIB_CRYPT32=
LIB_ICONV=-liconv
-+ ZLIB_LIBS=
+ LIB_INOTIFY=
+ LIB_KVM=
+elif test "$bbsd" = true ; then
@@ -69,51 +67,26 @@
+ MSVC_CFLAGS=
+ LIB_CRYPT32=
+ LIB_ICONV=-liconv
-+ ZLIB_LIBS=-lz
+ LIB_INOTIFY=-linotify
+ LIB_KVM=-lkvm
else
LIB_WS32=
LIB_GDI32=
-@@ -220,6 +257,9 @@ else
+@@ -220,6 +257,8 @@ else
LIB_MAC=
MSVC_CFLAGS=
LIB_CRYPT32=
-+ ZLIB_LIBS=-lz
+ LIB_INOTIFY=-linotify
+ LIB_KVM=
fi
AC_SUBST(LIB_WS32)
-@@ -232,6 +272,9 @@ AC_SUBST(LIB_IPHLPAPI)
+@@ -232,6 +272,8 @@ AC_SUBST(LIB_IPHLPAPI)
AC_SUBST(LIB_SHELL32)
AC_SUBST(LIB_PSAPI)
AC_SUBST(LIB_MAC)
-+AC_SUBST(ZLIB_LIBS)
+AC_SUBST(LIB_INOTIFY)
+AC_SUBST(LIB_KVM)
AC_SUBST(MSVC_CFLAGS)
AC_SUBST(LIB_CRYPT32)
AC_SUBST(LIB_ICONV)
-@@ -246,7 +289,9 @@ ZDB_REQUIRED=2.10
- #LIBNAUTILUS_EXTENSION_REQUIRED=2.30.1
- CURL_REQUIRED=7.17
- FUSE_REQUIRED=2.7.3
-+if test "$blinux" = true ; then
- ZLIB_REQUIRED=1.2.0
-+fi
-
- PKG_CHECK_MODULES(SSL, [openssl])
- AC_SUBST(SSL_CFLAGS)
-@@ -276,9 +321,11 @@ PKG_CHECK_MODULES(LIBEVENT, [libevent >=
- AC_SUBST(LIBEVENT_CFLAGS)
- AC_SUBST(LIBEVENT_LIBS)
-
-+if test "$blinux" = true ; then
- PKG_CHECK_MODULES(ZLIB, [zlib >= $ZLIB_REQUIRED])
- AC_SUBST(ZLIB_CFLAGS)
- AC_SUBST(ZLIB_LIBS)
-+fi
-
- if test x${compile_python} = xyes; then
- AM_PATH_PYTHON([2.6])
diff --git a/net-mgmt/seafile-server/files/patch-configure.ac b/net-mgmt/seafile-server/files/patch-configure.ac
index b3c4f56156a1..69e4c8779570 100644
--- a/net-mgmt/seafile-server/files/patch-configure.ac
+++ b/net-mgmt/seafile-server/files/patch-configure.ac
@@ -38,21 +38,19 @@
AM_CONDITIONAL([LINUX], [test "$blinux" = "true"])
-@@ -134,6 +148,9 @@ if test "$bwin32" = true; then
+@@ -134,6 +148,8 @@ if test "$bwin32" = true; then
LIB_MAC=
MSVC_CFLAGS="-D__MSVCRT__ -D__MSVCRT_VERSION__=0x0601"
LIB_CRYPT32=-lcrypt32
-+ ZLIB_LIBS=
+ LIB_INOTIFY=
+ LIB_KVM=
LIB_ICONV=-liconv
elif test "$bmac" = true ; then
LIB_WS32=
-@@ -149,6 +166,26 @@ elif test "$bmac" = true ; then
+@@ -149,6 +166,24 @@ elif test "$bmac" = true ; then
LIB_MAC="-framework CoreServices"
LIB_CRYPT32=
LIB_ICONV=-liconv
-+ ZLIB_LIBS=
+ LIB_INOTIFY=
+ LIB_KVM=
+elif test "$bbsd" = true ; then
@@ -69,51 +67,26 @@
+ MSVC_CFLAGS=
+ LIB_CRYPT32=
+ LIB_ICONV=-liconv
-+ ZLIB_LIBS=-lz
+ LIB_INOTIFY=-linotify
+ LIB_KVM=-lkvm
else
LIB_WS32=
LIB_GDI32=
-@@ -162,6 +199,9 @@ else
+@@ -162,6 +199,8 @@ else
LIB_MAC=
MSVC_CFLAGS=
LIB_CRYPT32=
-+ ZLIB_LIBS=-lz
+ LIB_INOTIFY=-linotify
+ LIB_KVM=
fi
AC_SUBST(LIB_WS32)
-@@ -174,6 +214,9 @@ AC_SUBST(LIB_IPHLPAPI)
+@@ -174,6 +214,8 @@ AC_SUBST(LIB_IPHLPAPI)
AC_SUBST(LIB_SHELL32)
AC_SUBST(LIB_PSAPI)
AC_SUBST(LIB_MAC)
-+AC_SUBST(ZLIB_LIBS)
+AC_SUBST(LIB_INOTIFY)
+AC_SUBST(LIB_KVM)
AC_SUBST(MSVC_CFLAGS)
AC_SUBST(LIB_CRYPT32)
AC_SUBST(LIB_ICONV)
-@@ -188,7 +231,9 @@ ZDB_REQUIRED=2.10
- #LIBNAUTILUS_EXTENSION_REQUIRED=2.30.1
- CURL_REQUIRED=7.17
- FUSE_REQUIRED=2.7.3
-+if test "$blinux" = true ; then
- ZLIB_REQUIRED=1.2.0
-+fi
-
- PKG_CHECK_MODULES(SSL, [openssl])
- AC_SUBST(SSL_CFLAGS)
-@@ -218,9 +263,11 @@ PKG_CHECK_MODULES(LIBEVENT, [libevent >=
- AC_SUBST(LIBEVENT_CFLAGS)
- AC_SUBST(LIBEVENT_LIBS)
-
-+if test "$blinux" = true ; then
- PKG_CHECK_MODULES(ZLIB, [zlib >= $ZLIB_REQUIRED])
- AC_SUBST(ZLIB_CFLAGS)
- AC_SUBST(ZLIB_LIBS)
-+fi
-
- if test x${compile_python} = xyes; then
- AM_PATH_PYTHON([2.6])
diff --git a/net-p2p/transmission-cli/Makefile b/net-p2p/transmission-cli/Makefile
index 3a4d63cb9226..6deae8fb7091 100644
--- a/net-p2p/transmission-cli/Makefile
+++ b/net-p2p/transmission-cli/Makefile
@@ -44,8 +44,7 @@ GEN_RUN_DEPENDS=${LOCALBASE}/share/transmission/web/index.html:www/transmission-
USES+= gmake iconv libtool localbase pkgconfig
GNU_CONFIGURE= yes
LIBS+= ${ICONV_LIB}
-CONFIGURE_ENV= ZLIB_CFLAGS=" " ZLIB_LIBS="-lz" \
- ${ICONV_LIB:C@.+@ac_cv_func_iconv=yes@}
+CONFIGURE_ENV= ${ICONV_LIB:C@.+@ac_cv_func_iconv=yes@}
CONFIGURE_ARGS= --without-inotify \
--enable-external-b64 \
--enable-external-dht \
diff --git a/news/nzbget/Makefile b/news/nzbget/Makefile
index cd9602dbcfe2..dcc779a1ff71 100644
--- a/news/nzbget/Makefile
+++ b/news/nzbget/Makefile
@@ -60,8 +60,6 @@ CONFIGURE_ARGS+= --disable-sigchld-handler
.if ${OSVERSION} < 1000500
USE_GCC= yes
-CONFIGURE_ENV+= zlib_LIBS='-lz ' \
- zlib_CFLAGS=' '
.endif
post-install:
diff --git a/news/pan/Makefile b/news/pan/Makefile
index 1b2701689f59..21a9a72200a5 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -22,8 +22,6 @@ USE_GNOME= intlhack
USE_GCC= any
GNU_CONFIGURE= yes
LDFLAGS+= -lgnuregex ${ICONV_LIB}
-CONFIGURE_ENV+= ZLIB_CFLAGS="-I/usr/include" \
- ZLIB_LIBS="-L/usr/lib -lz"
OPTIONS_DEFINE= GTKSPELL GNUTLS NLS
OPTIONS_RADIO= GTK
diff --git a/print/cups-filters/Makefile b/print/cups-filters/Makefile
index 78475aed2859..6511d65289f6 100644
--- a/print/cups-filters/Makefile
+++ b/print/cups-filters/Makefile
@@ -29,8 +29,7 @@ SHEBANG_FILES= filter/braille/drivers/generic/brftoembosser.in \
USE_GNOME= glib20
USE_RC_SUBR= cups_browsed
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-shell=/bin/sh \
- ZLIB_CFLAGS=" " ZLIB_LIBS="-lz"
+CONFIGURE_ARGS= --with-shell=/bin/sh
INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/print/libmspub01/Makefile b/print/libmspub01/Makefile
index 64327df0d326..ef16dd4067b7 100644
--- a/print/libmspub01/Makefile
+++ b/print/libmspub01/Makefile
@@ -23,7 +23,6 @@ USES= compiler:c++0x libtool pathfix pkgconfig tar:xz
INSTALL_TARGET= install-strip
CONFIGURE_ARGS= --disable-werror --without-docs
-CONFIGURE_ENV= ZLIB_CFLAGS="-I/usr/include" ZLIB_LIBS="-lz"
CPPFLAGS+= -I${LOCALBASE}/include
post-patch:
diff --git a/security/openvas-libraries/files/patch-base-CMakeLists.txt b/security/openvas-libraries/files/patch-base-CMakeLists.txt
deleted file mode 100644
index 6ad2c2ade684..000000000000
--- a/security/openvas-libraries/files/patch-base-CMakeLists.txt
+++ /dev/null
@@ -1,12 +0,0 @@
---- base/CMakeLists.txt.orig 2015-08-03 10:14:33 UTC
-+++ base/CMakeLists.txt
-@@ -30,7 +30,8 @@ if (NOT MINGW)
- # because they change the API (e.g. _FILE_OFFSET_BITS).
- set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${HARDENING_FLAGS} -D_FILE_OFFSET_BITS=64 -Wall -fPIC")
-
-- pkg_check_modules (ZLIB REQUIRED zlib)
-+ set (ZLIB_INCLUDE_DIRS "")
-+ set (ZLIB_LDFLAGS "-lz")
-
- pkg_check_modules (GIO REQUIRED gio-2.0)
- endif (NOT MINGW)
diff --git a/textproc/libe-book/Makefile b/textproc/libe-book/Makefile
index 2965ecb7030c..44aae393a1a7 100644
--- a/textproc/libe-book/Makefile
+++ b/textproc/libe-book/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libe-book
PORTVERSION= 0.1.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= textproc
MASTER_SITES= SF/libebook/${PORTNAME}-${PORTVERSION}/
@@ -23,7 +23,6 @@ USES= compiler:c++11-lang gmake gperf libtool pathfix pkgconfig \
tar:xz
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= ZLIB_CFLAGS="-DWEHAVEZLIBINBASE" ZLIB_LIBS="-DWEDOHAVEIT"
INSTALL_TARGET= install-strip
CONFIGURE_ARGS= --disable-werror --disable-tests
CPPFLAGS+= -I${LOCALBASE}/include -DBOOST_ERROR_CODE_HEADER_ONLY
diff --git a/www/aria2/Makefile b/www/aria2/Makefile
index 2327b9a5d153..e3cac1cc5680 100644
--- a/www/aria2/Makefile
+++ b/www/aria2/Makefile
@@ -29,8 +29,6 @@ CONFIGURE_ARGS= --disable-epoll --enable-bittorrent --enable-libaria2 \
--without-libnettle --without-libuv
CONFIGURE_ENV= OPENSSL_CFLAGS=-I${OPENSSLINC} \
OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl" \
- ZLIB_CFLAGS=-I${INCLUDEDIR} \
- ZLIB_LIBS="-L${LIBDIR} -lz" \
ac_cv_path_RST2HTML=no
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
diff --git a/www/nghttp2/Makefile b/www/nghttp2/Makefile
index aed6b8b0c000..aa74c9ea0614 100644
--- a/www/nghttp2/Makefile
+++ b/www/nghttp2/Makefile
@@ -24,9 +24,7 @@ SPDY_IMPLIES= APP
CONFIGURE_ARGS= --disable-python-bindings
CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
- OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl" \
- ZLIB_CFLAGS="-I${INCLUDEDIR}" \
- ZLIB_LIBS="-L${LIBDIR} -lz"
+ OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl"
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_CXXSTD= c++11
diff --git a/www/spdylay/Makefile b/www/spdylay/Makefile
index b590da21087c..26a4cbf83514 100644
--- a/www/spdylay/Makefile
+++ b/www/spdylay/Makefile
@@ -22,9 +22,7 @@ BROKEN_sparc64= does not build: fails to link
CONFIGURE_ARGS= --enable-examples \
--enable-src
CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
- OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl" \
- ZLIB_CFLAGS="-I${INCLUDEDIR}" \
- ZLIB_LIBS="-L${LIBDIR} -lz"
+ OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl"
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_CXXSTD= c++11