aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/seafile-client/files/patch-configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/seafile-client/files/patch-configure.ac')
-rw-r--r--net-mgmt/seafile-client/files/patch-configure.ac35
1 files changed, 4 insertions, 31 deletions
diff --git a/net-mgmt/seafile-client/files/patch-configure.ac b/net-mgmt/seafile-client/files/patch-configure.ac
index 8ce4aed3f861..9c9fea6b6a59 100644
--- a/net-mgmt/seafile-client/files/patch-configure.ac
+++ b/net-mgmt/seafile-client/files/patch-configure.ac
@@ -38,21 +38,19 @@
AM_CONDITIONAL([LINUX], [test "$blinux" = "true"])
-@@ -193,6 +207,9 @@ if test "$bwin32" = true; then
+@@ -193,6 +207,8 @@ if test "$bwin32" = true; then
LIB_MAC=
MSVC_CFLAGS="-D__MSVCRT__ -D__MSVCRT_VERSION__=0x0601"
LIB_CRYPT32=-lcrypt32
-+ ZLIB_LIBS=
+ LIB_INOTIFY=
+ LIB_KVM=
elif test "$bmac" = true ; then
LIB_WS32=
LIB_GDI32=
-@@ -207,6 +224,26 @@ elif test "$bmac" = true ; then
+@@ -207,6 +224,24 @@ elif test "$bmac" = true ; then
LIB_MAC="-framework CoreServices"
LIB_CRYPT32=
LIB_ICONV=-liconv
-+ ZLIB_LIBS=
+ LIB_INOTIFY=
+ LIB_KVM=
+elif test "$bbsd" = true ; then
@@ -69,51 +67,26 @@
+ MSVC_CFLAGS=
+ LIB_CRYPT32=
+ LIB_ICONV=-liconv
-+ ZLIB_LIBS=-lz
+ LIB_INOTIFY=-linotify
+ LIB_KVM=-lkvm
else
LIB_WS32=
LIB_GDI32=
-@@ -220,6 +257,9 @@ else
+@@ -220,6 +257,8 @@ else
LIB_MAC=
MSVC_CFLAGS=
LIB_CRYPT32=
-+ ZLIB_LIBS=-lz
+ LIB_INOTIFY=-linotify
+ LIB_KVM=
fi
AC_SUBST(LIB_WS32)
-@@ -232,6 +272,9 @@ AC_SUBST(LIB_IPHLPAPI)
+@@ -232,6 +272,8 @@ AC_SUBST(LIB_IPHLPAPI)
AC_SUBST(LIB_SHELL32)
AC_SUBST(LIB_PSAPI)
AC_SUBST(LIB_MAC)
-+AC_SUBST(ZLIB_LIBS)
+AC_SUBST(LIB_INOTIFY)
+AC_SUBST(LIB_KVM)
AC_SUBST(MSVC_CFLAGS)
AC_SUBST(LIB_CRYPT32)
AC_SUBST(LIB_ICONV)
-@@ -246,7 +289,9 @@ ZDB_REQUIRED=2.10
- #LIBNAUTILUS_EXTENSION_REQUIRED=2.30.1
- CURL_REQUIRED=7.17
- FUSE_REQUIRED=2.7.3
-+if test "$blinux" = true ; then
- ZLIB_REQUIRED=1.2.0
-+fi
-
- PKG_CHECK_MODULES(SSL, [openssl])
- AC_SUBST(SSL_CFLAGS)
-@@ -276,9 +321,11 @@ PKG_CHECK_MODULES(LIBEVENT, [libevent >=
- AC_SUBST(LIBEVENT_CFLAGS)
- AC_SUBST(LIBEVENT_LIBS)
-
-+if test "$blinux" = true ; then
- PKG_CHECK_MODULES(ZLIB, [zlib >= $ZLIB_REQUIRED])
- AC_SUBST(ZLIB_CFLAGS)
- AC_SUBST(ZLIB_LIBS)
-+fi
-
- if test x${compile_python} = xyes; then
- AM_PATH_PYTHON([2.6])