aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--shells/elvish/Makefile23
-rw-r--r--shells/elvish/distinfo22
-rw-r--r--shells/elvish/pkg-descr4
3 files changed, 26 insertions, 23 deletions
diff --git a/shells/elvish/Makefile b/shells/elvish/Makefile
index f3b679debea4..7aa094a43d51 100644
--- a/shells/elvish/Makefile
+++ b/shells/elvish/Makefile
@@ -2,11 +2,11 @@
PORTNAME= elvish
DISTVERSIONPREFIX= v
-DISTVERSION= 0.14.1
+DISTVERSION= 0.15.0
CATEGORIES= shells
MAINTAINER= vendion@gmail.com
-COMMENT= Friendly Interactive Shell and Expressive Programming Language
+COMMENT= Elvish = Expressive Programming Language + Versatile Interactive Shell
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
@@ -14,20 +14,23 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= go:modules
USE_GITHUB= yes
GH_ACCOUNT= elves
-GH_TUPLE= \
- BurntSushi:toml:v0.3.1:burntsushi_toml/vendor/github.com/BurntSushi/toml \
- etcd-io:bbolt:v1.3.4:etcd_io_bbolt/vendor/go.etcd.io/bbolt \
- golang:sys:85ca7c5b95cd:golang_sys/vendor/golang.org/x/sys \
- kr:pty:v1.1.4:kr_pty/vendor/github.com/kr/pty \
+GH_TUPLE= BurntSushi:toml:v0.3.1:burntsushi_toml/vendor/github.com/BurntSushi/toml \
+ creack:pty:v1.1.11:creack_pty/vendor/github.com/creack/pty \
+ etcd-io:bbolt:v1.3.5:etcd_io_bbolt/vendor/go.etcd.io/bbolt \
+ golang:sys:c12d262b63d8:golang_sys/vendor/golang.org/x/sys \
mattn:go-isatty:v0.0.12:mattn_go_isatty/vendor/github.com/mattn/go-isatty \
- xiaq:persistent:a1d9ac4077fc:xiaq_persistent/vendor/github.com/xiaq/persistent
+ xiaq:persistent:3175cfb92e14:xiaq_persistent/vendor/github.com/xiaq/persistent
-
-GO_BUILDFLAGS= -ldflags="-s -w -X github.com/elves/elvish/pkg/buildinfo.Version=${DISTVERSIONPREFIX}${DISTVERSION}" \
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+GO_BUILDFLAGS= -ldflags="-s -w -X github.com/elves/elvish/pkg/buildinfo.Version=${DISTVERSIONPREFIX}${DISTVERSION} -X github.com/elves/elvish/pkg/buildinfo.Reproducible=true" \
-gcflags="all=-trimpath=${GO_WRKSRC}" \
-asmflags="all=-trimpath=${GO_WRKSRC}"
GO_TESTFLAGS= -race
PLIST_FILES= bin/elvish
+do-test:
+ @(cd ${GO_WRKSRC} ; \
+ ${GO_ENV} ${GO_CMD} test -race ${GO_TESTTARGET})
+
.include <bsd.port.mk>
diff --git a/shells/elvish/distinfo b/shells/elvish/distinfo
index 148b6d691368..894a48bf6a31 100644
--- a/shells/elvish/distinfo
+++ b/shells/elvish/distinfo
@@ -1,15 +1,15 @@
-TIMESTAMP = 1597667743
-SHA256 (elves-elvish-v0.14.1_GH0.tar.gz) = 8a8113c0a1325785b212ed59410869bdea30ca2cb7400f95ebb3fbc8689eb6d8
-SIZE (elves-elvish-v0.14.1_GH0.tar.gz) = 575753
+TIMESTAMP = 1612047801
+SHA256 (elves-elvish-v0.15.0_GH0.tar.gz) = 761739307c68fcbc51fd46c052c0a20ae848a30dba1ce3fbb6d27f99672f58e0
+SIZE (elves-elvish-v0.15.0_GH0.tar.gz) = 603715
SHA256 (BurntSushi-toml-v0.3.1_GH0.tar.gz) = 6593da894578ba510a470735ffbdc88ce88033094dc5a8f4d3957ab87e18803f
SIZE (BurntSushi-toml-v0.3.1_GH0.tar.gz) = 42077
-SHA256 (etcd-io-bbolt-v1.3.4_GH0.tar.gz) = 536029610c6cd08e4a9fe2e1b0857ae539b0736850132cbbe1c18f0fbed8a4da
-SIZE (etcd-io-bbolt-v1.3.4_GH0.tar.gz) = 95404
-SHA256 (golang-sys-85ca7c5b95cd_GH0.tar.gz) = 06a5cbc446381df9653d4b410239720eea6b27461597de88f3e621664c811294
-SIZE (golang-sys-85ca7c5b95cd_GH0.tar.gz) = 1047239
-SHA256 (kr-pty-v1.1.4_GH0.tar.gz) = f69af477ac2df39246ab64f4bf61767015d493a98a74d5f4da40131f0fe6af7a
-SIZE (kr-pty-v1.1.4_GH0.tar.gz) = 5819
+SHA256 (creack-pty-v1.1.11_GH0.tar.gz) = ee903119251fdf7d90dae890fec40015c5b6049daa68ec8d8750c3ebceaaf5ed
+SIZE (creack-pty-v1.1.11_GH0.tar.gz) = 8396
+SHA256 (etcd-io-bbolt-v1.3.5_GH0.tar.gz) = 63fed2e9bbdcc2aa279c2a7ea4a59c39bc21616ec2c96abff0020872beb3dbad
+SIZE (etcd-io-bbolt-v1.3.5_GH0.tar.gz) = 96494
+SHA256 (golang-sys-c12d262b63d8_GH0.tar.gz) = 57663347583aec8dca1fa3f24af9fdf6612e5db0fd65bcef26a79509548c8d40
+SIZE (golang-sys-c12d262b63d8_GH0.tar.gz) = 1060884
SHA256 (mattn-go-isatty-v0.0.12_GH0.tar.gz) = addbdc341d7685ed4cc8d2d8a8fd2bd9b784bde00d0ea99fb251039fc10c611c
SIZE (mattn-go-isatty-v0.0.12_GH0.tar.gz) = 4548
-SHA256 (xiaq-persistent-a1d9ac4077fc_GH0.tar.gz) = 43f431d16d4bef10b1fc6e72f61b3f60f3f0198f8384befba9742b582d2a61aa
-SIZE (xiaq-persistent-a1d9ac4077fc_GH0.tar.gz) = 19502
+SHA256 (xiaq-persistent-3175cfb92e14_GH0.tar.gz) = c481b2ba3bb0ad0dc7dc6d0d3179a55f7770c59b83ea54962cc37da5f5864611
+SIZE (xiaq-persistent-3175cfb92e14_GH0.tar.gz) = 19394
diff --git a/shells/elvish/pkg-descr b/shells/elvish/pkg-descr
index e18e2c4ed0bd..d2f74952bb82 100644
--- a/shells/elvish/pkg-descr
+++ b/shells/elvish/pkg-descr
@@ -1,4 +1,4 @@
-Elvish is a friendly interactive shell and an expressive programming language.
-It runs on Linux, BSDs, macOS and Windows.
+Elvish is an expressive programming language and a versatile interactive shell,
+combined into one seamless package. It runs on Linux, BSDs, macOS and Windows.
WWW: https://elv.sh/
3'>Remove trailing spaceadamw2019-03-201-1/+1 * Remove neovim from TEST_DEPENDS, and original submitter becomes maintaineradamw2019-03-201-5/+6 * New port: editors/py-pynvim: Python client and plugin host for Neovim0mp2019-03-185-0/+51 * Qt4 deprecationtcberner2019-03-172-16/+0 * editors/lazarus: remove qt4 flavor (Qt4 deprecation)tcberner2019-03-171-2/+1 * Qt4 deprecation: Remove Qt4 and its consumes.tcberner2019-03-1733-730/+0 * multimedia/phonon, multimedia/phonon-gestreamer, multimedia/phonon-designerpl...tcberner2019-03-171-1/+1 * devel/qca: remove flavors (Qt4 deprecation)tcberner2019-03-171-2/+2 * archivers/quazip: remove flavors (Qt4 deprecation)tcberner2019-03-171-2/+2 * editors/texmaker: remove QT4/QT5 options (Qt4 deprecation)tcberner2019-03-161-24/+5 * editors/texmacs: remove QT4 option (Qt4 deprecation)tcberner2019-03-161-18/+4 * editors/mp: remove QT4 option (Qt4 deprecation)tcberner2019-03-161-12/+2 * Fix build on gcc-based architectures:linimon2019-03-151-1/+2 * editors/emacs-devel: Update to latest commit, 8b30082jrm2019-03-143-6/+5 * editors/focuswriter: Update to 1.7.2kai2019-03-102-5/+4 * Update KDE Applications to 18.12.3tcberner2019-03-081-3/+3 * editors/poedit: unbreak after r493853jbeich2019-03-071-1/+1 * - New port: editors/cudatextacm2019-03-076-0/+1042 * - Update to 3.7.4acm2019-03-073-10/+10 * - Bump PORTREVISION. lang/ldc was update to 1.14.0acm2019-03-071-1/+1 * - Bump PORTREVISION. editors/lazarus was updated to 2.0.0acm2019-03-071-1/+1 * - Update to 2.0.0acm2019-03-073-8/+7 * Update MASTER_SITES.hrs2019-03-041-1/+1 * editors/kak-lsp: Update to 6.1.0tobik2019-03-023-130/+132 * editors/kak-lsp: Suggest disabling completion.detailedLabel in cclstobik2019-03-012-3/+9 * Update vim to patchlevel 985adamw2019-03-013-15/+4 * editors/jucipp: Update 1.4.4 -> 1.4.6yuri2019-03-012-19/+20 * lang/rust: update to 1.33.0jbeich2019-03-013-3/+3 * USES=cargo to update libc to 0.2.49 for Tier2jbeich2019-03-016-12/+12 * - Update to git snapshot 52cd63dashish2019-02-283-8/+12 * Exclude devel_nox due to build failure.hrs2019-02-271-1/+3 * Chase the shlib version bump of `mail/mailutils' in r493966.danfe2019-02-262-1/+2 * Add missing pkgconf build dependencybapt2019-02-261-1/+1 * Remove -Wno-expansion-to-defined to fix build with base GCC.linimon2019-02-251-1/+1 * wxGTK3.0: switch to gtk3 and webkit2bapt2019-02-254-3/+4 * Switch openoffice-devel to the upstream AOO42X branch from trunk andtruckman2019-02-203-17/+15 * editors/py-editorconfig: Update version 0.12.1=>0.12.2bofh2019-02-192-7/+8 * Add temporary workaround for poudriere build breakage.hrs2019-02-194-5/+45 * - Add a port of wxHexEditor, an advanced graphical (wxWidgets) hex editordanfe2019-02-1312-1/+237 * Bump revisions after poppler upgrade.tcberner2019-02-126-6/+6 * Update graphics/poppler* to 0.74.0tcberner2019-02-122-0/+10 * Update KDE Applications to 18.12.2tcberner2019-02-082-4/+3 * Remove unnecessary CXXFLAGS for powerpcspelwhsu2019-02-061-2/+0 * Add support for powerpc and powerpcspelwhsu2019-02-062-9/+54 * Mark devel_nox flavor BROKEN tooantoine2019-02-041-1/+1 * editors/emacs-devel: Update to latest commit to fix Emacs bug #34297jrm2019-02-042-5/+5 * Ensure that USES=gnome is set whenever USE_GNOME is usedadamw2019-02-031-3/+3 * editors/emacs-devel: Update to latest master-branch commitjrm2019-02-023-16/+15 * Update vim to patchlevel 865adamw2019-02-013-5/+16 * editors/emacs: Fix spellchecking with hunspell 1.7.0jrm2019-02-012-1/+25 * editors/nvi-m17n: Only append to LIB_DEPENDS after bsd.port.pre.mktobik2019-02-011-1/+1 * editors/kak-lsp: Prefer bingo over go-langservertobik2019-01-302-2/+22 * editors/scite: update to 4.1.0swills2019-01-284-26/+32 * security/botan2: Update to 2.9.0 (Fixes CVE-2018-20187)tcberner2019-01-271-1/+1 * editors/parinfer-rust: Fix Kakoune plugin for Lisp and Scheme filestobik2019-01-272-0/+12 * New port: editors/parinfer-rusttobik2019-01-275-0/+148 * editors/neovim-qt: update to 0.2.12swills2019-01-252-5/+4 * editors/featherpad update to v9.2jsm2019-01-253-4/+6 * Clenup xfce ports:madpilot2019-01-223-55/+64 * editors/kakoune: Update to 2019.01.20tobik2019-01-213-5/+5 * Update to 0.69ehaupt2019-01-204-22/+18 * textproc/hunspell: update to 1.7.0jbeich2019-01-1911-22/+22 * - Add LICENSE_FILEamdmi32019-01-182-1/+2 * editors/texstudio: take maintanership.rigoletto2019-01-181-1/+1 * lang/rust: update to 1.32.0jbeich2019-01-182-1/+2 * editors/texstudio: Reset maintainer after > 3 timeouts in a rowtobik2019-01-171-1/+1 * Fix Qt5 symbol version scripts to put the catch-all clause first. Whentijl2019-01-1616-6/+16 * editors/slime: Update to version 2.23jrm2019-01-165-160/+201 * - Add LLD_UNSAFEacm2019-01-151-0/+1 * editors/texstudio: update to version 2.12.14rigoletto2019-01-153-4/+5 * editors/kak-lsp: Update to 6.0.1tobik2019-01-142-34/+10 * Update to 0.3.4, and add TEST_DEPENDSadamw2019-01-132-4/+8 * editors/emacs-devel: update to latest master-branch commitjrm2019-01-113-15/+7 * Update KDE Applications to 18.12.1tcberner2019-01-111-3/+3 * Do not set SHEBANG_FILES twicetobik2019-01-081-1/+0 * Add explicit build dependency on python2.7antoine2019-01-081-1/+1 * Update neovim to 0.3.3adamw2019-01-062-4/+4 * editors/kile can no longer conflict with editors/kile-kde4 because theadridg2019-01-041-2/+0 * Update vim to patchlevel 676adamw2019-01-022-4/+4 * editors/yzis: remove KYZIS option after r488807tcberner2019-01-012-27/+6 * editors/vile: update to 9.8tswills2019-01-014-7/+16 * editors/xvile: Update to 9.8tswills2019-01-014-8/+17 * Remove KDE4, part 5rene2019-01-0122-2926/+0 * editor/libreoffice: remove optional dependency on expired KDE4rene2018-12-311-14/+1 * Update neovim to 0.3.2adamw2018-12-313-7/+25 * More GCC-related fixes in kde@ portstcberner2018-12-311-1/+1 * editors/with-editor: Update to 2.8.1swills2018-12-272-5/+4 * editors/focuswriter: Update to 1.7.1swills2018-12-272-6/+5 * This port requires a C++11-aware compiler. Set USES=compiler:c++11-langlinimon2018-12-261-2/+2 * Update math/eigen3 to 3.3.7tcberner2018-12-261-1/+1 * Change cmake default behaviour to outsource.tcberner2018-12-2612-12/+12 * editors/codelite: Update the port to the latest version (12.0)mmokhi2018-12-263-5/+7 * editors/emacs-devel: Update to latest master-branch commitjrm2018-12-253-6/+7 * Add compiler:c++14-lang to USES to fix build on GCC-based architectureslinimon2018-12-251-3/+1 * This port needs USES=compiler:c++11-lang to fix build on GCC-basedlinimon2018-12-221-1/+2 * editors/abiword: remove optional dependency on expired textproc/otsrene2018-12-212-10/+1 * Remove expired ports:rene2018-12-2114-471/+0 * editors/nano: Fix build (configure) on ARMkoobs2018-12-181-0/+5 * editors/kak-lsp: Update to 6.0.0tobik2018-12-184-128/+171 * Update poppler to 0.72tcberner2018-12-1613-217/+427 * Update Qt5 to 5.12.0tcberner2018-12-161-1/+1 * - Update to 47.0.1danilo2018-12-152-21/+7 * - Remove groff dependency. The tarball already has the HTML filesdanilo2018-12-151-11/+8 * Update KDE Applications to 18.12.0tcberner2018-12-142-4/+3 * Update to 3.1.38gblach2018-12-132-4/+4 * Bump PORTREVISION for ports depending on the canonical version of GCCgerald2018-12-12