aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hs-test-framework-hunit/Makefile18
-rw-r--r--devel/hs-test-framework-hunit/distinfo3
-rw-r--r--devel/hs-test-framework-hunit/pkg-descr3
-rw-r--r--devel/hs-test-framework-hunit/pkg-plist16
-rw-r--r--lang/ghc/bsd.hackage.mk1
6 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6504161e09af..6c57c3eda6b9 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -596,6 +596,7 @@
SUBDIR += hs-split
SUBDIR += hs-terminfo
SUBDIR += hs-test-framework
+ SUBDIR += hs-test-framework-unit
SUBDIR += hs-testpack
SUBDIR += hs-transformers
SUBDIR += hs-unamb
diff --git a/devel/hs-test-framework-hunit/Makefile b/devel/hs-test-framework-hunit/Makefile
new file mode 100644
index 000000000000..c36a9671b90b
--- /dev/null
+++ b/devel/hs-test-framework-hunit/Makefile
@@ -0,0 +1,18 @@
+# New ports collection makefile for: hs-test-framework-hunit
+# Date created: May 21, 2010
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= test-framework-hunit
+PORTVERSION= 0.2.6
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= HUnit support for the test-framework package
+
+USE_HACKAGE= test-framework>=0.2.0
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-test-framework-hunit/distinfo b/devel/hs-test-framework-hunit/distinfo
new file mode 100644
index 000000000000..4a47a34a883c
--- /dev/null
+++ b/devel/hs-test-framework-hunit/distinfo
@@ -0,0 +1,3 @@
+MD5 (test-framework-hunit-0.2.6.tar.gz) = 7c012ca5426d743b3cf35e231d6f6072
+SHA256 (test-framework-hunit-0.2.6.tar.gz) = f910e18e62615f64fac9bf4938a34cc36fad9d86e6ba31edcb79731e0ef46fc7
+SIZE (test-framework-hunit-0.2.6.tar.gz) = 2639
diff --git a/devel/hs-test-framework-hunit/pkg-descr b/devel/hs-test-framework-hunit/pkg-descr
new file mode 100644
index 000000000000..d440c1729d35
--- /dev/null
+++ b/devel/hs-test-framework-hunit/pkg-descr
@@ -0,0 +1,3 @@
+HUnit support for the test-framework package.
+
+WWW: http://batterseapower.github.com/test-framework/
diff --git a/devel/hs-test-framework-hunit/pkg-plist b/devel/hs-test-framework-hunit/pkg-plist
new file mode 100644
index 000000000000..e4038008e399
--- /dev/null
+++ b/devel/hs-test-framework-hunit/pkg-plist
@@ -0,0 +1,16 @@
+@comment $FreeBSD$
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Test/Framework/Providers/HUnit.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
+%%LIBDIR_REL%%/register.sh
+%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Test/Framework/Providers
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Test/Framework
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Test
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%LIBDIR_REL%%
+@exec /bin/sh %D/%%LIBDIR_REL%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister %%PORTNAME%%-%%PORTVERSION%%
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index df8e5ba0f4d2..4d3bbdf08d58 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -104,6 +104,7 @@ tagsoup_port= textproc/hs-tagsoup # executable
Tensor_port= devel/hs-Tensor
terminfo_port= devel/hs-terminfo
test-framework_port= devel/hs-test-framework
+test-framework-hunit_port= devel/hs-test-framework-hunit
testpack_port= devel/hs-testpack
texmath_port= textproc/hs-texmath # executable
transformers_port= devel/hs-transformers
d>- Update to 1.23sunpoet2012-07-202-5/+5 * - Remove SITE_PERL from *_DEPENDSaz2012-06-301-2/+2 * - Remove SITE_PERL from *_DEPENDSaz2012-06-301-39/+39 * - reset MAINTAINERdinoex2012-06-262-2/+2 * s/X11BASE/LOCALBASE/, or equivalent.dougb2012-06-251-1/+1 * - Update to 2.29sunpoet2012-06-182-4/+3 * - Update to version 2.1.8sylvio2012-06-186-171/+21 * - Update to version 2.12.3sylvio2012-06-183-30/+54 * - Update to 0.50sunpoet2012-06-133-22/+37 * - Convert all remaining instances of BUILD_DEPENDS=${RUN_DEPENDS} orswills2012-06-114-4/+4 * - Fix maintainer emailamdmi32012-06-071-1/+1 * SeqAn is an open source C++ library of efficient algorithmsamdmi32012-06-078-0/+2230 * - Remove SITE_PERL from *_DEPENDSaz2012-06-041-1/+1 * - Update to 0.49sunpoet2012-06-032-4/+3 * Set maintainership back to ports@cs2012-06-032-2/+2 * - update png to 1.5.10dinoex2012-06-0115-16/+19 * Remove non-serving mirrorcs2012-05-201-2/+1 * - Adjust BOINC_* variables to be consistent with new system in boinc-clientpav2012-05-162-9/+9 * - Update to 0.48sunpoet2012-05-032-5/+5 * - Update to 1.3culot2012-04-262-3/+3 * - Update to 2.28wen2012-04-173-3/+4 * - Update to 1.2culot2012-04-163-16/+18 * - Update to 0.47wen2012-04-112-3/+3 * - Update to 1.0wen2012-03-223-4/+7 * - Revert ports/165605 as requested by portmgr@pgollucci2012-03-141-1/+7 * - Remove ports that only work with < perl 5.12 (devel/p5-B-Size, devel/p5-Dev...pgollucci2012-03-091-7/+1 * - Update to 1.59wen2012-03-063-1070/+1129 * - Update to 0.46wen2012-03-053-3/+12 * - Update to 0.4.5wen2012-02-232-3/+3 * - Update MASTER_SITES and WWW: linemiwi2012-02-203-20/+28 * update to 1.5.0.1.maho2012-02-164-40/+76 * - Update to 0.78sunpoet2012-02-113-44/+58 * - Update to 2.26sunpoet2012-02-113-5/+7 * - Update to 1.22sunpoet2012-02-092-3/+3 * - Update to 0.77wen2012-02-093-5/+8 * - fix build with gcc46dinoex2012-02-071-7/+4 * - Mark BROKEN on FreeBSD 9.X and up: does not compilepav2012-02-061-1/+7 * - Respect CCmiwi2012-01-281-1/+2 * At the moment 1385 ports use BUILD_DEPENDS= ${RUN_DEPENDS} and 450eadler2012-01-225-5/+5 * - Update to 3.23sylvio2012-01-172-3/+3 * Chase pdflib.so version and bump PORTREVISION accordingly.ale2012-01-101-2/+2 * - The proper acronym for Apache Software License 2 is really AL2tabthorpe2012-01-091-1/+1 * - Update to 0.87wen2011-12-233-4/+6 * - Update to 1.21sunpoet2011-11-242-4/+5 * - unbreakgahr2011-11-172-2/+29 * Does not build on powerpc-9: error in pthreads.linimon2011-11-101-0/+4 * - Remove WITH_FBSD10_FIX, is no longer neededmiwi2011-11-091-1/+0 * - Mark BROKEN: does not compile with new fltkpav2011-11-051-0/+2 * - Fix fetch and update WWWpav2011-11-052-2/+2 * - Fix build on FreeBSD 10miwi2011-10-291-0/+1 * - Update to 0.45sunpoet2011-10-292-3/+3 * The vast majority of pkg-descr files had the following format when theydougb2011-10-243-10/+1 * - remove maintainer tags from pkg-descreadler2011-10-2311-27/+0 * - Update to 0.43sunpoet2011-10-173-3/+7 * - Update to 0.44wen2011-10-132-4/+4 * - ${FFLAGS} might contain commaspav2011-10-111-1/+1 * - Update to 0.7wen2011-10-102-3/+3 * - Fix LICENSE (Artistic 1 instead of Artistic 2)culot2011-10-071-1/+1 * - Update to 2.25sunpoet2011-10-033-22/+23 * - Add build depends to silence build warningsswills2011-09-251-1/+2 * - Fix missing DEPENDS to silence build warningsswills2011-09-251-1/+2 * - Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)amdmi32011-09-245-10/+8 * - Update to 0.6wen2011-09-222-3/+3 * Change maintainer address to my FreeBSD addresscs2011-09-152-2/+2 * - Fix MASTER_SITES and WWW: linewen2011-08-262-33/+19 * - Add missing BUILD_DEPENDSswills2011-08-181-1/+2 * Remove USE_GNOME=gnometarget from ports. It has been a empty keyword sincekwm2011-08-122-2/+0 * - Update to 1.5.1wen2011-08-113-12/+41 * - Update to 0.40culot2011-08-102-3/+6 * Remove WWW entries from unmaintained ports that return 404 or where the domainehaupt2011-08-031-2/+0 * Deprecate port with no more public distfilesbapt2011-08-021-0/+3 * Bye bye abandonwares (part 2)bapt2011-08-0130-726/+0 * - Update to 0.39sunpoet2011-08-013-3/+34 * Now that the Java 1.3 and Java 1.4 ports are deprecated and will expire soon,linimon2011-07-212-2/+2 * - Update to 0.38sunpoet2011-07-163-50/+64 * - Update to 1.20sunpoet2011-07-132-73/+71 * - kick MD5miwi2011-07-021-1/+0 * - Use USERS and GROUPScrees2011-06-282-47/+3 * - Fix *_DEPENDS after the repocopy of databases/py-sqlalchemynivit2011-06-251-1/+2 * Switch dependency on povray to povray-meta port.makc2011-06-211-2/+2 * Another bunch of deprecation: no more public distfiles and/or abandonwarebapt2011-06-171-0/+3 * Another bunch of deprecation: no more public distfiles and/or abandonwarebapt2011-06-163-0/+9 * - Update to 0.5wen2011-06-102-3/+3 * Update to 1.1.04jlaffaye2011-06-105-126/+35 * deprecate and set expiration date:bapt2011-06-091-0/+3 * - Update to 0.4.3wen2011-06-022-3/+3 * - update to 2.24bapt2011-06-023-3/+10 * - Update to 1.57wen2011-05-243-111/+18 * Update to 1.6. Web site has been moved.maho2011-05-114-10/+11 * Update math/gsl to 1.15, and adjust PORTREVISIONbf2011-05-101-1/+2 * - Update to 0.4wen2011-05-092-3/+3 * update to 1.4.1maho2011-05-093-8/+41 * - Update to 2.11swills2011-05-092-3/+3 * Bump PORTREVISION after open-mofit updatemakc2011-05-024-2/+4 * Fix build with open-motif-2.3.3makc2011-05-023-7/+72 * - Updated WWW: to a working linkglarkin2011-04-231-14/+17 * Bio::GFF3 are low-level, fast functions for parsing GFF version 3 files.wen2011-04-225-0/+49 * - Update to 0.4.2wen2011-04-132-3/+3 * Update to GNU make 3.82 after numerous -exp runs.ade2011-04-121-0/+11 * - Update to 0.36wen2011-04-013-4/+14 * - Get Rid MD5 supportmiwi2011-03-19