aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dns/bind9-devel/Makefile13
-rw-r--r--dns/bind910/Makefile11
-rw-r--r--dns/bind911/Makefile13
-rw-r--r--dns/bind99/Makefile4
4 files changed, 25 insertions, 16 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 62cdc0ef7634..c312f1d1bf99 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -5,10 +5,10 @@ PORTNAME= bind
PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
.if defined(BIND_TOOLS_SLAVE)
# dns/bind-tools here
-PORTREVISION= 0
+PORTREVISION= 1
.else
# dns/bind9xx here
-PORTREVISION= 0
+PORTREVISION= 1
.endif
CATEGORIES= dns net ipv6
MASTER_SITES= LOCAL/mat/bind
@@ -48,7 +48,7 @@ CONFIGURE_ARGS+= --localstatedir=/var --disable-linux-caps \
--disable-symtable \
--with-randomdev=/dev/random \
--with-libxml2=${LOCALBASE} \
- --with-readline=-ledit \
+ --with-readline="-L${LOCALBASE}/lib -ledit" \
--with-dlopen=yes \
--sysconfdir=${ETCDIR}
.if defined(BIND_TOOLS_SLAVE)
@@ -63,8 +63,8 @@ CONFLICTS+= bind9*-9.[456789].* bind910-* bind911-* bind9*-sdb-9.[456789].*
SUB_FILES= pkg-message
.endif
-OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE
-OPTIONS_DEFINE= IDN LARGE_FILE PYTHON \
+OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE JSON
+OPTIONS_DEFINE= IDN LARGE_FILE PYTHON JSON \
FIXED_RRSET SIGCHASE IPV6 THREADS FILTER_AAAA
OPTIONS_RADIO= CRYPTO GOSTDEF
OPTIONS_RADIO_CRYPTO= SSL NATIVE_PKCS11
@@ -149,6 +149,9 @@ NATIVE_PKCS11_CONFIGURE_ENABLE= native-pkcs11
GEOIP_CONFIGURE_WITH= geoip
GEOIP_LIB_DEPENDS= libGeoIP.so:net/GeoIP
+JSON_LIB_DEPENDS= libjson-c.so:devel/json-c
+JSON_CONFIGURE_WITH= libjson
+
GOST_CONFIGURE_ON= --with-gost
GOST_ASN1_CONFIGURE_ON= --with-gost=asn1
diff --git a/dns/bind910/Makefile b/dns/bind910/Makefile
index 42a90fa1fa0f..665ba34ac1e1 100644
--- a/dns/bind910/Makefile
+++ b/dns/bind910/Makefile
@@ -5,10 +5,10 @@ PORTNAME= bind
PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
.if defined(BIND_TOOLS_SLAVE)
# dns/bind-tools here
-PORTREVISION= 0
+PORTREVISION= 1
.else
# dns/bind9xx here
-PORTREVISION= 0
+PORTREVISION= 1
.endif
CATEGORIES= dns net ipv6
MASTER_SITES= ISC/bind9/${ISCVERSION}
@@ -60,8 +60,8 @@ CONFLICTS+= bind9*-9.[456789].* bind911-* bind9*-sdb-9.[456789].*
SUB_FILES= pkg-message
.endif
-OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE
-OPTIONS_DEFINE= IDN LARGE_FILE PYTHON \
+OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE JSON
+OPTIONS_DEFINE= IDN LARGE_FILE PYTHON JSON \
FIXED_RRSET SIGCHASE IPV6 THREADS FILTER_AAAA
OPTIONS_RADIO= CRYPTO GOSTDEF
OPTIONS_RADIO_CRYPTO= SSL NATIVE_PKCS11
@@ -145,6 +145,9 @@ NATIVE_PKCS11_CONFIGURE_ENABLE= native-pkcs11
GEOIP_CONFIGURE_WITH= geoip
GEOIP_LIB_DEPENDS= libGeoIP.so:net/GeoIP
+JSON_LIB_DEPENDS= libjson-c.so:devel/json-c
+JSON_CONFIGURE_WITH= libjson
+
GOST_CONFIGURE_ON= --with-gost
GOST_ASN1_CONFIGURE_ON= --with-gost=asn1
diff --git a/dns/bind911/Makefile b/dns/bind911/Makefile
index c71d3426503a..f0698f85bdc5 100644
--- a/dns/bind911/Makefile
+++ b/dns/bind911/Makefile
@@ -5,10 +5,10 @@ PORTNAME= bind
PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
.if defined(BIND_TOOLS_SLAVE)
# dns/bind-tools here
-PORTREVISION= 0
+PORTREVISION= 1
.else
# dns/bind9xx here
-PORTREVISION= 0
+PORTREVISION= 1
.endif
CATEGORIES= dns net ipv6
MASTER_SITES= ISC/bind9/${ISCVERSION}
@@ -46,7 +46,7 @@ CONFIGURE_ARGS+= --localstatedir=/var --disable-linux-caps \
--disable-symtable \
--with-randomdev=/dev/random \
--with-libxml2=${LOCALBASE} \
- --with-readline=-ledit \
+ --with-readline="-L${LOCALBASE}/lib -ledit" \
--with-dlopen=yes \
--sysconfdir=${ETCDIR}
.if defined(BIND_TOOLS_SLAVE)
@@ -60,8 +60,8 @@ CONFLICTS+= bind9*-9.[456789].* bind910-* bind9*-sdb-9.[456789].*
SUB_FILES= pkg-message
.endif
-OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE
-OPTIONS_DEFINE= IDN LARGE_FILE PYTHON \
+OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE JSON
+OPTIONS_DEFINE= IDN LARGE_FILE PYTHON JSON \
FIXED_RRSET SIGCHASE IPV6 THREADS FILTER_AAAA
OPTIONS_RADIO= CRYPTO GOSTDEF
OPTIONS_RADIO_CRYPTO= SSL NATIVE_PKCS11
@@ -146,6 +146,9 @@ NATIVE_PKCS11_CONFIGURE_ENABLE= native-pkcs11
GEOIP_CONFIGURE_WITH= geoip
GEOIP_LIB_DEPENDS= libGeoIP.so:net/GeoIP
+JSON_LIB_DEPENDS= libjson-c.so:devel/json-c
+JSON_CONFIGURE_WITH= libjson
+
GOST_CONFIGURE_ON= --with-gost
GOST_ASN1_CONFIGURE_ON= --with-gost=asn1
diff --git a/dns/bind99/Makefile b/dns/bind99/Makefile
index 4258964c5bf7..41c6ccf0b294 100644
--- a/dns/bind99/Makefile
+++ b/dns/bind99/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bind
PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= dns net ipv6
MASTER_SITES= ISC/bind9/${ISCVERSION}
PKGNAMESUFFIX= 99
@@ -32,7 +32,7 @@ CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
--disable-symtable \
--with-randomdev=/dev/random \
--with-libxml2=${LOCALBASE} \
- --with-readline=-ledit \
+ --with-readline="-L${LOCALBASE}/lib -ledit" \
--with-dlopen=yes \
--sysconfdir=${ETCDIR}
ETCDIR= ${PREFIX}/etc/namedb