aboutsummaryrefslogtreecommitdiffstats
path: root/dns/bind910/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/bind910/Makefile')
-rw-r--r--dns/bind910/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/dns/bind910/Makefile b/dns/bind910/Makefile
index 42a90fa1fa0f..665ba34ac1e1 100644
--- a/dns/bind910/Makefile
+++ b/dns/bind910/Makefile
@@ -5,10 +5,10 @@ PORTNAME= bind
PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
.if defined(BIND_TOOLS_SLAVE)
# dns/bind-tools here
-PORTREVISION= 0
+PORTREVISION= 1
.else
# dns/bind9xx here
-PORTREVISION= 0
+PORTREVISION= 1
.endif
CATEGORIES= dns net ipv6
MASTER_SITES= ISC/bind9/${ISCVERSION}
@@ -60,8 +60,8 @@ CONFLICTS+= bind9*-9.[456789].* bind911-* bind9*-sdb-9.[456789].*
SUB_FILES= pkg-message
.endif
-OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE
-OPTIONS_DEFINE= IDN LARGE_FILE PYTHON \
+OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE JSON
+OPTIONS_DEFINE= IDN LARGE_FILE PYTHON JSON \
FIXED_RRSET SIGCHASE IPV6 THREADS FILTER_AAAA
OPTIONS_RADIO= CRYPTO GOSTDEF
OPTIONS_RADIO_CRYPTO= SSL NATIVE_PKCS11
@@ -145,6 +145,9 @@ NATIVE_PKCS11_CONFIGURE_ENABLE= native-pkcs11
GEOIP_CONFIGURE_WITH= geoip
GEOIP_LIB_DEPENDS= libGeoIP.so:net/GeoIP
+JSON_LIB_DEPENDS= libjson-c.so:devel/json-c
+JSON_CONFIGURE_WITH= libjson
+
GOST_CONFIGURE_ON= --with-gost
GOST_ASN1_CONFIGURE_ON= --with-gost=asn1