aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/linbot/Makefile40
-rw-r--r--www/linbot/distinfo1
-rw-r--r--www/linbot/files/patch-compat123
-rw-r--r--www/linbot/files/patch-usage21
-rw-r--r--www/linbot/pkg-comment1
-rw-r--r--www/linbot/pkg-descr9
-rw-r--r--www/linbot/pkg-plist33
8 files changed, 0 insertions, 229 deletions
diff --git a/www/Makefile b/www/Makefile
index 403b20f13be6..ad9167f5a10d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -122,7 +122,6 @@
SUBDIR += libgtkhtml
SUBDIR += libwww
SUBDIR += libxpg4-ns
- SUBDIR += linbot
SUBDIR += links
SUBDIR += linux-flashplugin
SUBDIR += linux-lesstif-ns
diff --git a/www/linbot/Makefile b/www/linbot/Makefile
deleted file mode 100644
index c39f4b307ea4..000000000000
--- a/www/linbot/Makefile
+++ /dev/null
@@ -1,40 +0,0 @@
-# New ports collection makefile for: linbot
-# Date created: 19 September 1998
-# Whom: Bill Fumerola <billf@chc-chimes.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= linbot
-PORTVERSION= 1.0
-PORTREVISION= 3
-CATEGORIES= www python
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
-MASTER_SITE_SUBDIR= apps/www/misc
-EXTRACT_SUFX= .tgz
-
-MAINTAINER= mwm@mired.org
-
-USE_PYTHON= YES
-
-do-install:
- ${MKDIR} ${PREFIX}/share/linbot
- ${CP} ${WRKSRC}/*.py ${PREFIX}/share/linbot
- ${CP} ${WRKSRC}/*.css ${PREFIX}/share/linbot
-.for d in plugins schemes
- ${MKDIR} ${PREFIX}/share/linbot/${d}
- ${CP} ${WRKSRC}/${d}/*.py ${PREFIX}/share/linbot/${d}
-.endfor
- ${LN} -sf ${PREFIX}/share/linbot/linbot.py ${PREFIX}/bin/linbot
-.ifndef NOPORTDOCS
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/USAGE ${DOCSDIR}
-
-do-build:
- ${AWK} '/^Running Linbot/ { output=1 } output' \
- < ${WRKSRC}/INSTALL > ${WRKSRC}/USAGE
-.else
-NO_BUILD= yeah
-.endif
-
-.include <bsd.port.mk>
diff --git a/www/linbot/distinfo b/www/linbot/distinfo
deleted file mode 100644
index c15e5bde2b36..000000000000
--- a/www/linbot/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (linbot-1.0.tgz) = c1926fb359532daee0ea8fcade08e345
diff --git a/www/linbot/files/patch-compat b/www/linbot/files/patch-compat
deleted file mode 100644
index 7cf29a908699..000000000000
--- a/www/linbot/files/patch-compat
+++ /dev/null
@@ -1,123 +0,0 @@
---- myUrlLib.py Sun Mar 14 14:24:20 1999
-+++ myUrlLib.py Wed Apr 3 10:52:19 2002
-@@ -37,6 +38,7 @@
- import htmlparse
- import debugio
- import sys
-+import socket
-
-
- def get_robots(location):
-@@ -77,7 +79,7 @@
- self.init()
-
- debugio.write('\tparent = ' + str(parent),2)
-- from urlparse import *
-+ from urlparse import urlparse
-
- parsed = urlparse(url)
- self.scheme = parsed[0]
-@@ -105,7 +107,10 @@
-
- if (parent is None):
- Link.baseurl=self.URL
-- Link.base=self.URL[:string.rfind(self.URL,'/')+1]
-+ if hasattr(self.URL, 'rfind'):
-+ Link.base=self.URL[:self.URL.rfind('/')+1]
-+ else:
-+ Link.base=self.URL[:string.rfind(self.URL,'/')+1]
- if Link.base[-2:] == '//': Link.base = self.URL
- debugio.write('\tbase: %s' % Link.base)
- if self.scheme == 'http':
-@@ -257,7 +262,7 @@
-
- def is_external(url):
- """ returns true if url is an external link """
-- from urlparse import *
-+ from urlparse import urlparse
- parsed = urlparse(url)
- scheme = parsed[0]
- location = parsed[1]
---- robotparser.py Sat Jan 9 19:01:45 1999
-+++ robotparser.py Wed Jul 18 20:29:13 2001
-@@ -37,7 +37,7 @@
- self.parse(urlopener.open(self.url).readlines())
-
- def parse(self, lines):
-- import regsub, string, regex
-+ import re, string
- active = []
- for line in lines:
- if self.debug: print '>', line,
-@@ -49,7 +49,7 @@
- line = string.strip(line[:string.find(line, '#')])
- if not line:
- continue
-- line = regsub.split(line, ' *: *')
-+ line = re.split(' *: *', line)
- if len(line) == 2:
- line[0] = string.lower(line[0])
- if line[0] == 'user-agent':
-@@ -62,7 +62,7 @@
- if line[1]:
- if self.debug: print '>> disallow:', line[1]
- for agent in active:
-- self.rules[agent].append(regex.compile(line[1]))
-+ self.rules[agent].append(re.compile(line[1]))
- else:
- pass
- for agent in active:
-@@ -83,7 +83,7 @@
- return 1
- path = urlparse.urlparse(url)[2]
- for rule in self.rules[ag]:
-- if rule.match(path) != -1:
-+ if rule.match(path):
- if self.debug: print '>> disallowing', url, 'fetch by', agent
- return 0
- if self.debug: print '>> allowing', url, 'fetch by', agent
---- schemes/filelink.py Thu Mar 11 22:56:07 1999
-+++ schemes/filelink.py Wed Jul 18 20:19:26 2001
-@@ -42,7 +42,7 @@
- import time
- import mimetypes
- import myUrlLib
--import regsub
-+import re
-
- mimetypes.types_map['.shtml']='text/html'
-
-@@ -51,7 +51,7 @@
- parsed = urlparse.urlparse(self.URL,'file',0)
- filename = parsed[2]
- if os.name != 'posix':
-- filename = regsub.sub("^/\(//\)?\([a-zA-Z]\)[|:]","\\2:",filename)
-+ filename = re.sub("^/\(//\)?\([a-zA-Z]\)[|:]","\\2:",filename)
- try:
- stats = os.stat(filename)
- except os.error:
-@@ -70,7 +70,7 @@
- parsed = urlparse.urlparse(url,'file',0)
- filename = parsed[2]
- if os.name != 'posix':
-- filename = regsub.sub("^/\(//\)?\([a-zA-Z]\)[|:]","\\2:",filename)
-+ filename = re.sub("^/\(//\)?\([a-zA-Z]\)[|:]","\\2:",filename)
-
- return open(filename,'r').read()
-
---- htmlparse.py Wed Mar 10 23:51:25 1999
-+++ htmlparse.py Wed Apr 3 11:10:55 2002
-@@ -48,5 +48,5 @@
- based on parent"""
-
-- from urlparse import *
-+ from urlparse import urlparse
-
- method=urlparse(url)[0]
-@@ -125,5 +125,5 @@
- the <BASE HREF=> tag."""
- import htmllib
-- from urlparse import *
-+ from urlparse import urlparse
- from formatter import NullFormatter
-
diff --git a/www/linbot/files/patch-usage b/www/linbot/files/patch-usage
deleted file mode 100644
index 4d004c10f2bd..000000000000
--- a/www/linbot/files/patch-usage
+++ /dev/null
@@ -1,21 +0,0 @@
-This patch simply fixes a few typos. The author clearly did not care to
-run a spell-checker :)
-
- -mi
-
---- INSTALL Thu Mar 11 23:56:00 1999
-+++ INSTALL Thu Jul 12 02:30:50 2001
-@@ -31 +31 @@
--It is simple t run Linbot.
-+It is simple to run Linbot.
-@@ -71 +71 @@
--internal documents. An exampel would be a main server
-+internal documents. An example would be a main server
-@@ -148,2 +148,2 @@
-- locationThis specifies the hosts pointed to that are to be considered
-- internal. By default Linbot only consideres urls pointing to the
-+ location This specifies the hosts pointed to that are to be considered
-+ internal. By default Linbot only considers URLs pointing to the
-@@ -185 +185 @@
--concering bug reports.
-+concerning bug reports.
diff --git a/www/linbot/pkg-comment b/www/linbot/pkg-comment
deleted file mode 100644
index fbfb6c0d9912..000000000000
--- a/www/linbot/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-View structure of a web site, get a list of problems like broken links
diff --git a/www/linbot/pkg-descr b/www/linbot/pkg-descr
deleted file mode 100644
index 1541eb622e90..000000000000
--- a/www/linbot/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-Linbot is the professional Site Management Tool for webmasters. Linbot
-allows webmasters to view the structure of a site, track down broken links,
-find potentially outdated web pages list links pointing to external sites,
-view portfolio of inline images, get a run-down of problems sorted by
-author and to do all this periodically without user intervention.
-
-WWW: http://starship.python.net/crew/marduk/linbot/
-
-Bill Fumerola (billf@chc-chimes.com)
diff --git a/www/linbot/pkg-plist b/www/linbot/pkg-plist
deleted file mode 100644
index 757627a71d8a..000000000000
--- a/www/linbot/pkg-plist
+++ /dev/null
@@ -1,33 +0,0 @@
-share/linbot/config.py
-share/linbot/debugio.py
-share/linbot/htmlparse.py
-share/linbot/httpcodes.py
-share/linbot/linbot.css
-share/linbot/linbot.py
-share/linbot/myUrlLib.py
-share/linbot/plugins/__init__.py
-share/linbot/plugins/badlinks.py
-share/linbot/plugins/external.py
-share/linbot/plugins/images.py
-share/linbot/plugins/notchkd.py
-share/linbot/plugins/notitles.py
-share/linbot/plugins/problems.py
-share/linbot/plugins/rptlib.py
-share/linbot/plugins/sitemap.py
-share/linbot/plugins/slow.py
-share/linbot/plugins/whatsnew.py
-share/linbot/plugins/whatsold.py
-share/linbot/robotparser.py
-share/linbot/schemes/__init__.py
-share/linbot/schemes/filelink.py
-share/linbot/schemes/ftplink.py
-share/linbot/schemes/httplink.py
-share/linbot/version.py
-%%PORTDOCS%%share/doc/linbot/USAGE
-%%PORTDOCS%%@dirrm share/doc/linbot/
-@unexec rm -f %D/share/linbot/*.py[co] %D/share/linbot/*/*.py[co]
-@dirrm share/linbot/plugins
-@dirrm share/linbot/schemes
-@dirrm share/linbot
-@exec ln -fs %D/share/linbot/linbot.py %D/bin/linbot
-@unexec rm %D/bin/linbot