aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pydbx/Makefile20
-rw-r--r--databases/pydbx/distinfo2
-rw-r--r--databases/pydbx/pkg-descr6
-rw-r--r--databases/pydbx/pkg-plist10
5 files changed, 39 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index b4e58831df78..ff7e752e5bde 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -346,6 +346,7 @@
SUBDIR += py-sybase
SUBDIR += py-tada
SUBDIR += pydbdesigner
+ SUBDIR += pydbx
SUBDIR += qdbm
SUBDIR += qt-ibase-plugin
SUBDIR += qt-mysql-plugin
diff --git a/databases/pydbx/Makefile b/databases/pydbx/Makefile
new file mode 100644
index 000000000000..887b781c1cff
--- /dev/null
+++ b/databases/pydbx/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: py-dbx
+# Date created: 2005-12-18
+# Whom: David Phillips <david@acz.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pydbx
+PORTVERSION= 0.13
+CATEGORIES= databases python
+MASTER_SITES= http://david.acz.org/pydbx/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= david@acz.org
+COMMENT= Simple SQL database abstraction layer for Python
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/databases/pydbx/distinfo b/databases/pydbx/distinfo
new file mode 100644
index 000000000000..225ad99f76ae
--- /dev/null
+++ b/databases/pydbx/distinfo
@@ -0,0 +1,2 @@
+MD5 (pydbx-0.13.tar.gz) = c5804b34d987538e7cf795dac1a34028
+SIZE (pydbx-0.13.tar.gz) = 3574
diff --git a/databases/pydbx/pkg-descr b/databases/pydbx/pkg-descr
new file mode 100644
index 000000000000..b3a75887bac6
--- /dev/null
+++ b/databases/pydbx/pkg-descr
@@ -0,0 +1,6 @@
+dbx is a simple SQL database abstraction layer for Python. The goal
+of dbx is to make using a SQL database as simple as possible while
+providing a consistent API across different databases.
+
+Author: David Phillips <david@acz.org>
+WWW: http://david.acz.org/pydbx/
diff --git a/databases/pydbx/pkg-plist b/databases/pydbx/pkg-plist
new file mode 100644
index 000000000000..484a3813a437
--- /dev/null
+++ b/databases/pydbx/pkg-plist
@@ -0,0 +1,10 @@
+%%PYTHON_SITELIBDIR%%/dbx/__init__.py
+%%PYTHON_SITELIBDIR%%/dbx/__init__.pyc
+%%PYTHON_SITELIBDIR%%/dbx/__init__.pyo
+%%PYTHON_SITELIBDIR%%/dbx/mysql.py
+%%PYTHON_SITELIBDIR%%/dbx/mysql.pyc
+%%PYTHON_SITELIBDIR%%/dbx/mysql.pyo
+%%PYTHON_SITELIBDIR%%/dbx/sqlite.py
+%%PYTHON_SITELIBDIR%%/dbx/sqlite.pyc
+%%PYTHON_SITELIBDIR%%/dbx/sqlite.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/dbx