aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Scripts/check-stagedir.sh2
-rw-r--r--Mk/Scripts/qa.sh2
-rw-r--r--Mk/Uses/gssapi.mk15
-rw-r--r--Mk/Uses/kde.mk4
-rw-r--r--Mk/Uses/meson.mk3
-rw-r--r--Mk/Uses/pear.mk2
-rw-r--r--Mk/Uses/python.mk2
-rw-r--r--Mk/Uses/qt.mk16
-rw-r--r--Mk/Uses/ssl.mk2
-rw-r--r--Mk/bsd.default-versions.mk2
-rw-r--r--Mk/bsd.gecko.mk9
-rw-r--r--Mk/bsd.gstreamer.mk14
-rw-r--r--Mk/bsd.port.mk12
13 files changed, 36 insertions, 49 deletions
diff --git a/Mk/Scripts/check-stagedir.sh b/Mk/Scripts/check-stagedir.sh
index 0b0f1377351c..9037df598e6b 100644
--- a/Mk/Scripts/check-stagedir.sh
+++ b/Mk/Scripts/check-stagedir.sh
@@ -154,7 +154,7 @@ check_orphans_from_plist() {
*/.svn/*|'@dir '*/.svn) ;;
*/.svnignore) ;;
*/CVS/*|'@dir '*/CVS) ;;
- */info/dir|info/dir|info/*/dir) ;;
+ */info/dir|info/dir|info/*/dir|share/info/*/dir) ;;
share/fonts/*/fonts.dir) ;;
share/fonts/*/fonts.scale) ;;
share/applications/mimeinfo.cache) ;;
diff --git a/Mk/Scripts/qa.sh b/Mk/Scripts/qa.sh
index e6ad01b84b0e..a56fe69f9614 100644
--- a/Mk/Scripts/qa.sh
+++ b/Mk/Scripts/qa.sh
@@ -611,7 +611,7 @@ proxydeps_suggest_uses() {
elif [ ${pkg} = "devel/readline" ]; then
warn "you need USES+=readline"
# ssl
- elif [ ${pkg} = "security/openssl" -o ${pkg} = "security/openssl-devel" \
+ elif [ ${pkg} = "security/openssl" -o ${pkg} = "security/openssl111" \
-o ${pkg} = "security/libressl" -o ${pkg} = "security/libressl-devel" \
]; then
warn "you need USES=ssl"
diff --git a/Mk/Uses/gssapi.mk b/Mk/Uses/gssapi.mk
index f1e76ffc40b3..c09051ef2554 100644
--- a/Mk/Uses/gssapi.mk
+++ b/Mk/Uses/gssapi.mk
@@ -79,7 +79,6 @@ _HEIMDAL_DEPENDS=${GSSAPILIBDIR}/libgssapi.so:security/heimdal
_MITKRB5_DEPENDS=${GSSAPILIBDIR}/libkrb5support.so:security/krb5
_HEADERS= sys/types.h sys/stat.h stdint.h
-.undef _FIXUP_KRB5CONFIG
.if empty(gssapi_ARGS)
gssapi_ARGS= base
.endif
@@ -97,9 +96,6 @@ _HEADERS+= gssapi/gssapi.h gssapi/gssapi_krb5.h krb5.h
GSSAPICPPFLAGS= -I"${GSSAPIINCDIR}"
GSSAPILIBS= -lkrb5 -lgssapi -lgssapi_krb5
GSSAPILDFLAGS= -L"${GSSAPILIBDIR}"
-.if empty(OSREL:N9.3)
-_FIXUP_KRB5CONFIG= yes
-.endif
.elif ${_local} == "heimdal"
HEIMDAL_HOME?= ${LOCALBASE}
GSSAPIBASEDIR= ${HEIMDAL_HOME}
@@ -141,18 +137,7 @@ IGNORE= USES=gssapi - invalid args: [${_local}] specified
.endif
.endfor
-# Fix up krb5-config if broken. This script included in 9.X prior to
-# r271474 and in 10.X prior to r271473 are broken because
-# libgssapi_krb5 for some interfaces of GSS-API is missing.
-.if defined(_FIXUP_KRB5CONFIG)
-KRB5CONFIG=${WRKDIR}/krb5-config
-_USES_configure+= 290:krb5config-fix
-krb5config-fix:
- ${SED} -e 's,\$$lib_flags -lgssapi -lheimntlm,\$$lib_flags -lgssapi -lgssapi_krb5 -lheimntlm,' < ${GSSAPIBASEDIR}/bin/krb5-config > ${KRB5CONFIG}
- ${CHMOD} a+rx ${KRB5CONFIG}
-.else
KRB5CONFIG=${GSSAPIBASEDIR}/bin/krb5-config
-.endif
# Fix up -Wl,-rpath in LDFLAGS
.if defined(_RPATH) && !empty(_RPATH)
diff --git a/Mk/Uses/kde.mk b/Mk/Uses/kde.mk
index 9bdf08817519..95ed73bae103 100644
--- a/Mk/Uses/kde.mk
+++ b/Mk/Uses/kde.mk
@@ -74,8 +74,8 @@ KDE_FRAMEWORKS_VERSION?= 5.51.0
KDE_FRAMEWORKS_BRANCH?= stable
# Current KDE applications.
-KDE_APPLICATIONS_VERSION?= 18.08.2
-KDE_APPLICATIONS_SHLIB_VER?= 5.9.2
+KDE_APPLICATIONS_VERSION?= 18.08.3
+KDE_APPLICATIONS_SHLIB_VER?= 5.9.3
KDE_APPLICATIONS_BRANCH?= stable
# Upstream moves old software to Attic/. Specify the newest applications release there.
# Only the major version is used for the comparison.
diff --git a/Mk/Uses/meson.mk b/Mk/Uses/meson.mk
index e8afcabe30e3..d3904c104db4 100644
--- a/Mk/Uses/meson.mk
+++ b/Mk/Uses/meson.mk
@@ -35,7 +35,8 @@ BUILD_DEPENDS+= meson:devel/meson
USE_LOCALE?= en_US.UTF-8
CONFIGURE_ARGS+= --prefix ${PREFIX} \
- --mandir man
+ --mandir man \
+ --infodir ${INFO_PATH}
# meson has it own strip mechanic
INSTALL_TARGET= install
diff --git a/Mk/Uses/pear.mk b/Mk/Uses/pear.mk
index 62fc26f835a0..7bd88b2e9d4b 100644
--- a/Mk/Uses/pear.mk
+++ b/Mk/Uses/pear.mk
@@ -20,7 +20,7 @@ _valid_pear_ARGS= env
# Sanity check
. for arg in ${pear_ARGS}
. if empty(_valid_pear_ARGS:M${arg})
-IGNORE= Incorrect 'USES+= pear:${cmake_ARGS}' usage: argument [${arg}] is not recognized
+IGNORE= Incorrect 'USES+= pear:${pear_ARGS}' usage: argument [${arg}] is not recognized
. endif
. endfor
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index 1c40c843be3c..ff7f14d0e9a0 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -613,7 +613,7 @@ add-plist-pymod:
.if ${PYTHON_REL} >= 3200 && defined(_PYTHON_FEATURE_PY3KPLIST)
# When Python version is 3.2+ we rewrite all the filenames
# of TMPPLIST that end with .py[co], so that they conform
-# to PEP 3147 (see http://www.python.org/dev/peps/pep-3147/)
+# to PEP 3147 (see https://www.python.org/dev/peps/pep-3147/)
PYMAGICTAG= ${PYTHON_CMD} -c 'import imp; print(imp.get_tag())'
_USES_stage+= 935:add-plist-python
add-plist-python:
diff --git a/Mk/Uses/qt.mk b/Mk/Uses/qt.mk
index b06963f26fbb..93643f864451 100644
--- a/Mk/Uses/qt.mk
+++ b/Mk/Uses/qt.mk
@@ -137,7 +137,7 @@ _USES_POST+= qt
_QT_MK_POST_INCLUDED= qt.mk
# The Qt components supported by qt.mk: list of shared, and version specific ones
-_USE_QT_ALL= assistant dbus designer doc gui help \
+_USE_QT_ALL= assistant dbus declarative designer doc gui help \
imageformats l10n linguist linguisttools multimedia \
network opengl pixeltool qdbusviewer qmake script \
scripttools sql sql-ibase sql-mysql sql-odbc sql-pgsql \
@@ -145,7 +145,7 @@ _USE_QT_ALL= assistant dbus designer doc gui help \
xml xmlpatterns
_USE_QT4_ONLY= accessible assistant-adp assistantclient clucene codecs-cn codecs-jp \
- codecs-kr codecs-tw corelib declarative demo graphicssystems-opengl \
+ codecs-kr codecs-tw corelib demo graphicssystems-opengl \
help-tools iconengines inputmethods makeqpf moc phonon \
phonon-gst porting qdoc3 qmlviewer qt3support qtconfig \
qtestlib qvfb rcc uic uic3 xmlpatterns-tool
@@ -153,7 +153,7 @@ _USE_QT4_ONLY= accessible assistant-adp assistantclient clucene codecs-cn codec
_USE_QT5_ONLY= 3d buildtools canvas3d charts concurrent connectivity \
core datavis3d diag examples gamepad \
graphicaleffects location paths phonon4 plugininfo printsupport \
- qdbus qdoc qdoc-data qev qml quick quickcontrols \
+ qdbus qdoc qdoc-data qev quickcontrols \
quickcontrols2 scxml sensors serialbus serialport speech \
sql-tds uiplugin uitools virtualkeyboard wayland webchannel \
webengine websockets websockets-qml widgets x11extras
@@ -217,7 +217,11 @@ dbus_PORT= devel/${_QT_RELNAME}-dbus
dbus_LIB= libQt${_QT_LIBVER}DBus.so
declarative_PORT= x11-toolkits/${_QT_RELNAME}-declarative
+. if ${_QT_VER:M4}
declarative_LIB= libQt${_QT_LIBVER}Declarative.so
+. else
+declarative_LIB= libQt${_QT_LIBVER}Qml.so
+. endif
demo_PORT= misc/${_QT_RELNAME}-qtdemo
demo_PATH= ${LOCALBASE}/${QT_BINDIR_REL}/qtdemo
@@ -333,9 +337,6 @@ qev_PATH= ${LOCALBASE}/${QT_BINDIR_REL}/qev
qmake_PORT= devel/${_QT_RELNAME}-qmake
qmake_PATH= ${LOCALBASE}/${QT_BINDIR_REL}/qmake
-qml_PORT= lang/${_QT_RELNAME}-qml
-qml_LIB= libQt${_QT_LIBVER}Qml.so
-
qmlviewer_PORT= devel/${_QT_RELNAME}-qmlviewer
qmlviewer_PATH= ${LOCALBASE}/${QT_BINDIR_REL}/qmlviewer
@@ -348,9 +349,6 @@ qtconfig_PATH= ${LOCALBASE}/${QT_BINDIR_REL}/qtconfig
qtestlib_PORT= ${testlib_PORT}
qtestlib_LIB= ${testlib_LIB}
-quick_PORT= x11-toolkits/${_QT_RELNAME}-quick
-quick_LIB= libQt${_QT_LIBVER}Quick.so
-
quickcontrols_PORT= x11-toolkits/${_QT_RELNAME}-quickcontrols
quickcontrols_PATH= ${LOCALBASE}/${QT_QMLDIR_REL}/QtQuick/Controls/qmldir
diff --git a/Mk/Uses/ssl.mk b/Mk/Uses/ssl.mk
index 941467a18de1..4e5d48099d8c 100644
--- a/Mk/Uses/ssl.mk
+++ b/Mk/Uses/ssl.mk
@@ -10,7 +10,7 @@
#
# DEFAULT_VERSIONS+= ssl=<openssl variant>
#
-# Variants being base, openssl, openssl-devel, openssl111, libressl, and libressl-devel.
+# Variants being base, openssl, openssl111, libressl, and libressl-devel.
#
# The Makefile sets these variables:
# OPENSSLBASE - "/usr" or ${LOCALBASE}
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index 38197e1d1ea3..0a55c65cdd73 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -88,7 +88,7 @@ PYTHON3_DEFAULT?= 3.6
RUBY_DEFAULT?= 2.4
# Possible values: 4.6, 4.7, 4.8
SAMBA_DEFAULT?= 4.7
-# Possible values: base, openssl, openssl-devel, openssl111, libressl, libressl-devel
+# Possible values: base, openssl, openssl111, libressl, libressl-devel
.if !defined(SSL_DEFAULT)
# If no preference was set, check for an installed base version
# but give an installed port preference over it.
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index dd4b07fc85f0..f8d2400ce36b 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -81,9 +81,10 @@ MOZILLA_VER?= ${PORTVERSION}
MOZILLA_BIN?= ${PORTNAME}-bin
MOZILLA_EXEC_NAME?=${MOZILLA}
MOZ_RPATH?= ${MOZILLA}
-USES+= cpe gmake iconv localbase perl5 pkgconfig \
+USES+= cpe gl gmake iconv localbase perl5 pkgconfig \
python:2.7,build desktop-file-utils
CPE_VENDOR?=mozilla
+USE_GL= gl
USE_PERL5= build
USE_XORG= x11 xcomposite xdamage xext xfixes xrender xt
HAS_CONFIGURE= yes
@@ -162,8 +163,6 @@ RUSTFLAGS+= ${CFLAGS:M-mcpu=*:S/-mcpu=/-C target-cpu=/}
MOZ_EXPORT+= MOZ_JEMALLOC4=1
.if ${MOZILLA_VER:R:R} >= 48
MOZ_OPTIONS+= --enable-jemalloc=4
-.elif ${OSVERSION} < 1100079
-MOZ_OPTIONS+= --enable-jemalloc
.endif # Mozilla >= 48
.endif # Mozilla < 55
@@ -289,6 +288,7 @@ MOZ_TOOLKIT= cairo-gtk2
MOZ_TOOLKIT= cairo-gtk3-wayland
.endif
+USES+= gnome
.if ${MOZ_TOOLKIT:Mcairo-gtk3*}
BUILD_DEPENDS+= gtk3>=3.14.6:x11-toolkits/gtk30
USE_GNOME+= gdkpixbuf2 gtk20 gtk30
@@ -412,9 +412,6 @@ MOZ_OPTIONS+= --enable-rust-simd
.if ${PORT_OPTIONS:MDTRACE}
MOZ_OPTIONS+= --enable-dtrace \
--disable-gold
-. if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100061
-LIBS+= -lelf
-. endif
STRIP=
.else
MOZ_OPTIONS+= --disable-dtrace
diff --git a/Mk/bsd.gstreamer.mk b/Mk/bsd.gstreamer.mk
index a172cd321d49..5599634f11f4 100644
--- a/Mk/bsd.gstreamer.mk
+++ b/Mk/bsd.gstreamer.mk
@@ -98,7 +98,6 @@ _GSTREAMER_PLUGINS= \
pango \
pulse \
resindvd \
- schroedinger \
shout2 \
sndfile \
sndio \
@@ -137,6 +136,7 @@ _GSTREAMER_PLUGINS+= \
nas \
python \
qt4 \
+ schroedinger \
sdl \
vdpau \
vp8 \
@@ -146,6 +146,7 @@ _GSTREAMER_PLUGINS+= \
# plugins only in 1.0
.if defined(USE_GSTREAMER1)
_GSTREAMER_PLUGINS+= \
+ aom \
assrender \
bs2b \
chromaprint \
@@ -166,6 +167,7 @@ _GSTREAMER_PLUGINS+= \
openexr \
openh264 \
openjpeg \
+ openmpt \
png \
rsvg \
rtmp \
@@ -174,6 +176,7 @@ _GSTREAMER_PLUGINS+= \
srtp \
ttml \
vpx \
+ vulkan \
webp \
x \
x265 \
@@ -356,6 +359,9 @@ aalib_IMPL= good
annodex_DEPENDS= multimedia/gstreamer-plugins-annodex
annodex_IMPL= good
+aom_DEPENDS= multimedia/gstreamer-plugins-aom
+aom_IMPL= bad
+
assrender_DEPENDS= multimedia/gstreamer-plugins-assrender
assrender_IMPL= bad
@@ -392,6 +398,9 @@ openexr_IMPL= bad
openjpeg_DEPENDS= graphics/gstreamer-plugins-openjpeg
openjpeg_IMPL= bad
+openmpt_DEPENDS= audio/gstreamer-plugins-openmpt
+openmpt_IMPL= bad
+
png_DEPENDS= graphics/gstreamer-plugins-png
png_IMPL= good
@@ -507,6 +516,9 @@ vp8_IMPL= bad
vpx_DEPENDS= multimedia/gstreamer-plugins-vpx
vpx_IMPL= good
+vulkan_DEPENDS= graphics/gstreamer-plugins-vulkan
+vulkan_IMPL= bad
+
# XXX: This is a quick solution for ports with USE_GSTREAMER=python
# but without USE_PYTHON.
PYTHON_PKGNAMEPREFIX?= py*-
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 1ccbf30d433e..7f948c334793 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -543,8 +543,6 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# the path relative to ${INFO_PATH}.
# INFO_PATH - Path, where all .info files will be installed by your
# port, relative to ${PREFIX}
-# Default: "share/info" if ${PREFIX} is equal to /usr
-# and "info" otherwise.
#
# Set the following to specify all documentation your port installs into
# ${DOCSDIR}
@@ -1180,7 +1178,7 @@ OSVERSION!= ${AWK} '/^\#define[[:blank:]]__FreeBSD_version/ {print $$3}' < ${SRC
.endif
_EXPORTED_VARS+= OSVERSION
-.if (${OPSYS} == FreeBSD && (${OSVERSION} < 1004000 || (${OSVERSION} >= 1100000 && ${OSVERSION} < 1102000))) || \
+.if (${OPSYS} == FreeBSD && ${OSVERSION} < 1102000) || \
(${OPSYS} == DragonFly && ${DFLYVERSION} < 400400)
_UNSUPPORTED_SYSTEM_MESSAGE= Ports Collection support for your ${OPSYS} version has ended, and no ports\
are guaranteed to build on this system. Please upgrade to a supported release.
@@ -1506,7 +1504,8 @@ FLAVORS:= ${FLAVOR} ${FLAVORS:N${FLAVOR}}
.if !empty(FLAVOR) && !defined(_DID_FLAVORS_HELPERS)
_DID_FLAVORS_HELPERS= yes
-_FLAVOR_HELPERS_OVERRIDE= DESCR PLIST PKGNAMEPREFIX PKGNAMESUFFIX
+_FLAVOR_HELPERS_OVERRIDE= DESCR PLIST PKGNAMEPREFIX PKGNAMESUFFIX \
+ DEPRECATED EXPIRATION_DATE
_FLAVOR_HELPERS_APPEND= CONFLICTS CONFLICTS_BUILD CONFLICTS_INSTALL \
PKG_DEPENDS EXTRACT_DEPENDS PATCH_DEPENDS \
FETCH_DEPENDS BUILD_DEPENDS LIB_DEPENDS \
@@ -2671,12 +2670,7 @@ MAN${sect}PREFIX?= ${MANPREFIX}
.endfor
MANLPREFIX?= ${MANPREFIX}
MANNPREFIX?= ${MANPREFIX}
-
-.if ${PREFIX} == /usr
INFO_PATH?= share/info
-.else
-INFO_PATH?= info
-.endif
.if defined(INFO)
RUN_DEPENDS+= indexinfo:print/indexinfo