aboutsummaryrefslogtreecommitdiffstats
path: root/devel/fpp
diff options
context:
space:
mode:
Diffstat (limited to 'devel/fpp')
-rw-r--r--devel/fpp/files/patch-ab60
-rw-r--r--devel/fpp/files/patch-sparc::Makefile17
2 files changed, 39 insertions, 38 deletions
diff --git a/devel/fpp/files/patch-ab b/devel/fpp/files/patch-ab
index 4eaa9386d03b..9ed4e15dacae 100644
--- a/devel/fpp/files/patch-ab
+++ b/devel/fpp/files/patch-ab
@@ -1,38 +1,22 @@
-*** src/Makefile.common.orig Wed Mar 19 04:23:18 1997
---- src/Makefile.common Mon Sep 8 04:14:24 1997
-***************
-*** 20,26 ****
- fpp: $(OBJ) $(OBJ1) $(EXTRA_LIB)
- $(CC) $(COPTS) -o $@ $(OBJ) $(OBJ1) $(EXTRA_LIB)
-
-! $(OBJ): $$(@:%.o=$(SRC)/%.c)
- $(CC) -c $(ALL_OPTS) $(@:%.o=$(SRC)/%.c)
-
- y.tab.o: y.tab.c
---- 20,26 ----
- fpp: $(OBJ) $(OBJ1) $(EXTRA_LIB)
- $(CC) $(COPTS) -o $@ $(OBJ) $(OBJ1) $(EXTRA_LIB)
-
-! $(OBJ): #$$(@:%.o=$(SRC)/%.c)
- $(CC) -c $(ALL_OPTS) $(@:%.o=$(SRC)/%.c)
-
- y.tab.o: y.tab.c
-***************
-*** 34,41 ****
- lint: $(LINTFILES)
- $(LINT) $(LINTFILES)
-
-! $(LINTFILES): $$(@:%.ln=$(SRC)/%.c)
-! $(LINT) $(LOPTS) $(EXTRA_DEF) $(EXTRA_INC) $(@:%.ln=$(SRC)/%.c)
-
- clean:
- $(RM) fpp *.o y.tab.c $(LINTFILES)
---- 34,41 ----
- lint: $(LINTFILES)
- $(LINT) $(LINTFILES)
-
-! #$(LINTFILES): $$(@:%.ln=$(SRC)/%.c)
-! # $(LINT) $(LOPTS) $(EXTRA_DEF) $(EXTRA_INC) $(@:%.ln=$(SRC)/%.c)
-
- clean:
- $(RM) fpp *.o y.tab.c $(LINTFILES)
+--- src/Makefile.common.orig Tue Mar 18 21:23:18 1997
++++ src/Makefile.common Mon Oct 21 14:08:06 2002
+@@ -20,7 +20,7 @@
+ fpp: $(OBJ) $(OBJ1) $(EXTRA_LIB)
+ $(CC) $(COPTS) -o $@ $(OBJ) $(OBJ1) $(EXTRA_LIB)
+
+-$(OBJ): $$(@:%.o=$(SRC)/%.c)
++$(OBJ): #$$(@:%.o=$(SRC)/%.c)
+ $(CC) -c $(ALL_OPTS) $(@:%.o=$(SRC)/%.c)
+
+ y.tab.o: y.tab.c
+@@ -34,8 +34,8 @@
+ lint: $(LINTFILES)
+ $(LINT) $(LINTFILES)
+
+-$(LINTFILES): $$(@:%.ln=$(SRC)/%.c)
+- $(LINT) $(LOPTS) $(EXTRA_DEF) $(EXTRA_INC) $(@:%.ln=$(SRC)/%.c)
++#$(LINTFILES): $$(@:%.ln=$(SRC)/%.c)
++# $(LINT) $(LOPTS) $(EXTRA_DEF) $(EXTRA_INC) $(@:%.ln=$(SRC)/%.c)
+
+ clean:
+ $(RM) fpp *.o y.tab.c $(LINTFILES)
diff --git a/devel/fpp/files/patch-sparc::Makefile b/devel/fpp/files/patch-sparc::Makefile
new file mode 100644
index 000000000000..f42a2962ba19
--- /dev/null
+++ b/devel/fpp/files/patch-sparc::Makefile
@@ -0,0 +1,17 @@
+
+$FreeBSD$
+
+--- sparc/Makefile.orig Tue Mar 18 21:23:25 1997
++++ sparc/Makefile Mon Oct 21 14:10:57 2002
+@@ -1,8 +1,8 @@
+ SRC = ../src
+
+-CC = gcc
+-COPTS = -ansi -O -w
+-EXTRA_DEF = "-DRELEASE=\"v1.1\""
++CC ?= gcc
++COPTS = -ansi -w ${CFLAGS}
++EXTRA_DEF = "-DRELEASE=\"v1.1\"" -I../src
+
+ all: fpp
+
-06-17 02:45:03 +0800'>2013-06-171-2187/+2179 * Updated Lithuanian translationAurimas Černius2013-06-131-2172/+2205 * Updated Spanish translationDaniel Mustieles2013-06-121-237/+266 * Updated Galician translationsFran Diéguez2013-06-101-205/+233 * Add EMailPrintConfigHeaders.Matthew Barnes2013-06-081-0/+1 * EMailPartHeaders: Add a "default-headers" property.Matthew Barnes2013-06-081-0/+1 * Bug #555130 - Redesign task editorMilan Crha2013-06-061-2/+0 * Updated Spanish translationDaniel Mustieles2013-06-061-37/+56 * Updated Galician translationsFran Diéguez2013-06-061-387/+425 * Updated Spanish translationDaniel Mustieles2013-06-061-142/+176 * Updated Marathi TranslationsSandeep Sheshrao Shedmake2013-06-051-5434/+5771 * Updated Greek translationDimitris Spingos2013-06-051-1041/+1051 * Added Aragonese translationJorge Pérez Pérez2013-06-052-0/+21404 * Updated Slovenian translationMatej Urbančič2013-06-041-868/+859 * Updated Spanish translationDaniel Mustieles2013-06-031-284/+278 * Updated Norwegian bokmål translationKjartan Maraas2013-06-031-283/+247 * Remove deleted fileKjartan Maraas2013-06-031-1/+0 * Updated Galician translationsFran Diéguez2013-06-021-942/+938 * l10n: Update Japanese translationJiro Matsuzawa2013-05-311-3/+3 * Updated Odia Translation.ManojKumar Giri2013-05-301-1177/+801 * Updated Norwegian bokmål translationKjartan Maraas2013-05-281-227/+177 * Updated Spanish translationDaniel Mustieles2013-05-271-40/+36 * Tamil Translation UpdatedShantha kumar2013-05-271-1869/+2378 * Updated Spanish translationDaniel Mustieles2013-05-241-752/+745 * Updated gujarati fileSweta Kothari2013-05-24