aboutsummaryrefslogtreecommitdiffstats
path: root/math/geogram/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/geogram/Makefile')
-rw-r--r--math/geogram/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/math/geogram/Makefile b/math/geogram/Makefile
index 9b548488d1c8..657cf8f03b74 100644
--- a/math/geogram/Makefile
+++ b/math/geogram/Makefile
@@ -1,10 +1,9 @@
# $FreeBSD$
PORTNAME= geogram
-DISTVERSION= 1.6.11
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.7.1
CATEGORIES= math
-MASTER_SITES= https://gforge.inria.fr/frs/download.php/file/37934/
-DISTNAME= ${PORTNAME}_${DISTVERSION}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Programming library of geometric algorithms
@@ -15,6 +14,8 @@ LICENSE_FILE= ${WRKSRC}/doc/devkit/license.dox
LIB_DEPENDS= libglfw.so:graphics/glfw
USES= cmake gl localbase:ldflags
+USE_GITHUB= yes
+GH_ACCOUNT= alicevision
USE_XORG= x11 xcursor xi xinerama xrandr xxf86vm
USE_GL= gl glu
USE_LDCONFIG= yes
@@ -23,7 +24,4 @@ CMAKE_ON= GEOGRAM_USE_SYSTEM_GLFW3 VORPALINE_BUILD_DYNAMIC
CMAKE_ARGS= -DVORPALINE_PLATFORM:STRING=FreeBSD
LDFLAGS+= -pthread
-post-stage:
- @${RMDIR} ${STAGEDIR}${PREFIX}/include/geogram1/geogram_gfx/glup_viewer/colormaps
-
.include <bsd.port.mk>