aboutsummaryrefslogtreecommitdiffstats
path: root/math/geogram
diff options
context:
space:
mode:
Diffstat (limited to 'math/geogram')
-rw-r--r--math/geogram/Makefile10
-rw-r--r--math/geogram/distinfo6
-rw-r--r--math/geogram/files/patch-src_lib_geogram__gfx_glup__viewer_glup__viewer.c16
-rw-r--r--math/geogram/pkg-plist43
4 files changed, 30 insertions, 45 deletions
diff --git a/math/geogram/Makefile b/math/geogram/Makefile
index 9b548488d1c8..657cf8f03b74 100644
--- a/math/geogram/Makefile
+++ b/math/geogram/Makefile
@@ -1,10 +1,9 @@
# $FreeBSD$
PORTNAME= geogram
-DISTVERSION= 1.6.11
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.7.1
CATEGORIES= math
-MASTER_SITES= https://gforge.inria.fr/frs/download.php/file/37934/
-DISTNAME= ${PORTNAME}_${DISTVERSION}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Programming library of geometric algorithms
@@ -15,6 +14,8 @@ LICENSE_FILE= ${WRKSRC}/doc/devkit/license.dox
LIB_DEPENDS= libglfw.so:graphics/glfw
USES= cmake gl localbase:ldflags
+USE_GITHUB= yes
+GH_ACCOUNT= alicevision
USE_XORG= x11 xcursor xi xinerama xrandr xxf86vm
USE_GL= gl glu
USE_LDCONFIG= yes
@@ -23,7 +24,4 @@ CMAKE_ON= GEOGRAM_USE_SYSTEM_GLFW3 VORPALINE_BUILD_DYNAMIC
CMAKE_ARGS= -DVORPALINE_PLATFORM:STRING=FreeBSD
LDFLAGS+= -pthread
-post-stage:
- @${RMDIR} ${STAGEDIR}${PREFIX}/include/geogram1/geogram_gfx/glup_viewer/colormaps
-
.include <bsd.port.mk>
diff --git a/math/geogram/distinfo b/math/geogram/distinfo
index 8d05c12e1c67..1640d62d6515 100644
--- a/math/geogram/distinfo
+++ b/math/geogram/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1556957125
-SHA256 (geogram_1.6.11.tar.gz) = 5d823eb8bc3b34cc5c7abd78320a81e7e79ae16374a9706a7069d53ca032caf6
-SIZE (geogram_1.6.11.tar.gz) = 10287048
+TIMESTAMP = 1567315726
+SHA256 (alicevision-geogram-v1.7.1_GH0.tar.gz) = cf0b7fba482407b650d1f494ee18dcf6744afbfdcd7028d28975ab60c44b9455
+SIZE (alicevision-geogram-v1.7.1_GH0.tar.gz) = 9921323
diff --git a/math/geogram/files/patch-src_lib_geogram__gfx_glup__viewer_glup__viewer.c b/math/geogram/files/patch-src_lib_geogram__gfx_glup__viewer_glup__viewer.c
deleted file mode 100644
index 7eefdca72872..000000000000
--- a/math/geogram/files/patch-src_lib_geogram__gfx_glup__viewer_glup__viewer.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/lib/geogram_gfx/glup_viewer/glup_viewer.c.orig 2018-12-09 17:49:50 UTC
-+++ src/lib/geogram_gfx/glup_viewer/glup_viewer.c
-@@ -64,11 +64,11 @@
- #include <png/png.h>
- #endif
-
--#ifndef __APPLE__
-+#if !defined(__APPLE__) && !defined(__FreeBSD__)
- #include <malloc.h>
- #endif
-
--#if defined(__APPLE__) || defined(__linux__) || defined(__EMSCRIPTEN__)
-+#if defined(__APPLE__) || defined(__linux__) || defined(__FreeBSD__) || defined(__EMSCRIPTEN__)
- #include <unistd.h>
- static void glup_viewer_pause() {
- usleep(1000);
diff --git a/math/geogram/pkg-plist b/math/geogram/pkg-plist
index 62199e02a869..0926d60b4c41 100644
--- a/math/geogram/pkg-plist
+++ b/math/geogram/pkg-plist
@@ -1,11 +1,14 @@
bin/geobox
bin/geocod
bin/geodump
+bin/geogram_demo_Application
bin/geogram_demo_Delaunay2d
bin/geogram_demo_Delaunay3d
bin/geogram_demo_Evert
bin/geogram_demo_GLUP
bin/geogram_demo_Raytrace
+bin/geogram_demo_SimpleApplication
+bin/geoshade
bin/vorpalite
bin/vorpaview
include/geogram1/geogram/NL/nl.h
@@ -24,6 +27,7 @@ include/geogram1/geogram/NL/nl_private.h
include/geogram1/geogram/NL/nl_superlu.h
include/geogram1/geogram/api/defs.h
include/geogram1/geogram/basic/algorithm.h
+include/geogram1/geogram/basic/android_wrapper.h
include/geogram1/geogram/basic/argused.h
include/geogram1/geogram/basic/assert.h
include/geogram1/geogram/basic/atomics.h
@@ -116,6 +120,7 @@ include/geogram1/geogram/numerics/predicates/.pck.h
include/geogram1/geogram/numerics/predicates/aligned3d.h
include/geogram1/geogram/numerics/predicates/det3d.h
include/geogram1/geogram/numerics/predicates/det4d.h
+include/geogram1/geogram/numerics/predicates/det_compare_4d.h
include/geogram1/geogram/numerics/predicates/dot3d.h
include/geogram1/geogram/numerics/predicates/dot_compare_3d.h
include/geogram1/geogram/numerics/predicates/orient2d.h
@@ -140,6 +145,7 @@ include/geogram1/geogram/points/co3ne.h
include/geogram1/geogram/points/colocate.h
include/geogram1/geogram/points/kd_tree.h
include/geogram1/geogram/points/nn_search.h
+include/geogram1/geogram/points/principal_axes.h
include/geogram1/geogram/third_party/HLBFGS/HLBFGS.h
include/geogram1/geogram/third_party/HLBFGS/HLBFGS_BLAS.h
include/geogram1/geogram/third_party/HLBFGS/ICFS.h
@@ -203,6 +209,7 @@ include/geogram1/geogram/third_party/stb_image/stb_image.h
include/geogram1/geogram/third_party/stb_image/stb_image_write.h
include/geogram1/geogram/third_party/tetgen/tetgen.h
include/geogram1/geogram/third_party/triangle/triangle.h
+include/geogram1/geogram/third_party/xatlas/xatlas.h
include/geogram1/geogram/third_party/zlib/crc32.h
include/geogram1/geogram/third_party/zlib/deflate.h
include/geogram1/geogram/third_party/zlib/gzguts.h
@@ -265,7 +272,6 @@ include/geogram1/geogram_gfx/GLUP/shaders/fullscreen/blur_fragment_shader.h
include/geogram1/geogram_gfx/GLUP/shaders/fullscreen/depth_dependent_blur_fragment_shader.h
include/geogram1/geogram_gfx/GLUP/shaders/fullscreen/unsharp_masking_fragment_shader.h
include/geogram1/geogram_gfx/GLUP/shaders/fullscreen/vertex_shader.h
-include/geogram1/geogram_gfx/ImGui_ext/file_dialog.h
include/geogram1/geogram_gfx/ImGui_ext/icon_font.h
include/geogram1/geogram_gfx/ImGui_ext/imgui_ext.h
include/geogram1/geogram_gfx/api/defs.h
@@ -276,28 +282,25 @@ include/geogram1/geogram_gfx/basic/frame_buffer_object.h
include/geogram1/geogram_gfx/full_screen_effects/ambient_occlusion.h
include/geogram1/geogram_gfx/full_screen_effects/full_screen_effect.h
include/geogram1/geogram_gfx/full_screen_effects/unsharp_masking.h
-include/geogram1/geogram_gfx/glup_viewer/glup_viewer.h
-include/geogram1/geogram_gfx/glup_viewer/glup_viewer_gui.h
-include/geogram1/geogram_gfx/glup_viewer/glup_viewer_gui_private.h
+include/geogram1/geogram_gfx/gui/application.h
+include/geogram1/geogram_gfx/gui/arc_ball.h
+include/geogram1/geogram_gfx/gui/command.h
+include/geogram1/geogram_gfx/gui/console.h
+include/geogram1/geogram_gfx/gui/events.h
+include/geogram1/geogram_gfx/gui/gui_state.h
+include/geogram1/geogram_gfx/gui/gui_state_bigfont_h.h
+include/geogram1/geogram_gfx/gui/gui_state_bigfont_v.h
+include/geogram1/geogram_gfx/gui/simple_application.h
+include/geogram1/geogram_gfx/gui/simple_mesh_application.h
+include/geogram1/geogram_gfx/gui/status_bar.h
+include/geogram1/geogram_gfx/gui/text_editor.h
include/geogram1/geogram_gfx/lua/lua_glup.h
-include/geogram1/geogram_gfx/lua/lua_glup_viewer.h
include/geogram1/geogram_gfx/lua/lua_imgui.h
+include/geogram1/geogram_gfx/lua/lua_simple_application.h
include/geogram1/geogram_gfx/mesh/mesh_gfx.h
-include/geogram1/geogram_gfx/third_party/ImGui/OLD/glup_compat.h
-include/geogram1/geogram_gfx/third_party/ImGui/OLD/imconfig.h
-include/geogram1/geogram_gfx/third_party/ImGui/OLD/imgui.h
-include/geogram1/geogram_gfx/third_party/ImGui/OLD/imgui_impl_android.h
-include/geogram1/geogram_gfx/third_party/ImGui/OLD/imgui_impl_glfw.h
-include/geogram1/geogram_gfx/third_party/ImGui/OLD/imgui_impl_opengl3.h
-include/geogram1/geogram_gfx/third_party/ImGui/OLD/imgui_impl_win32.h
-include/geogram1/geogram_gfx/third_party/ImGui/OLD/imgui_internal.h
-include/geogram1/geogram_gfx/third_party/ImGui/OLD/imstb_rectpack.h
-include/geogram1/geogram_gfx/third_party/ImGui/OLD/imstb_textedit.h
-include/geogram1/geogram_gfx/third_party/ImGui/OLD/imstb_truetype.h
include/geogram1/geogram_gfx/third_party/ImGui/glup_compat.h
include/geogram1/geogram_gfx/third_party/ImGui/imconfig.h
include/geogram1/geogram_gfx/third_party/ImGui/imgui.h
-include/geogram1/geogram_gfx/third_party/ImGui/imgui_impl_android.h
include/geogram1/geogram_gfx/third_party/ImGui/imgui_impl_glfw.h
include/geogram1/geogram_gfx/third_party/ImGui/imgui_impl_opengl3.h
include/geogram1/geogram_gfx/third_party/ImGui/imgui_impl_win32.h
@@ -305,7 +308,6 @@ include/geogram1/geogram_gfx/third_party/ImGui/imgui_internal.h
include/geogram1/geogram_gfx/third_party/ImGui/imstb_rectpack.h
include/geogram1/geogram_gfx/third_party/ImGui/imstb_textedit.h
include/geogram1/geogram_gfx/third_party/ImGui/imstb_truetype.h
-include/geogram1/geogram_gfx/third_party/ImGuiColorTextEdit/OLD/TextEditor.h
include/geogram1/geogram_gfx/third_party/ImGuiColorTextEdit/TextEditor.h
include/geogram1/geogram_gfx/third_party/glad/KHR/khrplatform.h
include/geogram1/geogram_gfx/third_party/glad/glad.h
@@ -319,9 +321,10 @@ include/geogram1/geogram_gfx/third_party/quicktext/glQuickText.h
lib/cmake/modules/FindGeogram.cmake
lib/libgeogram.so
lib/libgeogram.so.1
-lib/libgeogram.so.1.6.11
+lib/libgeogram.so.1.7.1
lib/libgeogram_gfx.so
lib/libgeogram_gfx.so.1
-lib/libgeogram_gfx.so.1.6.11
+lib/libgeogram_gfx.so.1.7.1
libdata/pkgconfig/geogram1.pc
libdata/pkgconfig/geogram_gfx1.pc
+@dir include/geogram1/geogram_gfx/gui/colormaps